Cosas de Administradores

Error al actualizar versión de moodle

 
Imagen de Alfonso lopez
Error al actualizar versión de moodle
 


Error al actualizar versión de moodle, en la sección de  Comprobaciones del servidor

Me manda que revise este problema versión 3.1 es obligatoria y está ejecutando 2.5.8 (Build: 20140908)

Error al actualizar moodle


 
Promedio de calificaciones: -
Imagen de Jose Luis Martin Jimenez
Re: Error al actualizar versión de moodle
Moodlers de gran ayuda

No es un error, sino un aviso.

Te está diciendo que no puedes actualizar directamente desde tu versión 2.5.8 actual a la versión 3.5.1+.

Como te dice el mensaje, primero tendrás que actualizar desde la versión 2.5.8 a la versión 3.1.x (la última creo que es la 3.1.13). Eso lo puedes hacer en un solo paso.

Después, cuando ya tengas tu Moodle correctamente funcionando en la versión 3.1.x, podrás realizar otra actualización hasta la 3.5.1+

Por supuesto, recuerda hacer copias de seguridad de todo (B.D. y carpeta moodledata) antes de comenzar, y antes de cada paso, comprobar que cumples los requisitos en cuanto a PHP, MySQL (u otro tipo de B.D. que estés usando), actualizaciones de plugins no estándar, etc.

Saludos.

 
Promedio de calificaciones:Útil (1)
Imagen de Juan Pablo Miranda Aguayo
Re: Error al actualizar versión de moodle
Moodlers de gran ayuda

Hola Alfonso,

Para actualizar a 3.5.1+ debes hacerlo desde 3.1

Pero para actualizar a 3.1, debes hacerlo desde 2.7

Por tanto, en tu caso, para poder actualizar a 3.5.1+ desde 2.5.8, debes actualizar primero a 2.7.20, luego a 3.1.13 y entonces a 3.5.1+

Aquí tienes el enlace a 2.7.20: https://download.moodle.org/releases/legacy/

Aquí el de 3.1.13: https://download.moodle.org/releases/security/

Aquí a la versión más reciente: https://download.moodle.org/releases/latest/

Por otro lado, también es importante instalar la extensión OPcache de PHP según te indica la otra advertencia.

Aquí puedes encontrar información: http://php.net/manual/es/opcache.installation.php

Un saludo

JP

 
Promedio de calificaciones:Útil (2)
Imagen de Jose Luis Martin Jimenez
Re: Error al actualizar versión de moodle
Moodlers de gran ayuda

Tienes razón, Juan Pablo, no me había acordado de que para pasar a 3.1 es necesario primero llegar a la 2.7.

Saludos.

 
Promedio de calificaciones: -
Imagen de Alfonso lopez
Re: Error al actualizar versión de moodle
 
Gracias por su apoyo, lo haré y les aviso.

Saludos.



El jue., 26 de jul. de 2018 a la(s) 03:20, Jose Luis Martin Jimenez (vía
 
Promedio de calificaciones: -