Installing and upgrading help

version 5.5.31 is required and you are running 5.5.5.10.1.29.6

 
Picture of Jordan Young
version 5.5.31 is required and you are running 5.5.5.10.1.29.6
 

Please help!

Running Ubuntu 18. Moodle 3.3.5+ (Build: 20180515)

mysql (5.5.5-10.1.29-MariaDB-6)

Error - version 5.5.31 is required and you are running 5.5.5.10.1.29.6


Anyone know the Ubuntu commands to update this??

 
Average of ratings: -
Picture of Matteo Scaramuccia
Re: version 5.5.31 is required and you are running 5.5.5.10.1.29.6
Core developersParticularly helpful MoodlersPlugin developers

Hi Jordan,

sed -ri -e "s|\\$CFG->dbtype\s*=\s*'[^']+';|\\$CFG->dbtype = 'mariadb';|" /path/to/moodle/config.php

When you have installed Moodle you have selected MySQL instead of MariaDB wink.

More at https://moodle.org/mod/forum/discuss.php?d=362906#p1463526 .

HTH,
Matteo

 
Average of ratings: Useful (1)
Picture of Howard Miller
Re: version 5.5.31 is required and you are running 5.5.5.10.1.29.6
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

In the nicest way... that is the most geeky answer to that question I have ever seen tongueout

 
Average of ratings: -