Installing and upgrading help

Error when upgrading to 3.4

 
Picture of Irith Herman
תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: Error when upgrading to 3.4
 

I want to turn on the debugger and I cant

 
Average of ratings: -
Picture of Howard Miller
Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: Error when upgrading to 3.4
Core developersDocumentation writersParticularly helpful MoodlersPlugin developers

If you read Debugging you can get more information. You can copy the debugging lines from config-dist.php to config.php and uncomment them.

However, it's very unlikely that the Error 500 was not logged *anywhere*. You would need to tell us what operating system you are running and what web server. Personally I would go back to your server admin. A server that throws an Error 500 and does not log it is not set up properly. 

 
Average of ratings: -
Picture of Ken Task
Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: תשובה ל: Re: Error when upgrading to 3.4
Particularly helpful Moodlers

Pardon interruption ... Howard is quite capable in assisting, but thought this might help ...

Suggestion ... sometimes one can get directly to an admin area by using a URL upon initial access to the server.

Without trying to login, go to:

https://yoursite/admin/settings.php?section=debugging

replacing 'yoursite' above with your server URL.

That should prompt you to login and then forward you to the page for turning on debugging.

Once that's done, click on Site Admin menu link.

Catch 22 ... if your moodle is in the middle of a failed upgrade ... the above suggestion might not work.

It's the only way I know of without ssh cli access to server or cPanel text editor where one could edit the config.php file to put server in debug mode.

Best of luck!

'spirit of sharing', Ken


 
Average of ratings: Useful (1)