Instalación y Actualización

Actualización 2.6 a 3.4

 
Imagen de Valentina Miller
Actualización 2.6 a 3.4
 

Hola! Estoy usando Moodle 2.6 y quiero actualizar a 3.4. Alguien sabe cómo? Tengo entendido que primero tengo que actualizar a la versión 3.0 para finalmente poder actualizar a la 3.4. Es así? Gracias!!

 
Promedio de calificaciones: -
Imagen de Fernando Acedo
Re: Actualización 2.6 a 3.4
Desarrolladores de pluginsMoodlers de gran ayudaTesters

En la documentación de moodle tienes toda la información:

https://docs.moodle.org/all/es/Actualizaci%C3%B3n_de_moodle

 
Promedio de calificaciones:Útil (1)
Imagen de Adolfo Juárez Briones
Re: Actualización 2.6 a 3.4
Moodlers de gran ayuda

Saludos


Por experiencia te digo que si es preferible hacer los brincos necesarios para llegar a la versión que quieres, fíjate las versiones estables que tienes hacia adelante primero aplicalas y así sucesivamente para llegar ala version que quieres.


Lo demás como te mencionan esta en la documentación que ya te postearon.


Cuéntanos como te fue.



Bye

 
Promedio de calificaciones: -
Imagen de Jose Luis Martin Jimenez
Re: Actualización 2.6 a 3.4
Moodlers de gran ayuda

Hola, Valentina.

En cualquier caso, ya optes por ir paso a paso o dar el salto más grande, lo que tienes que tener en cuenta son los requisitos específicos para cada versión de Moodle (sobre todo, la versión de PHP y MySQL u otra base de datos que uses).

Por eso, antes de comenzar a hacer actualizaciones, te sugiero que utilices la herramienta que Moodle te facilita para saber hasta qué versión de Moodle está soportada con tu entorno actual, o los cambios que necesitarías hacer en tus servidores. Para eso, debes acceder a ...

Administración del sitio > Servidor > Entorno

En primer lugar haz clic donde pone "Actualizar componente" (habitualmente en la parte superior derecha).

Después de ello, ya puedes utilizar el menú desplegable para comprobar cada una de las versiones posteriores de Moodle, fijándote en si la columna "Estado" señala OK o pone "Revisar" ... lo que implicaría actualizar o instalar el elemento señalado.

Un saludo.

 
Promedio de calificaciones: -
180tic SAS
Re: Actualización 2.6 a 3.4
 

Hola Valentina.

Wow, es una actualización que tomará algo de tiempo, por experiencia te recomiendo hacer actualizaciones sucesivas desde la 2.6 hasta la versión 3.4. Alguna vez debí actualizar para una universidad desde la versión 6.4 hasta la 9.3, tenían más de 5000 usuarios registrados y debimos cerrar la plataforma por 8 días que nos tomó la actualización.

Antes, verifica si tu servidor o servicio de hosting cumple con los requisitos para la versión 3.4. Algunos servicios de hosting no permiten que pases bases de datos de Antelope a Barracuda y sin esto no te funcionará la versión 3.4. Has pruebas de instalación en otro directorio con la última versión para verificar que es posible instalarla en tu servidor y si todo sale bien ya puedes comenzar con la actualización.

Recuerda hacer una copia de seguridad de la base de datos y del directorio moodledata antes de iniciar la actualización.

Un abrazo y espero haber ayudado un poco.

 
Promedio de calificaciones: -