Instalación y Actualización

 
 
Picture of Isabel Martinez
Problemas al cargar /admin/index.php
 
Hola a todos, otra vez.

Continuo con el mismo problema. no consigo que se cargue la página. He instalado la versión 1.5.2 y le he creado una base de datos mysql nueva.
Cuando accedo al apartado administración para modificar alguna variable clico en el botón guardar y entonces cuando se tendria que carga la página /admin/index.php no lo hace, aparece en blanco.
Pero lo mejor del problema es que si actualizo la pagina que no se carga 4 o 5 veces seguidas al final se carga. asombro

Espero que alguien me pueda ayudar.

Gracias.

 
Average of ratings: -
Picture of Juan Raul Garcia Canet
Re: Problemas al cargar /admin/index.php
 
Hola Beatriz,
* Echa un vistazo al final del archivo config.php de tu moodle y comprueba que no hay espacios ni líneas en Blanco.
*Otra cosa que puedes comprobar es que tengas la variable "secureforms" desactivada en la sección Configuración->Variables del sitio
Espero que esto te sirva. Ya me cuentas.
Salu2.
J. Raúl
 
Average of ratings: -
Picture of Isabel Martinez
Re: Problemas al cargar /admin/index.php
 
Gracias, pero no es nada de lo que me has dicho, todo esta bien.

He intentado volver a instalarlo pero no acaba la instalación cuando está acabando y tiene que cargar la página /admin/index.php, no lo hace.

Espero que alguien me pueda dar más pistas sobre que és.
La base de datos que utilizo es mysql, y lo estoy instalando en un servidor debian.

Ya os iré informando de mis logros ( si es que hay alguno).
Saludos.
 
Average of ratings: -
Picture of Juan Raul Garcia Canet
Re: Problemas al cargar /admin/index.php
 
Hola Beatriz,
He estado siguiendo la instalación de Moodle y según el punto en que dices que se para corresponde al fichero "index.php" del directorio principal de moodle. allí pide tres ficheros:
    require_once('config.php');
    require_once($CFG->dirroot .'/course/lib.php');
    require_once($CFG->dirroot .'/lib/blocklib.php');
Como parace que no te da ningún error (o al menos no los has indicado), yo creo que el problema lo debes tener en:
  - Alguna parte del fichero "config.php"
  - Permisos del directorio moodle
Yo tengo mi moodle instalado en una Debian 3.1 y recuerdo que me pasó algo similar. Al final resultó que tenía un ";" de más en una de las líneas del config.php.
¿Podrías poner un extracto de tu config.php?
Así podríamos ver si se te ha pasado algo por al alto.
En fin, espero que ahora esto sí te sirva.
Salu2.
J. Raúl.
 
Average of ratings: -
Picture of Isabel Martinez
Re: Problemas al cargar /admin/index.php
 
Aqui esta el config.php

<?php  /// Moodle Configuration File
unset($CFG);
$CFG->dbhost = 'localhost';
$CFG->dbname = 'testmoodle';
$CFG->dbuser = 'testmoodle';
$CFG->dbpass = 'test';
$CFG->dbpersist = false;
$CFG->prefix = 'mdl_';
$CFG->wwwroot = 'http://10.40.65.2/projectes/moodle';
$CFG->dirroot = '/var/www/projectes/moodle';
$CFG->dataroot = '/var/www/projectes/moodledata';
$CFG->admin = 'admin';
$CFG->directorypermissions = 00777; // try 02777 on a server in Safe Mode
require_once("$CFG->dirroot/lib/setup.php");
// MAKE SURE WHEN YOU EDIT THIS FILE THAT THERE ARE NO SPACES, BLANK LINES,
// RETURNS, OR ANYTHING ELSE AFTER THE TWO CHARACTERS ON THE NEXT LINE.
?>

Que permisos tendrian que tener la carpeta moodle??
No he tocado nada de los permisos.



 
Average of ratings: -
Picture of Juan Raul Garcia Canet
Re: Problemas al cargar /admin/index.php
 
Hola Beatriz,
mi directorio moodle tiene permisos 0777, además en mi config.php tengo :
     $CFG->directorypermissions = 02777; (prueba con esto)
Tal vez sea por el 2 que tengo en los permisos del directorio. Pruébalo a ver si es eso.
Prueba también a escribir directamente en el navegador la dirección de tu sitio:
a ver si te da algun tipo de error.
Y por último comprueba en los logs de Apache si apartece algun tipo de error del servidor (a veces es muy útil comprobar los logs de Apache para detectar errores)
NOTA: Por cierto, ¿ese es tu config completo?
es que veo que falta una línea del tipo:
$CFG->dbtype    = 'mysql';       // mysql or postgres7 (for now)
De momento no se me ocurre ningún sitio más para la configuración dónde puedas mirar. Espero que ahora sí te vaya.
Siento mucho no poder ayudarte más.
Salu2.
J.Raúl.
 
Average of ratings: -
Picture of Isabel Martinez
Re: Problemas al cargar /admin/index.php
 
Hola otra vez, no hay manera de que vaya bien, aaaah !!!!

La página continua sin cargarse, en ningún momento da ningun error, ni en el log de Apache.
He mirado los permisos y los he puesto tal como has dicho, la varialble directoypermissions tambien,
el config.php que tengo contiene $CFG->dbtype    = 'mysql'; por lo tanto no se lo qu puede hacer.
Te vuelvo a esplicar el problema porque quizás no quedo muy claro:
    El moodle 1.5.2 que he instalado funciona correctamente, puedes navegar por sus opciones crear cursos... el único problema que tengo es que cuando voy a configuración -> Administración y se tiene que cargar la página http://10.40.65.2/projectes/moodle/admin/index.php   no la hace, la página se queda en blanco y no da ningún tipo de error.
Y si en esta página haces actualizar (con el navegardor) 5 o 6 veces seguidas al final carga la página.

En el mismo servidor tengo otra la versión 1.5 del moodle instalado que funciona correctamete, esta versión utiliza una base de datos diferente a la del moodle 1.5.2 y el nombre de las coockis tambien es diferente.

Por lo tanto deduzco que no es problema del servidor sino del la versión del moodle.

Espero que alguien me pueda ayudar, gracias.


 
Average of ratings: -
Picture of Antonio Gracia
Re: Problemas al cargar /admin/index.php
 
Yo he tenido el mismo problema. Lo he creado en localhost (http://localhost/.....), después de mucho probrar, se me ocurrió que en el momento de la instalación acceder no como localhost, sino como 127.0.0.1 y funcionó perfectamente.
Espero que te ayude smile
 
Average of ratings: -