Wiki

Uploaded pictures not saving consistantly in Wiki

 
John Provasnik at Moodle Moot US
Uploaded pictures not saving consistantly in Wiki
Particularly helpful Moodlers
I am having issues with Moodle 2.6 and Wikis. Uploaded images are just not consistently sticking.

Students insert an image (images) in the page of their Wiki. They show up fine at first. Student saves the page and all seems fine. However, when they return a day or so later to their page, their picture is no longer there. Students are blaming each other for deleting their pictures. Using a Wiki has been a complete disaster as the reason for using a wiki is to foster collaboration. Instead, I have several angry students and parents. After viewing the Wiki forum it seems this is an issue that is affecting more than just me.

Has there been any resolution to this issue? I really want to continue using Wikis, but if there is no resolution, my principal wants them to be removed from the class.

I have looked at two or three Moodle trackers, but they all seem to get closed since the issue cannot be reproduced. I'm not sure if I should open up a new one or not. Fingers crossed someone out there can let me know what I can do to resolve this.
Thanks!!
 
Average of ratings: -
Picture of Sarah Oelker
Re: Uploaded pictures not saving consistantly in Wiki
 

Same here! Yes, please do start a new Tracker issue, I have excellent descriptions of the problem to add, and I was contemplating the same thing. 

We're running 2.6.2 and we've had this problem for over a year: the reports last fall that cmoore added were us, too. It's difficult to reproduce because it happens when there is a class all working in a wiki at the same time, but not when only one or two people are editing a wiki. This means it _looks_ fine when one or two staff test it out, but when students are getting close to deadlines they have their image links break and freak out and come banging on our doors. We're considering testing out OU Wiki as an alternative but we would far rather use the regular wiki if this bug can be chased down. 

Here's a roundup of the relevant links for the infamous draftfile.php bug



...on which you'll see us reporting the problem last fall around this time. We don't think it was ever fixed in 2.4. We're certainly still having it. 

John, please do open up a new tracker issue, I'll both add to it and encourage others who have had the problem to speak up. It's a leading source of frustration about our install right now, and we have faculty with a long history of wiki projects under our previous CMS and we need to find them a solution that behaves at deadline time.

Thanks!
 
Average of ratings: -
John Provasnik at Moodle Moot US
Re: Uploaded pictures not saving consistantly in Wiki
Particularly helpful Moodlers

Thanks. I've posted a tracker: https://tracker.moodle.org/browse/MDL-48371

 
Average of ratings: -