Installation help

 
 
Picture of Greg Holmes
webservice error
 

Using 2.6.1+ (Build: 20140131)

Trying to set up webservices. Trying to "add" an external service.

Upon clicking the Add button, I get this error:

 

Coding error detected, it must be fixed by a programmer: Request for an unknown renderer class core_webservice_renderer

 

Server info:

Database Version 5.1.72-cll
PHP Version 5.3.28
Web Server Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4

 
Average of ratings: -
Picture of Greg Holmes
Re: webservice error
 

Nobody has any ideas?

 

 
Average of ratings: -
Picture of Greg Holmes
Re: webservice error
 

I turned debug on and tried again.

Coding error detected, it must be fixed by a programmer: Request for an unknown renderer class core_webservice_renderer
More information about this error
Debug info: 
Error code: codingerror Stack trace: •line 299 of /lib/outputfactories.php: coding_exception thrown
•line 1500 of /lib/outputlib.php: call to theme_overridden_renderer_factory->get_renderer()
•line 779 of /lib/pagelib.php: call to theme_config->get_renderer()
•line 46 of /admin/webservice/service.php: call to moodle_page->get_renderer()

 

 

I searched the files of moodle-latest-26.

 

The string "webservice_renderer" is not found anywhere.

What could be wrong?  How do I fix this?

 
Average of ratings: -
Picture of Rick Jerz
Re: webservice error
Group Particularly helpful Moodlers

I do not know what you are trying to do, "webservices".  Might you be able to better explain?  I wonder if the lack of response is because some folks are like me, somewhat clueless. I am a bit of a novice at this Moodle stuff, so I apologize for not better understanding your need.  But I wish that I could help.

 
Average of ratings: -