General help

 
 
Picture of John Hughes
File Picker not showing for SCORM packages
 

Suddenly our system has developed a fault so that we can no longer add or update SCORM packages.  We believe this occurred after our last upgrade to 2.3.2.  We have just upgraded to the very latest version to try and fix it - and we still see the same fault.

When you go in and create a new SCORM package activity or go and update an existing one the file picker is not displayed. Instead the "circle of death" is displayed and it never completes.  I have included an attachment to show what we see.

It shold be noted that when we try "Adding a new file" reouirce to a course the file picker is shown.

Anyone any ideas on what is goong on and how we fix this??

John

 
Average of ratings: -
I Teach With Moodle
Re: File Picker not showing for SCORM packages
Group Testers

Shot in the dark

  • Purge all caches
  • Purge any opcode cache you may be using e.g APC
  • Purge any reverse proxy you may be using e.g varnish

Cheers,

Fred

 
Average of ratings: -
Picture of John Hughes
Re: File Picker not showing for SCORM packages
 

Thanks Fred

Tried that and it still does not work.

we have set up another VM with a new clean install - and that is fine. 

John

 

 
Average of ratings: -
Picture of John Hughes
Re: File Picker not showing for SCORM packages
 

We are still struggling this - and we have been trying to debug this as much as we can.

When we using the javascript console in Chrome we are seeing the below errors.  It looks like an issue with themes - of some sort.

Does a moodle developer have any idea what these errors mean?

John

 

  1. GET http://www.infosecskills.org/courses/lib/javascript.php/1358878580/lib/form/filepicker.js yui_combo.php:4791
    1. Transaction._insertyui_combo.php:4791
    2. Transaction.executeyui_combo.php:4547
    3. Y.Get.Get._nextyui_combo.php:4323
    4. Y.Get.Get._loadyui_combo.php:4306
    5. Y.Get.Get.jsyui_combo.php:4097
    6. Y.Loader._insertyui_combo.php:7697
    7. (anonymous function)yui_combo.php:7750
    8. Y.Loader._continueyui_combo.php:7733
    9. Y.Loader.insertyui_combo.php:7752
    10. handleLoaderyui_combo.php:976
    11. handleLoaderyui_combo.php:976
    12. Y.Loader._finishyui_combo.php:7411
    13. Y.Loader._onSuccessyui_combo.php:7456
    14. Y.Get.js.onSuccessyui_combo.php:7715
    15. Transaction._finishyui_combo.php:4624
    16. Transaction._nextyui_combo.php:4806
    17. Transaction._progressyui_combo.php:4913
  1. Uncaught TypeError: Cannot call method 'init' of undefined modedit.php:1569
    1. (anonymous function)modedit.php:1569
    2. proto._notifyyui_combo.php:836
    3. handleLoaderyui_combo.php:971
    4. Y.Loader._finishyui_combo.php:7411
    5. Y.Loader._onFailureyui_combo.php:7495
    6. Y.Get.js.onFailureyui_combo.php:7720
    7. Transaction._finishyui_combo.php:4621
    8. Transaction._nextyui_combo.php:4806
    9. Transaction._progressyui_combo.php:4913

 

 
Average of ratings: -
me
Re: File Picker not showing for SCORM packages
 

I've just started experiencing the exact same problem.

This is on a clean install which I started setting up a few days ago, everything worked fine until this afternoon, I don't believe I have changed anything which would affect this (server side or in moodle admin).

Moodle 2.5 (Build: 20130514)

We have other moddle instances on the same server which still function correctly.

I've also tried changing to the moodle standard theme and the problem persists.

Did you get any further with this problem John?

 
Average of ratings: -