Hotpot (add-on)

 
 
Picture of Martin Fischer
cloze : do not continue automatically option doesn´t work
 

I would like students to decide by themselves on how long they want to look at their hotpot-cloze exercise once they have completed it correctly. The option  Wait till student clicks ok is not quite satisfactory, because the “ok”-pop up window -  placed  in the very center of the screen - hides part of the exercise. The option Do not continue automatically - together with show stop button - seems to be a perfect solution, but option Do not continue automatically does not work with me, because the exercise gets closed almost instantaneously.

 

regards, Martin Fischer

 
Average of ratings: -
Picture of Glenys Hanson
Re: cloze : do not continue automatically option doesn´t work
 

Hi Martin,

I don't know why "Do not continue automatically" isn't working for you. On Moodle 1.9 it doesn't in the HotPot Module but it does on QuizPort. Gordon will need to know which version of Moodle you're on and whether you're using the HotPot Module, QuizPort or even TaskChain.

I can help with the feedback box, though. For the reasons you mention I always raise it.

On your computer, make a copy of the HotPot source folder and call it "boxup"or something like that. Open hp6showmessage.js_ in a text editor and in this part:

function ShowMessage(Feedback){
    var Output = Feedback + '<br /><br />';
    document.getElementById('FeedbackContent').innerHTML = Output;
    var FDiv = document.getElementById('FeedbackDiv');
    topZ++;
    FDiv.style.zIndex = topZ;
    FDiv.style.top = TopSettingWithScrollOffset(30) + 'px';

Change the 30 to a smaller value: 10 or 5.

Then select the source file as shown in the screenshots below and regenerate the exercise.

Cheers,

Glenys


 
Average of ratings: -
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Thanks Glenys,

of course you are right, I forgot to mention my versions. Here they are:

moodle 2.3.4; hotpot 6.03.4; hotpot module 2010080353

As I upload the  *.jcl file, I use the hotpot module´s sourcefiles.  With me, Do not continue automtically  works neiter in the standard HP6 format nor  with the Rottmeier-type dropdown source file.

I don´t have (easy) access our moodle site´s folders and files. 

reards, Martin

 
Average of ratings: -
Picture of Glenys Hanson
Re: cloze : do not continue automatically option doesn´t work
 

Hi Martin,

Maybe the Do not continue automatically doesn't work in the HotPot Module on Moodle 2 either. Try uploading the .htm file instead of the .jcl file.

It does work in TaskChain, see: White Chistmas - Bing Crosby. Even after you click OK at the end you can stay on the page as long as you want. You'll just have to be patient and wait for TaskChain to have its last buglets worked out. You'll see I'll be very busy in the coming weeks reporting little things to Gordon.

Can't manage to move the box up in TaskChain. Outside TaskChain, the feedback box covers Bing's face - not the exercise.

I can make it write the feedback to the Instruction field, though.

Cheers,

Glenys

 
Average of ratings: -
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Hi Glenys,

honestly, I am a bit confused about hotpot module, quiz port and task chain. I work with moodle 2.3xx and the latest hotpot module, I never used quiz port (should I ? Any advantages?) and I thought that Task Chain for moodle 2.xx hasn´t come out yet. I know that Gordon is working hard on the new Task Chain version which is supposed to substitute the hotpot module (and maybe also quiz port, I don´t know). Therefore, from what I understood, the best would be to continue with hotpot until Task Chain "2" is available. Am I right? What do you recommend me? Thanks.

cheers,

Martin 

 

 
Average of ratings: -
Picture of Glenys Hanson
Re: cloze : do not continue automatically option doesn´t work
 

Hi Martin,

It is a little confusing, isn't it? But you're right you should stay with the HotPot Module for the moment on your production site. QuizPort only works on Moodle 1.9 but TaskChain will do all QuizPort can do and more.

If you could test TaskChain and give Gordon feedback I know it would be welcome. The more people who do that the faster he'll finish it. You can down load it here: TaskChain module for Moodle 2.x

As I go along testing TaskChain, I write "tutorials" for myself - I'd be happy to share them.

Cheers,

Glenys

 
Average of ratings: -
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Hi Glenys

I am going to install TaskChain right away. And if you sent me your tutorials, I would be really grateful. 

Thanks a lot, 

Martin 

By the way, is it a good idea to install both modules - Hotpot and TaskChain - on the school´s moodle site? Any danger about that? Or should I rather test TaskChain on my local moodle site.

 
Average of ratings: -
Picture of Glenys Hanson
Re: cloze : do not continue automatically option doesn´t work
 

Hi Martin,

Here's my "tutorial" for what it's worth. You'll see I couldn't get some things to work. That's normal in the circumstances - I'll report them to Gordon.

I don't think there's any problem running the HotPot Module and TaskChain on the same server. Just don't make the the TaskChains available to students.

Cheers,

Glenys

 
Average of ratings: -
Picture of Gordon Bateson
Re: cloze : do not continue automatically option doesn´t work
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Glenys  - thanks for shraing your tutorials approve

Martin - thanks for reporting the fact that "Do not continue" does not work as expected. I will look into it and report back.

regards
Gordon

 
Average of ratings: -
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Glenys, thanks for the tutorial

Gordon, on my local moodle site 2.3XX  an activity with *.jcl+*.mp3 and *.jpg source files works fine if uploaded as a  Hotpot activity,  but not as TaskChain activity. Is this information of any use for you? And, by the way,  Is there any other forum to report Task chain testing affairs?

Nice weekend to all

Martin

 
Average of ratings: -
Picture of Glenys Hanson
Re: cloze : do not continue automatically option doesn´t work
 

Hi Martin,

This is the right forum: just put TaskChain in the subject of your message.

The other thing you can do that is helpful for Gordon is to upload a copy of the problem exercise to one of his testing sites. 2.4 is preferable because some things that were problematic in 2.3 have been ironed out in 2.4. But if you're stuck with 2.3, this is the site for you:

http://bateson.kanazawa-gu.ac.jp/23/
Username: guestteacher
Password: taskchainv09

Cheers,

Glenys

 
Average of ratings:Useful (1)
Picture of Gordon Bateson
Re: cloze : do not continue automatically option doesn´t work
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Hi Martin, Hi Glenys,
thanks for raising the issue of "Do not continue automatically" in the HotPot module for Moodle 2.x. It seems I had not implemented that function. Sorry about that.

I have now added the functionality to the HotPot module for moodle 2.x. I would be grateful if you could download the latest version of the module and check that it behaves as you expect now.

best regards
Gordon

 
Average of ratings: -
avatar
Re: cloze : do not continue automatically option doesn´t work
 

Hi Gordon,

I've upgraded to the latest HotPot module, and now I have a problem that didn't have before. My quizzes have the abanadon button, and now that button doesn't work properly, when click displays a blank page with the URL: ... / hotpot / submit.php.

To solve that problem I deleted these lines, in submit.php:

// redirect the browser (only if necessary)
if ($redirect = $hotpot->require_redirect()) {
    $hotpot->redirect($redirect); // script stops here
}

Please have a look to this issue.

Best regards,

Antonio


 
Average of ratings: -
Picture of Gordon Bateson
Re: cloze : do not continue automatically option doesn´t work
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Ah, sorry Antonio,
thanks for pointing this out.
I need to spend some more time on this.
I will look at it on Monday.
regards
Gordon

 
Average of ratings: -
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Hi Gordon,

I just updated to hotpot (3.0.55) + moodle 2.4.1, now hotpots won´t work any more when I want to abandon:

Fatal error: Call to undefined method stdClass::can_continue() in /home/moodle.eoivh.cat/moodle/mod/hotpot/locallib.php on line 2049

similar to Antonio´s problem, it seems.

regards

Martin Fischer

 

 
Average of ratings: -
Picture of Gordon Bateson
Re: cloze : do not continue automatically option doesn´t work
Group DevelopersGroup Particularly helpful MoodlersGroup Translators

Dear Antonio and Martin,

sorry for the delay. I have spent some time working on the STOP button and "Do not continue automatically". I think I have it working now. I would be grateful if you could donwload the latest version and check it works as expected with your HotPot activities.

best regards
Gordon

 
Average of ratings: -
avatar
Re: cloze : do not continue automatically option doesn´t work
 

Dear Gordon,

STOP button checked and it works properly.

As always, thank you very much for your effort in improving the HotPot module.

Best regards.

Antonio

 
Average of ratings:Useful (1)
Picture of Martin Fischer
Re: cloze : do not continue automatically option doesn´t work
 

Hi Gordon,

"Do not continue automatically" now works fine with my activities. smile

The "stop button", when activated, takes me back to the beginning of the exercise (entry page, in case there is one, or beginning of the quiz).  From Antonio´s post, I assume this is the way it is supposed to be (?).

As a matter of fact, the stop button seems to  serve quite well as a "retry"-button, something I always missed in hotpots.  

regards,

Martin Fischer 

 

 
Average of ratings: -