Roles and permissions

Users showing as participants but not in Assigned roles

 
 
Picture of Jon Breitenbucher
Users showing as participants but not in Assigned roles
 

When viewing the Participants list in any course (manually created or auto created via LDAP) it appears that the same set of 59 people are being listed even though they do not have any locally assigned role for the course. 14 of them are always listed as Teachers in Participants and 45 are listed as Students. The 14 "Teachers" are actually teachers in other course, as they should be, but do not have a System wide or Category wide role assignment. The same is true of the 45 users listed as "Students".

This issue is not just limited to the Participants block. The "Students" also appear in the Gradebook. All 59 appear in the Quickmail block (as maintained by CLAMP) and all 59 display in the Course description if the display of Teachers and Students is enabled in the settings for Course Managers.

Our configuration is authenticating against AD and our courses are being auto created from AD. We are running 1.9.18 with PHP 5.2.14 and mySQL 5.0.95. As I indicated no user has a system wide or category wide assignment to the Teacher or Student role. Also, when viewing the editing screen for any of these 59 people, the only courses listed are the ones where they have a locally assigned role of Student or Teacher. What should we be looking at to determine why these 59 people are appearing as participants and in the gradebook but do not have a locally assigned role or system wide role?

In the image the only participant that should be in the course on the right is Jon Breitenbucher and the participants on the left that are the same as the ones on the right are actually not enrolled in the course according to Assign Roles.

Thanks.


 
Average of ratings: -
Picture of Luis Alberto Molina Quintanilla
Re: Users showing as participants but not in Assigned roles
 

I have the same problem.

 
Average of ratings: -
Picture of Fabulous Phil
Re: Users showing as participants but not in Assigned roles
 
I also have the same problem
 
Average of ratings: -