I want to upgrade my moodle installation to 1.6. Blogs would be really great for what I'm doing with Moodle right now. Anyway, I'm hosting on LunarPages. They only offer servers with PHP 5.0.4 and PHP 4.4. In the upgrade docs it says to steer clear of both of those versions. They say (kindof adamantly) to use only 4.3.x or 5.1.x.
What sort of trouble should I expect with PHP 5.0.4 or PHP 4.4? Out of those two, which version should I pick? Am I guaranteed trouble or is it worth a try? Or am I stuck and I have to wait until Lunarpages adopts PHP 5.1? If I upgrade, what's the test to see if I'm having the dreaded issues? (What ever they are.)
Thanks In Advance for any advice.
Have found a similar problem on my VPS with IPowerweb. What happens when you try to install 1.6 with PHP 5.0.4 is that you get a fail message on the second screen which checks installation and then the installation stops. Mind you, we also had a MSQL version which was not up to it. So I had PostgreSQL installed but still the installation stopped with PHP 5.0.4 being the only stumbling block.
Our solution has been to upgrade the VPS to PHP 5.1.4 and MySQL 4.1.20. Still waiting for the job to be completed. Support at Ipowerweb has been very patchy. WHile you can do things as admin or root, there are no hints as to what you might break if you install components that Plesk (the control panel software) does not like.
With shared servers, you are really stuck with what you paid for. Virtual private server providers will make you pay extra but it can be done. Decicated servers and running your own are fine.
Sorry can't help with anything more constructive.
I have Moodle 1.6 running on a server with PHP 4.4.2. Frankly, I hadn't checked ahead of time and Moodle didn't complain about it during the install. I haven't done an awful lot with site yet--but I haven't had any problems so far!
On the download page for Moodle 1.6, it says PHP 4.3 or later.
Here is a quote from the Upgrade to 1.6 documentation:
Check the system requirements
Go to Administration >> Environment (in recent versions of Moodle 1.5) and choose Moodle 1.6 You will get a report of whether your server specs meet the requirements for Moodle 1.6 and what needs to be done. Basically you need PHP 4.3.0 or later (for PHP5, version 5.1.0 or later is required), and MySQL 4.1.16 or later (4.1.12 is ok if your site is latin-only) or PostgreSQL. Native iconv support in PHP will really speed things up too (it needs to be specified during compilation) but is not required.
You can use PHP 4.3.0 or newer, or PHP 5.1.0 or newer. I am not aware of any problems with PHP 4.4. (where did you read that there are problems?).
So, your answer is to go with 4.4 I guess
Upgrading (or downgrading) PHP often causes numerous problems with websites that are running PHP, for this reason it is not something we like to do often.
However, if you (or your software creator) can provide details of the 'number of problems' with PHP 5.0.x, and especially if those problems are related to security or functionality we will look at providing an upgrade.
Can you or anyone else point me in the direction of a list of the issues with 5.0.4 that I can send to support the case for an upgrade?
PS - let me know if there is a better place to post this request.
The best way to do this is to look at the PHP Changelog and look at the changes made in the 5.0.5 release (which fixes the bugs in 5.0.4). The bug fixes which jump out re security are the ones related to safe mode and sessions. There are some mysql ones also which forms part of the "functionality" requirements that your host has.
Possibly a repost in the developer forum may get you some very specific reasons.