Moodle for mobile

Error message "Invalid response value detected" when accessing quizzes from iOS mobile app

 
Picture of carl haynes
Error message "Invalid response value detected" when accessing quizzes from iOS mobile app
 

Hi all,

I am receiving the error message "Invalid response value detected" when trying to access quizzes (via a hyperlinked label) using the iOS mobile app but not from Android devices. But I can access the quiz when I go direct to the quiz (without the label hyperlink).


In a nutshell I have built a course using only labels which then link to videos, quizzes, documents etc that sit in the last topic in the course.  Once it is finished I shall orphan this topic so it is effectively hidden from view.  Everything works fine on desktops and android devices via the Moodle app.  The issues are with the iOS app as I have detailed above.


I'd be grateful for any help with this.  Everything seems to point an issue with the iOS app but you may think otherwise.


Thanks, Carl

 
Average of ratings: -
Picture of Juan Leyva
Re: Error message "Invalid response value detected" when accessing quizzes from iOS mobile app
Core developersMoodle HQParticularly helpful MoodlersPlugin developersTesters

Hi Carl,

is this a new error due to an update of the app, or has it been happening before?

Could you send us a backup of the course without user data to mobile@moodle.com so we can test?

Thanks, Juan

 
Average of ratings: -
Picture of carl haynes
Re: Error message "Invalid response value detected" when accessing quizzes from iOS mobile app
 

Hi Juan,

Thanks for getting back to me so quickly.  I can't say whether this is a new error or not as this is the first time that I've built a course using labels as shortcuts to activities.  I'm afraid I can't send a backup of the course as it is emblazoned with the clients details so I am not permitted to share.


The strange thing is that I am able to view external sites, documents, videos from a label with a hyperlink.  It is only when it comes to accessing a quiz via a hyperlink when it fails - but only with the iOS app.  The Android app works like a charm.  So the question is what is the iOS app doing differently?

BTW I have just installed the new iOS app 3.5.0 (version code 3501)


Thanks, Carl

 
Average of ratings: -