Assistance technique

Erreur blocks/lp pendant mise à jour vers version 3.4

 
Avatar AGOSTA Dominique
Erreur blocks/lp pendant mise à jour vers version 3.4
 

Bonjour

Suite à la mise à jour de Moodle en git de la version 3.3.3 vers la version 3.4 j'ai un message d'erreur qui m'empêche de finaliser : 

Le plugin « block/lp » est défectueux ou obsolète. Impossible de continuer.

Debug info: Missing main block class file.
Error code: detectedbrokenplugin
×Stack trace:
  • line 911 of /lib/upgradelib.php: plugin_defective_exception thrown
  • line 510 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
  • line 1850 of /lib/upgradelib.php: call to upgrade_plugins()
  • line 694 of /admin/index.php: call to upgrade_noncore()
Savez-vous comment sortir de ce problème ?

Merci


 
Moyenne des évaluations  -
Avatar AGOSTA Dominique
Re: Erreur blocks/lp pendant mise à jour vers version 3.4
 

Je me suis sorti de ce mauvais pas en récupérant le contenu du répertoire blocks/lp de la version Moodle 3.3.3 et en le mettant à jour avec les fichiers récupérés sur le site https://github.com/moodle/moodle/tree/master/blocks/lp.

En fait, seul le fichier version.php est différent.

J'ai aussi eu un problème avec le thème Boost... J'ai fait pareil et tout est rentré dans l'ordre.


Conclusion : je me suis un peu précipité pour cette dernière mise à jour de Moodle ! Cela me servira de leçon : la prochaine fois, j'attendrai quelques semaines...

 
Moyenne des évaluations  -