Configurable reports block (plugin)

Installation fail on Moodle 2.5+ (Build: 20130621)

 
 
Picture of A B
Installation fail on Moodle 2.5+ (Build: 20130621)
 

Hello,
I am fairly new to Moodle. I tried installing block_configurable_reports_moodle25_2011040105  on Moodle 2.5+ (Build: 20130621) (This is a fresh install of Moodle, directly cloned from official git). And I got the following error:block configurable reports error

If anyone can please explain the error and the way to fix, I'd really appreciate it.

 
Average of ratings: -
Picture of Marcus Green
Re: Installation fail on Moodle 2.5+ (Build: 20130621)
Group Particularly helpful Moodlers

The version.php file of configurable reports should have a line in it that says something like

$plugin->requires = xxxxxxxx;

Where xxxx is a series of digits

Check that against the version number of the Moodle install.

 

 
Average of ratings: -
Picture of A B
Re: Installation fail on Moodle 2.5+ (Build: 20130621)
 

This is what is on the version.php file:

$plugin->requires = 2010112400;

So, doesn't that mean the plugin will work on Moodle build 2010112400 and Newer.

 
Average of ratings: -
Picture of A B
Re: Installation fail on Moodle 2.5+ (Build: 20130621)
 

Just a quick update: the installation is working now. I installed it on another instance of moodle and it worked. So, I guess there was some conflict on the earlier instance of moodle in which I tried installing.

 
Average of ratings: -