Moodle for mobile

Cannot connect: the site must use Moodle 2.4 or later

 
 
Picture of M Horn
Cannot connect: the site must use Moodle 2.4 or later
 

I downloaded the official Mobile App on my Android phone and tried to connect to our test Moodle server running Moodle 2.4.4 (Build: 20130513), but received the error message: Cannot connect: the site must use Moodle 2.4 or later.

I have already checked "Enable mobile web services" under Settings > Site administration > Plugins > Web services > Mobile and have double-checked that the mobile web services automatically enabled all the necessary services.

 

Any suggestions?

 
Average of ratings: -
Mary Cooch
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Documentation writersGroup Moodle Course Creator Certificate holdersGroup Moodle HQGroup Particularly helpful MoodlersGroup TestersGroup Translators

If you look at #6 in Mobile Moodle FAQ it also mentions some sites using special authentication methods like Shibboleth, CAS or LDAP/SSO are currently  not supported - might that apply to yours?

 
Average of ratings: -
Picture of Eduardo Del Valle
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi,

the FAQ page you mention does not exist...

I am having the same problem, we use LDAP as our authentication provider and we are using 2.4.3+.

when connecting to the server, the authentication window appears and it has the spinner that stays there for ever.

Thanks,

 
Average of ratings: -
Picture of M Horn
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Eduardo - The correct Moodle Mobile FAQ URL is: http://docs.moodle.org/24/en/Mobile_Moodle_FAQ

 
Average of ratings: -
Picture of David Perry
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Particularly helpful MoodlersGroup Testers

I have LDAP on our test 2.4 install and the app lets me login with my LDAP details fine.

 
Average of ratings: -
Picture of M Horn
Re: Cannot connect: the site must use Moodle 2.4 or later
 

David - Which version of Moodle 2.4 are you currently running? (We're running Moodle 2.4.4 (Build: 20130513) )

 
Average of ratings: -
Picture of David Perry
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Particularly helpful MoodlersGroup Testers

It's 2.4.1+ (Build: 20130118) - yes pretty old.

I was thinking of updating it, but maybe I won't now. Our plan in summer is to move to the latest 2.4 build at the time, I'll set up a latest24 installation later on (or maybe tomorrow now) and test the app against it.

 
Average of ratings: -
Picture of David Perry
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Particularly helpful MoodlersGroup Testers

Update - I've installed the same build version as you, and the app is connecting fine.

 
Average of ratings: -
Picture of M Horn
Re: Cannot connect: the site must use Moodle 2.4 or later
 

I upgraded from 2.3.3+ to 2.4.4. I think I'll revert back to 2.3.3+ and then go to 2.4.1 (or even just 2.4) and see if it works then.

If that doesn't solve it, then I have no idea what could be the issue.

It is quite frustrating that there isn't any debug/error code to work from to determine what the issue is.

 
Average of ratings: -
Picture of M Horn
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Thank you, Mary. The error message (re: site not Moodle 2.4) did not really point to non-supported authentication methods in my mind.

We do, however, also have Manual Accounts enabled under "Available authentication plugins" in Moodle, but I still cannot log on with a manual account user. (Same error message).

Does that mean that, because we have LDAP as one of our available authentication plugins, that no other authentication method (e.g. manual, email based etc.) will work, rendering the app useless (for now)?

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi,

I'm the main developer of the app, if you can create a non-privileged account in your Moodle server I can try to log-in and debug the problem

You can send me the user credentials and your Moodle site URL via a private message.

Regards

 
Average of ratings: -
Picture of David Perry
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Particularly helpful MoodlersGroup Testers

Juan, it might be helpful if some of these ' why can't you connect' diagnostics could be built into the app? So you can find out what administrator settings need enabling. Probably including the 'can you access the site url' check, just in case someone's trying to access a site which is blocked by firewall.

Does the app facilitate connecting to sites on non-standard ports? I can't tinker with our live apache to find out myself (unless I want to get some grief from users anyway).

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Yes, we are getting a lot of negative review in Play Store because people try to use the app in any Moodle installation, and you know, it requires Moodle 2.4 and WebServices so people get frustatted because they can't connect and don't understand the reasons

I was thinking in a button at the bottom of the page like "Help! I can't connect" with some basic instructions

 
Average of ratings: -
Picture of David Perry
Re: Cannot connect: the site must use Moodle 2.4 or later
Group Particularly helpful MoodlersGroup Testers

That is a good idea.

Is there a way the app could detect which version of moodle it's trying to connect to? That would be a nice message, e.g. "you are trying to access moodle site that is an older version than this app supports" - clear enough.

 
Average of ratings: -
Picture of Guillaume Seraglini
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi,

 

I have the same issue. I downloaded the Moodle Mobile app for iOS to test and I have the same error.

 

I did the test on our test server, it has Moodle 2.4.2 installed. I enabled the mobile services option in Settings > site administration > Plugins > Web services > Mobile. It didn't work so I also enabled the same option in Settings > Site administration > Plugins >Web services > External services. And I also checked that the XML-RPC protocol was activated.

 

But nothing, I still get the error "the site must use Moodle 2.4 or later", but I'm using Moodle 2.4.2 so it should work, or at least not telling me to use Moodle 2.4 if I'm actually using it. I tried with a user using LDAP authentification and with another one using Manual authentification.

 

So if someone has any ideas, it would be nice.

 

Thanks a lot.

 

GK.

 
Average of ratings: -
Picture of Jairo Martinez
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi, I am having the same message. I am using ANDROID´s smartphone and the server is update to Moodle 2.5

No way for connecting.

Thanks

 

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

I just updated:

http://docs.moodle.org/24/en/Mobile_Moodle_FAQ#Moodle_Mobile_app_say_I_need_2.4_or_higher

Try to first Enable Web Services in Site Administration -> Advanced settings and then Enable Mobile Services

 
Average of ratings: -
Picture of Jairo Martinez
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Thanks Juan, both services were previously enabled. I am using just EMAIL CREATION, MANUAL CREATION and NO LOGIN as authenticathion methods.

Site was just created for testing this new facility before migrating the operational one. Almost all all environement were defined by default.

No way to connect to server from mobile yet.

 

Thanks for your support

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi, very strange, in order to perform further investigations  I would need a user a password in your Moodle installation (just an user without any course enrolled)

If is ok for you, you can send me the user credentials and your site url via a private message.

 
Average of ratings: -
Picture of Jairo Martinez
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Thanks Juan, please let me know your email, mine is jamardu@aprendizajevirtual.org

Regards, Jairo

 
Average of ratings: -
Picture of Jo Matthews
Re: Cannot connect: the site must use Moodle 2.4 or later
 

I'm having the same issue authenticating with both ldap and manual accounts.

we're using v243. I downloaded the app for android. Enable web services for mobile devices is enabled

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi Jo,

in this cases, I need access to your Moodle installation for doing some tests, if it's not a problem for you, I would need a user account in your Moodle site without any special privilege and not enrolled in any course.

If it's ok for you, you can send me the login information via a private message

Regards

 
Average of ratings: -
Picture of Arshad Hussanee
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi all, 

Anymore update i regards to this issue? We are running Moodle 2.5.3 - Iphone 5S login fine but but android Samsung note/S3 cannot. However, my android tablet asus transformer logged in fine. What going on there?

Shad

 
Average of ratings: -
Picture of stefan hoefler
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Maybe you can check via the chrome debug bridge which action is used by the login form? 

 
Average of ratings: -
Picture of Vani Bheemreddy
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hi Juan,

I have the same issue, for both manual and ldap users. For security reasons, i cannot share a user account with you. Is there anything that I could do to test/analyse this issue myself? Probably some settings that are missing? BTW The webservices and mobile webservices are enabled. 

When I access the site from the app on andriod, it automatically changes to http. And after that i cant login. The error '..Unable to log in...Check the URL...The site must be moodle 2.4 or above...' is on these lines. I have moodle 2.6.

When the site is accessed from a mobile browser, I get a certificate issue. If i proceed anyway, I am able to login to it and view all the courses just fine, but this certificate prompt makes the user skeptical from using the site. BTW there is a valid certificate signed by a trusted certificate authority.  

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi,

the app doesn't accept untrusted certificates (self-signed).

If your mobile browser displays a certificate issue, the app is not going to work.

You should change your site certificate by one trusted by the Android browser

Cheers, Juan

 
Average of ratings: -
Picture of Fuchur Kool
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Hey,

I have the following problem:

When I'm trying to login to our moodle server with the Moodle app from Appstore, then there is no problem. But when I compile the Moodle App of  Juan Levya and try to connect with this, I get the error...

 

Any suggestions?

 
Average of ratings: -
Picture of Fuchur Kool
Re: Cannot connect: the site must use Moodle 2.4 or later
 

Sorry for the double post but here is some more information!

The problem seems to be the building process. I tried to build the MM Master build and get the same error. Also if I try to login using the test server provided by moodle.

What I do when I build the app with phonegap (online):

 

1) Upload Zip File

2) Build with signature key (Followed this tutorial: https://github.com/amirudin/build/wiki/Android-Signing)

3) Download the .apk 

4) Install it on my Samsung Galaxy S4

5) Start the app

6) Try to connect -> Error

Any ideas what might be wrong?

 
Average of ratings: -
Picture of Juan Leyva
Re: Cannot connect: the site must use Moodle 2.4 or later
Group DevelopersGroup Moodle HQGroup Particularly helpful MoodlersGroup Testers

Hi,

master is unstable and maybe broken, you should download by tags

I've uploaded all the tags related to released versions, for download latest stable:

https://github.com/moodlehq/moodlemobile/archive/VERSION_1.4.zip

Regards

 

 
Average of ratings: -