SCORM

 
 
David Delgado: developer of learning systems an online communities
Can't allow slash arguments to use SCORM packages
 

Hi,
I have managed to install Moodle 2.2.1+ in a 1&1 hosting, with phpdev option activated (5.4). Anyway, to make it work I had to disable slash arguments in admin/server/HTTP. This way, everthing works ok but the SCORM packages, which I need to use.

I have tried to allow slash arguments, adding the following line to my .htaccess at moodle directory and allowing slash arguments in admin/server/HTTP, as seen in the Installation FAQ

AcceptPathInfo on

Anyway, it still doesn't work.

Does anybody know how to fix that and make it to allow slash arguments and make SCORM packages work?

On the other hand, if I load SCORM packages as IMS resources instead of SCORM activities, they load fine, but with all the images broken.

I have been working days trying to fix this, but I cannot find a fix.

I look forward to hearning from you about this.

 
Average of ratings:Useful (1)
David Delgado: developer of learning systems an online communities
Re: Can't allow slash arguments to use SCORM packages - Fixed!
 

Fixed. I just had to create a php.ini file in the moodle directory with this content:

cgi.fix_pathinfo = 0

It was a know bug when using PHP as CGI.

 
Average of ratings:Useful (1)
Picture of Ian Cockram
Re: Can't allow slash arguments to use SCORM packages - Fixed!
 

You sir, are a genius!

Thank you!

 
Average of ratings: -
Picture of Gurdain Rayatt
Re: Can't allow slash arguments to use SCORM packages - Fixed!
 

Hi there,

I have made a php.ini file within the root of my moodle 2.6 installation and added the line you mentioned. Also added the .htaccess command mentioned before. Also on 1&1. Turned off slash arguments as they were breaking the menu tree links and the image links.

Still can't get scorm to load.

Any ideas?

 
Average of ratings: -
Picture of Julio García
Re: Can't allow slash arguments to use SCORM packages - Fixed!
 

Thank you.

I tried and worked. Very usefull

 
Average of ratings: -
Picture of Jorge Rodriguez
Re: Can't allow slash arguments to use SCORM packages
 

It worked out for me as well. Thank you.

1&1 hosting did not help allowing slash arguments and did not provide any solution.

My settings:

Moodle 2.4.1
php 5.4.12
MySQL 5.1.67
Apache Server API CGI/FastCGI

 
Average of ratings: -