Languages

Edited Strings Not Visible

 
Picture of Prashant Ghildiyal
Edited Strings Not Visible
 
Hi!!
I am new to moodle, to understand the "language editing" option I followed these steps and have been struggling with the problem for some time now.

I logged in as administrator and selected language editing option, and after choosing "Local String Customization" of English Language pack, changed the entry against "Author" to "Contributor" and saved wiki.php.

I was expecting to see "Contributor" instead of "Author" on the refreshed "wiki.php" but it was still showing "Author"

Can you please point out error in the steps i have taken. I am using Moddle 1.9+ on windows XP.

Thanks
Prashant Ghildiyal
 
Average of ratings: -
Picture of David Mudrák
Re: Edited Strings Not Visible
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersPlugins guardiansTestersTranslators
Hi!

the procedure seems to be OK. I have tested it right now and I am able to save the modified local string. See the attached screenshot on how it looks after the save. The green highlighted cell indicates the difference of your local translation.
Just to clarify - is "Author" still showing at the translation page or at the wiki activity page?

d.

 
Average of ratings: -
Picture of Prashant Ghildiyal
Re: Edited Strings Not Visible
 
Hi David,
Author is still showing on both translation page as well as wiki page.

When I tried to replicate this issue on a free web-host (earlier i was doing it on my local system) it showed intended behavior that is author string got replaced by creator; I think it is because of XAMPP setting on my local system, do you have any idea as to what can be reason?

Regards,
Prashant
 
Average of ratings: -
larry's pix
Re: Edited Strings Not Visible
 
Hi Prashant and David

I'm an old hand around Moodle and support a number of sites. I too am experiencing this problem with multiple language files ... so you are not alone.

The changes are made to the local language folders when I examine them in the moodledata/lang/en_utf8 folder (in my cases) but are not displaying as changes in the GUI or the page content. I made a significant change (substituting another term for the word "course" to meet an institutional requirement) and the changes made on a demo server are visible but the ones made on the production one are not.

In both instances, an XAMPP build are being used. The production box is 20090805 and the demo box is 20090804, so there should be no significant difference.

I look forward to suggestions from David and others as well.
 
Average of ratings: -
Picture of David Mudrák
Re: Edited Strings Not Visible
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersPlugins guardiansTestersTranslators
Can you check if moodledata/lang/en_utf8_local/ has been created on the XAMPP (not working) sites? Is there any content inside?
 
Average of ratings: -
Picture of Prashant Ghildiyal
Re: Edited Strings Not Visible
 
moodledata/lang/en_utf8_local/ has properly updated content, it is showing string creator linked to author.

Regards,
Prashant Ghildiyal
 
Average of ratings: -
Picture of David Mudrák
Re: Edited Strings Not Visible
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersPlugins guardiansTestersTranslators
Hmm... So to sum up:
  • there is no problem with the language translation tool itself as the string is successfully saved into the proper folder. Is it displayed with the green highlight as shown at the screenshot above?
  • you experience a problem that XAMPP (or maybe any Windows-based server?) does not prefer local strings as it should, right?
Do you have any other languages installed on the problematic server? Or just English?
 
Average of ratings: -
larry's pix
Re: Edited Strings Not Visible
 
Not to hijack, but hopefully help David, so you can look at 2 sets of data.

The green highlight does not display on mine
The tech person who installed the production server did add multiple languages where the demo one only had English.

I uninstalled all other language packs, deleted one of the local lang files, made the change to it again, and still no green nor showing up in the GUI

larry




 
Average of ratings: -
Picture of koen roggemans
Re: Edited Strings Not Visible
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTranslators
Do you have langcache enabled?
 
Average of ratings: -
Picture of Prashant Ghildiyal
Re: Edited Strings Not Visible
 
No Langcache is not enabled, also i checked moodledata/cache and it is empty.

Regards
Prashant
 
Average of ratings: -
larry's pix
Re: Edited Strings Not Visible
 
Lang cache was enabled on my system, as the tech admin added extra languages. I deleted those languages and shut the cache option off. No difference on my system.

I have one other anomaly and am wondering if you have the same, Prashant.

Our installation was running out of hard drive space (original drive was E) and a new drive was added. The original install was copied to the new E: drive and the old drive was renamed T:

Prashant, did you have anything out of the ordinary done you your build as well?
 
Average of ratings: -
Picture of Prashant Ghildiyal
Re: Edited Strings Not Visible
 
I didnt do anything out of ordinary, but yes i used the XAMPPLite bundle provided on the moodle site to do installation on my local computer.

 
Average of ratings: -
Picture of Panayiotis Iliopoulos
Re: Edited Strings Not Visible
 
Hello everyone,

I am experiencing the exact same problem as Prashant.

Has a solution come up or are you still facing this issue?

Regards,

Panos
 
Average of ratings: -
Anthony Borrow
Re: Edited Strings Not Visible
Core developersMoodle HQPlugin developersPlugins guardiansTesters
It does not sound like folks have found a solution to this. If possible, I would like to work individually with someone via IM to see if we can figure out what is happening. Please send me a Moodle message to arrange a date and time. Peace - Anthony
 
Average of ratings: -
Picture of Joseph Rézeau
Re: Edited Strings Not Visible
Core developersParticularly helpful MoodlersPlugin developersTestersTranslators

I have exactly the same problem as described by the others in this thread. I have 2 local installs of Moodle with the most uptodate 1.9.6 version, both using XAMP, both identical.

My moodle install on my main computer does not have the language editing problem.

My moodle install on my laptop computer displays the problem as described:

I can go into the admin / Language Editing / Edit Words or phrases menu; I can edit strings, they are saved to the moodledata/lang/en_utf8 folder with my changes... but the changes do not appear in the Edit Words or phrases menu, i.e. I do not see the green highlighted original strings as I should. And, of course, in my moodle courses the original strings are still being used, not my modified strings.

This is a mystery.surprise

Joseph

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Edited Strings Not Visible
Core developersParticularly helpful MoodlersPlugin developersTestersTranslators

Found the culprit : eAccelerator evil

In my server's php/php.ini file I commented out all the commands in the [eAccelerator]

section, emptied the server/tmp cache, re-launched my moodle site on my laptop and language files editing works as expected.

I do appreciate that accelerators and caches are needed for optimum performance, but I do find them quite irritating, especially when they are installed by default, since they will quite often make editing without visible effect when you are developing.

Joseph

 
Average of ratings: Useful (2)
Picture of David Mudrák
Re: Edited Strings Not Visible
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersPlugins guardiansTestersTranslators
Nice catch! Thanks for sharing your findings Joseph. I wonder if this can be reason for others' problem, too...
 
Average of ratings: -
Picture of James Jameson
Re: Edited Strings Not Visible
 

My Moodle seems to be doing exactly the same thing.

Could you give a bit more (step-by-step if possible) guidance as to exactly what you did.

Cheers,

James

 
Average of ratings: -
Picture of Mauno Korpelainen
Re: Edited Strings Not Visible
 

James,

if you are using for example the Complete Windows package it has by default PHP eaccelerator enabled and you need to edit your php.ini file (found from server\php folder) and change

eaccelerator.enable = "1"

to

eaccelerator.enable = "0"

or comment that line out with semicolon.

Then save php.ini and restart your apache/server (XAMPP)

Eaccelerator has a "bad habit" to cache all kinds of settings - for example if theme changes (to config.php etc) don't seem to "stick" the reason is often in eaccelerator...but it can be useful to have eaccelerator enabled if site has performance issues.

 
Average of ratings: Useful (2)
Picture of James Jameson
Re: Edited Strings Not Visible
 

Thank you very much. The explanation was perfect. It has not only resolved the issue specified, it has also resolved the caching issue with my themes.

Thank you for your time and advice.

James

 
Average of ratings: -
Picture of Joseph Rézeau
Re: Edited Strings Not Visible
Core developersParticularly helpful MoodlersPlugin developersTestersTranslators
Hey, Mauno, that's what I wrote in my message.... Except I did not mention that you could set eaccelerator.enable = "0".wink
Joseph
 
Average of ratings: -
Picture of Mauno Korpelainen
Re: Edited Strings Not Visible
 
Yes - your answer was perfect already, Joseph - James just asked "a bit more (step-by-step if possible) guidance" so I added that bit... wink
 
Average of ratings: -
Picture of koen roggemans
Re: Edited Strings Not Visible - eaccelerator
Core developersDocumentation writersMoodle HQParticularly helpful MoodlersPlugin developersTranslators
For what it's worth: I use xcache with garbage collection at 300 seconds and that doesn't give me any problems.
 
Average of ratings: -