Themes: waxed

theme_waxed
Maintained by Picture of Richard Oelmann Richard Oelmann
THEME_WAXED Theme_Waxed is a child theme of Moodle's new core theme Boost. It is built on Boostrap4 and Mustache templates and adds additional settings to those in Boost to allow a level of customisation with limited knowledge of scss/css.
289 sites
509 downloads
14 fans

THEME_WAXED

Theme_Waxed is a child theme of Moodle's new core theme Boost.

It is built on Boostrap4 and Mustache templates.

In addition to Boost's preset settings, Wax adds:

1. Presets - presets added by ftp/ssh to the theme/scss/presets folder will
be automatically added to the presets drop down, in addition to those uploaded
via the user interface.
2. Colours - additional brad colour pickers to fine tune the seleected presets,
along with the standard pre/post raw scss custom settings.
3. Content - a footnote setting to add standard content into the footer space
4. Heading and images - add a page background image and a default heading background
image - the heading image can be overridden at a course level by adding an image
banner to the course summary files. A separate login page background image can also
be added.
5. Social networking icons - a panel of social icons can be created, including self-
defined icons.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Picture of Richard Oelmann
Richard Oelmann (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Richard Oelmann
    Wed, 12 Jul 2017, 12:52 PM
    Hi Diego - firstly check you have the correct version of Waxed. Waxed has around 18 presets to choose from, not just the two in Boost. You can also upload other presets, for example the ones on moodle.net. As for the images in the screenshot, they were all done using presets and Waxed theme settings to add background images etc. No additional css/scss should be needed to create a look and feel similar to the ones above.
  • Picture of Jocelyn Chappaz
    Tue, 1 Aug 2017, 9:00 AM
    Hello. I've juste downloaded and installed Waxed... but I can't find anywhere the presets... ? where am I supposed to see them ? to change between them ? I got the tab Presets in administration where I can add some presets, but they are none right now and I don't know where I can download them... It is written that we got to check the link https://docs.moodle.org/dev/waxed_Presets .. but this goes to a blank page...
  • Picture of Richard Oelmann
    Tue, 1 Aug 2017, 3:17 PM
    I've just re-downloaded Waxed from the plugins database and can confirm that there is a list of about 18 presets in the drop down 'Theme Presets' on the Presets tab if you go to Site Admin > Appearance > Themes > Waxed (comments here dont allow screenshots).
    As for the link you have posted - can you tell me where you found that link and the instruction to go and check it as I'm not familiar with it and didn't set it up - or it would have some content on it!
  • Picture of Peter Sereinigg
    Thu, 28 Dec 2017, 8:08 PM
    Is this theme compatible with Moodle 3.4+ (Build: 20171222) cant install it, stopps after installing when trying to save settings?
    Any idea?
  • Picture of Richard Oelmann
    Thu, 28 Dec 2017, 10:21 PM
    Hi Peter, I've just done a fresh clean install of 3.4+ and then installed Waxed with no issues - also have it working on 3.5dev
  • Picture of Agnes Kijewski
    Wed, 14 Mar 2018, 7:26 PM
    Hi Richard, I encountered an error when using the Waxed theme, Moodle 3.2, PHP 7.1. The error says that there is an "Illegal string offset" in presets_settings.php on line 40 for each preset in the theme and at the end "natsort() expects parameter 1 to be array, string given" in presets_settings.php on line 52. This causes the theme preset drop-down to be blank and unchangeable. I got around the bug by changing line 34 in the presets_settings.php from $presetchoices = ' ' to $presetchoices = array().
  • Picture of Clarence Prudhoe
    Sun, 15 Apr 2018, 6:53 AM
    Hi Richard, thanks for your work on this theme.
    I am using the Waxed theme - "Darkly" and I found two CSS problems that need your attention.

    1. In Course Administration / users / Enrolled users / when you use the search field the result is displayed with white text on a white field so you can't read the search list. Please tell me the CSS code to use to fix this.

    2 In Course Administration / users / Enrolled users / Enroll Users / when you search for a user to enroll, the result list text is dark grey on a black background so it is difficult to read. Please tell me the CSS code to use to fix this.

    3. When you make an entry on the calendar, the event description doesn't show when you click on the event date.

    Thanks for your help.
    Clarence
  • Picture of Roland Sherwood
    Mon, 25 Jun 2018, 6:37 PM
    Hi Richard. As other users have stated, many thanks for making this theme available, and just a quick note to confirm that under a fresh install of 3.5 stable (with PHP 7.2) we're encountering a couple of small issues:

    - course header images are not being displayed, only the default header set at the site-level is visible
    - when installing the theme, the installation gets stuck in a loop during the accept upgrade settings step
    - as noted by others, the illegal string offset issue prevents display of the presets drop-down menu

    Again, many thanks for crafting and sharing this theme; we really like it and hope you might be able to resolve the above at some point.
  • Picture of Roland Sherwood
    Tue, 26 Jun 2018, 9:49 AM
    Hi Richard. Just as a quick update to the above: under 3.5 stable and PHP 7.0 the installation loop and presets issues go away, but course level header images still don't display (only site level default ones are shown).
  • Picture of Richard Oelmann
    Tue, 26 Jun 2018, 1:30 PM
    Thanks Roland - I thought I'd fixed the course header issue a few weeks ago. I'll need to check if I've made a regression or just not pushed it out properly.
    PHP7.2 - will look at as soon as I can.
  • Picture of Brian Pool
    Sun, 1 Jul 2018, 10:44 PM
    The theme will not install in a clean copy of version 3.5. I get "
    nstall plugin from ZIP file
    Validating theme_waxed ... Error
    [Error] Extracted file not found [{"file":"waxed\/style\/"}]
    Installation aborted due to validation failure"

    This happens in an install from Moodle and from a download of the zip file.

  • Picture of Richard Oelmann
    Mon, 2 Jul 2018, 3:37 AM
    @Roland and @Brian - both issues now fixed with a new version pushed to the database. Found both had been fixed but only on my localhost and had failed to push some of it to either gitlab or the database. Apologies - I'd done it as part of fixing my work theme and not come back to correcting the community version.
  • St Petersburg, Russia
    Wed, 8 Aug 2018, 12:52 AM
    Because of other plugin compatability issues I am constrained to migrate to Moodle 3.4. On the git site there is only the Master branch for M 3.5. And the Current Versions page only has a version for Moodle 3.2. Disappointingly, the previous version for Moodle 3.3 & 3.4 (ie v v3.3.0.1 (2017040101)) is now not available. So I cannot try this one out currently. Is there any reason why this is the case ? Thanks.
  • Picture of Richard Oelmann
    Wed, 8 Aug 2018, 1:48 AM
    Thanks Mark - oversight corrected and I've re-enabled the 3.3/3.4 version
  • St Petersburg, Russia
    Wed, 8 Aug 2018, 2:53 AM
    Thanks a ton Richard. I really appreciate your attention to this.
    Mark
1 2
Please login to post comments