Flexpage Theme

Themes ::: theme_flexpage
Maintained by Open LMS LogoOpen LMS Development
Moodlerooms is proud to release the Flexpage Theme, which allows for the new and improved layout in the Flexpage course format
Latest release:
110 sites
88 downloads
10 fans
This theme provides enhancements to Flexpage course format which allows more independent control over the course structure. 

Sets

This plugin is part of set Flexpage.

Screenshots

Screenshot #0

Contributors

Open LMS Logo
Open LMS Development (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Thu, Jul 26, 2012, 6:04 AM
    @Jeff: The Flexpage theme is simple on purpose - it is a proof-of-concept based on the core Standard theme. You can add Flexpage to a theme of your choice to get the features you need. I've updated the documentation to include these instructions, but it will require some basic knowledge on Moodle Theme development.
  • Thu, Apr 18, 2013, 11:48 AM
    Hi Kris, I've tried to install flexpage. I have version 2.4.1, but am getting a warning: format_flexpage (2012071900) To be installed. Any ideas? (note I didn't install anything but the flexpage theme.
  • Sat, Apr 20, 2013, 12:32 AM
    Hi Barb - Flexpage is part of a set that requires the installation of several plugins. For the full installation instructions, please see http://docs.moodle.org/22/en/Flexpage. The version for 2.4 is not available yet, but we are working on that now and it should be soon.
  • Fri, May 17, 2013, 12:34 PM
    A new version of Flexpage has been updated to support Moodle 2.4. Please note this is a Beta release, and has not been fully tested by our QA team.
  • Sat, Dec 7, 2013, 6:49 AM
    Is there any thought of updating the Flexpage plugins to 2.6?
  • Mon, Jan 20, 2014, 5:50 AM
    Version 2.5 of Flexpage has been uploaded to the plugins repository. In addition, we've posted the plugin code in Github, which we will be updating in the future prior to availability in the Plugins Repository. Please check there first for updates to new Core versions.
  • Mon, Apr 28, 2014, 1:48 PM
    Can Flexpage functionality be added to a bootstrap based theme?
  • Mon, Apr 28, 2014, 9:08 PM
    @Doug - we're working on that right now. It's going to be very challenging to get it to be responsive. We should know more in about 3-4 weeks, stay tuned.
  • Thu, May 1, 2014, 1:54 PM
    Thanks Kris. On (for me) a related note, any idea of when a Flexpage version for 2.6 will be released?
  • It's only an avatar...
    Thu, May 15, 2014, 2:11 PM
    Hi Kris, can you explain to me why Flexpage theme has no main content token? It has blocks but these are not defined anywhere that I could see.
  • Mark Nielsen in Prague, Czech Republic - 2006
    Thu, May 15, 2014, 11:07 PM
    Hey Mary, the main content token is the first thing after the header. For flexpage, it is actually only used to output the editing options (I think that's the only thing). All the content for flexpage is actually in the blocks that you can add to the various regions on the page. Hope that helps!
  • Wed, Aug 13, 2014, 4:20 AM
    Hi Kris...any news yet on whether the Flexpage Theme will be bootstrap compatible or whether it will be updated for Moodle versions beyond 2.5?
  • Thu, Aug 14, 2014, 11:40 PM
    A new version of this plugin for Moodle 2.6 has been uploaded to the plugins repository. We apologize for the delay - there were significant updates that were required for the new course editing interface in this version of Moodle. There are no known issues with the new version at this time, but if you do experience a problem please ensure that you submit any issues to tracker.moodle.org.
  • Thu, Aug 14, 2014, 11:46 PM
    @Doug - Flexpage is not very compatible with Clean in this version. We are making improvements to the user experience in a new theme called Snap, based on Boostrap v3, which will be released to the community in the near future. However, the UX in Flexpage using small screen devices will likely never be ideal without drastic modifications that could potentially even require a re-write. We are currently discussing our options here.
  • Sat, Apr 11, 2015, 10:15 PM
    I tried to install Flexpage set after updating to 2.8.5+ and it doesn't work. The error message I get is...Fatal error: Class course_format_flexpage_lib_condition contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (core_availability\info::get_view_hidden_capability) in www.../public_html/moodle/course/format/flexpage/lib/condition.php on line 32
1 2
Please login to post comments