Select Moodle version:

Themes: theme_coursesearch

theme_coursesearch
coursesearch theme is required by course search plugin. Installing coursesearch theme will start evaluating course search results from course search plugin out of box.
Maintained by: Picture of Shashikant Vaishnav Shashikant Vaishnav

Sets

This plugin is part of set Course search tool. Plugins from the set work the best when installed together.

coursesearch theme is required by course search plugin. Installing course search theme will start evaluating course search results from course search plugin.

Required by:-

Course search plugin

Screenshots

screenshot
screenshot
screenshot
screenshot
screenshot
screenshot
screenshot
screenshot
screenshot
screenshot

Contributors

Picture of Marina Glancy
Marina Glancy: Mentor
My ugly mug
Michael de Raadt: Mentor
Picture of Shashikant Vaishnav
Shashikant Vaishnav (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • It's only an avatar...
    Fri, Feb 7, 2014, 10:33 AM
    Hi Shashikant,
    Congratulations with getting your first theme publish here in Moodle plugins directory.
    I was looking through your code just now and notice that whilst your theme will work OK in Moodle 2.5, it will not work correctly in 2.6 as the Grader CSS is missing from the less files, where in 2.5 it was part of the LESS css. This is because in Moodle 2.6 the exclude grader styles.css setting was removed from the config.php, and so was the majority of the grader.less css removed too.
    So to make this theme workable in both Moodle 2.5 and 2.6 you would need to remove the exclude grader and blocks stylesheet setting from theme/coursesearch/config.php as it is no longer. See: MDL-40533 and MDL-40534
    Hope this helps?
    Cheers
    Mary
  • It's only an avatar...
    Fri, Feb 7, 2014, 10:36 AM
    What I also forgot to say in my last comment is that you would need two separate versions of this theme. One for Moodle 2.5 and another for Moodle 2.6+ for the reasons mentioned above. smile
  • It's only an avatar...
    Fri, Feb 7, 2014, 10:53 AM
    Hi,
    I'm finding some problems with this theme, just by looking at the various elements and code you have here. I am surprised no one picked up on this. The layout file you are using is out of date if intended to be uses with bootstrapbase in Moodle 2.5 and 2.6. Firstly because it is called general.php and secondly there is no $THEME->layouts listed in the theme's config.php so it will not be used. So why is it there?
  • Picture of Shashikant Vaishnav
    Fri, Feb 7, 2014, 2:29 PM
    Hello mary,


    Thanks for letting me know, I will update with proper corrections with in few time.

    Regards
    Shashikant
  • Picture of Shashikant Vaishnav
    Wed, Feb 12, 2014, 8:42 PM
    Hello mary,

    first of all thanks for making me aware of this issues, I just did update with the plugin "advance course search(tool_coursesearch)". This theme is part of that admin tool.

    With the first release of the plugin, we suggested users to use this theme, which exactly clone of clean theme, with some hacks to make Advance course search work, out of box.

    I just released advance course search with few new features, so bumped the version for this theme too. This theme is used just to render results from advance course search plugin.

    let me know what changes we may go further. I am not sure though.

    Regards
    Shashikant
Please login to post comments