Themes: Bootstrap

theme_bootstrap
Maintained by Picture of Bas Brands Bas Brands
This is a Moodle theme based on the Bootstrap CSS framework. It has minimal styling and can be used to create User Experience optimized themes
4845 sites
4k downloads
34 fans

This is a Moodle theme based on the Bootstrap CSS framework. It has minimal styling and can be used to create User Experience optimized themes.

This theme was created with the help of Stuart Lamour and David Scotson

Please report issues on github: https://github.com/bmbrands/theme_bootstrap/issues

Screenshots

Screenshot #0

Contributors

Picture of Bas Brands
Bas Brands (Lead maintainer): Focus: technical and design, build the best theme possible
Picture of Stuart Lamour
Stuart Lamour: Focus: accessibility, build a true HTML5 theme for everybody
Picture of David Scotson
David Scotson: Focus: technical, build a theme for devs and improve Moodle
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Anthony Borrow
    Tue, 13 May 2014, 9:58 PM
    Bas - I noticed that in theme/bootstrap/thirdpartylibs.xml you did not have a for the second entry. This was causing some errors when trying to use the code checker:

    Warning: simplexml_load_file(): /var/www/m27/theme/bootstrap/thirdpartylibs.xml:16: parser error : Opening and ending tag mismatch: library line 10 and libraries in /var/www/m27/local/codechecker/locallib.php on line 194

    When you get a chance, could you patch that up. Peace - Anthony
  • Picture of Bas Brands
    Tue, 13 May 2014, 11:03 PM
    Thanks Anthony, I have updated the thirdpartylibs.xml.
  • Picture of Ben Hutchens
    Mon, 19 May 2014, 7:40 PM
    Hi,

    I am trying to adjust the the width of select (drop down boxes in the css) i.e. 100% for text based and auto for things like numbers, dates etc. The reason for this is that some of our text based drop-downs underlap other divs. When I set select to 100% it solves this however, it makes the time/date drop downs span the width of the div which is not required. Can I assign css qualities to particular drop down menus?

    Thanks

    Ben
  • Picture of Shivani Bhatt
    Sat, 11 Oct 2014, 11:56 PM
    Hi,
    I am very new to moodle. I am trying to install elegance theme and it needs bootstrap as well. I have tried to install bootstrap multiple times but unsuccessful every time. Please help.
  • Picture of Heru Susanto
    Mon, 24 Nov 2014, 2:53 AM
    Hi

    my name is Heru S from Bootstrapmade marketplace. We do accept Moodle bootstrap theme now, you can earn 70% commission per sale. It's free to join and submit your moodle theme at https://bootstrapmade.com




  • Picture of Chris Lamb
    Thu, 30 Apr 2015, 6:26 PM
    Thank you for the development - a great theme to start from. May I ask a question which I am sure will strike others as simple! I am unsure the scope of Bootstrap 3 functionality to anticipate.

    I have tested css styling - and it works, thank you. Should I anticipate being able to use javascript component features such as the accordion? I am not finding it and the only references are to requiring jquery - if I reference UI will it allow access to the UI components, too?

    Chris
  • Picture of Bas Brands
    Thu, 30 Apr 2015, 8:11 PM
    Hi Chris,

    Thanks for your comment. If you want to make use of the Bootstrap javascript element you will need to install the jquery version of the bootstrap theme.
    The jquery version is available on:
    https://github.com/bmbrands/theme_bootstrap/tree/MOODLE_28_STABLE_WITH_JQUERY
  • Picture of Chris Lamb
    Thu, 30 Apr 2015, 8:38 PM
    Thank you, Bas.

    I shall checkout that version. THanks for replying so quickly - saving me from more hacking away blindly!

    Chris
  • Picture of Bas Brands
    Thu, 30 Apr 2015, 9:26 PM
    You're welcome, I have started a forum post on the topic. https://moodle.org/mod/forum/discuss.php?d=312844 I am wondering what the responses will be.
  • Picture of David Mudrák
    Tue, 5 May 2015, 5:13 AM

    I am happy to announce that the Bootstrap theme has received the Featured Moodle plugin award! See the great interview with Bas at Plugin traffic blog. Thanks Bas, Stuart and David for your work on this project.

  • Picture of Torsten Händler
    Tue, 17 Nov 2015, 8:15 PM
    its OK but why was the moodlezoom yui and css removed after version 2.8 ? So I've to use the older one because the new bootstrap theme did to much errors for my theme.
  • Picture of Richy Sandoval
    Mon, 4 Jul 2016, 2:37 AM
    Hi Guys,

    How to do changes of the bootstrap CSS? i.e. background color of navbar.

    Thanks,
    RS
  • Picture of Michael Veit
    Sat, 30 Jul 2016, 4:00 PM
    Hi Bas,

    thanks for this theme. I want to update to the moodle version 3.1.1. Do you know if the Theme version 3.0.0 (2016042200) of Bootstrap is compatible with the version of Moodle 3.1.1?

    Best regards
    Michael
  • Picture of Luis Moreno
    Sat, 27 Aug 2016, 1:01 AM

    The destination location already exists, that is what appears Can you help me please. Thanks
  • Ricardo Caiado
    Wed, 7 Dec 2016, 8:58 PM
    Any upgrade to Moodle 3.2?
1 2 3 4 5 6
Please login to post comments