Question types: Opaque

qtype_opaque
Maintained by Tim at Lone Pine Koala SanctuaryTim Hunt
This question type uses web services to connect to other question engines like OpenMark or ounit, so that their questions can be used in a Moodle quiz.
104 sites
68 downloads
5 fans
Current versions available: 7
Opaque (http://docs.moodle.org/en/Development:Opaque) is the Open protocol for
accessing question engines. It can be used to add questions to a Moodle quiz from third party assessment systems that support the protocol, like OpenMark or ounit (http://code.google.com/p/ounit/) and possibly other question systems we don't know about.

As well as this question type, you aslo need the associated question behaviour https://moodle.org/plugins/qbehaviour_opaque.

Sets

This plugin is part of set Open University.

Screenshots

Screenshot #0

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
Picture of Chris Nelson
Chris Nelson: Product owner
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • SelfieChicago
    Tue, Oct 30, 2012, 12:33 AM
    Hi, Tim. I appreciate your time to help me. Stack ver. 3.0 inside Moodle was installed successfully. I started to add a Stack question. Cheers
  • SelfieChicago
    Tue, Oct 30, 2012, 2:48 AM
    Hi, there. I started with a new Stack question. I followed the Stack documentation. However, when I clicked to create the question the following error message appeared in the the section Model answer
    CAS failed to return any data. ans1:3*(x-1)^2

    I decided to run the healthcheck.php script. This script showed all information without any error message.

    Any idea?

    TIA

    Monico
  • SelfieChicago
    Tue, Oct 30, 2012, 11:24 PM
    Hi there. I found what my problem was with the following error:
    CAS failed to return any data. ans1: 3*(x-1)^2
    After I checked it out, it was the maxima CAS version installed on the server. I updated on the Stack configuration and it is working.
    Cheers
    Mónico
  • Picture of tas ras
    Thu, Feb 28, 2013, 4:09 AM
    Hello. Opaque doesn't seem to function properly (Moodle 2.3).

    When trying to create an Opaque question, while using Developer debug mode, the form does not appear, instead a Strict Standards error message appears, about a non-existent HTML element (questiontext and generalfeedback). At the upgrade.txt of question/type (https://github.com/moodle/moodle/blob/master/question/type/upgrade.txt), at the = 2.3 = section it states:
    " If you are overriding export_to_xml and import_from_xml to provide Moodle XML format
    import and export, then you will probably get PHP strict syntax notices in developer
    debug mode until you change the method signature to include qformat_xml $format.
    That is, you need to specify the argument type."

    After correcting the argument type at question/type/opaque/questiontype.php as above, the new opaque question form still doesn't appear. Instead, an error occurs starting with:
    "QuickForm Error: nonexistent html element Element 'questiontext' does not exist in HTML_QuickForm::getElement()"
    and ending:
    "Fatal error: Call to undefined method HTML_QuickForm_Error::getValue() in [...]moodle/question/type/edit_question_form.php on line 441 "

    As a quick solution, I've tried editing edit_opaque_form.php, by commenting out this part:
    $mform->removeElement('questiontext');
    $mform->removeElement('generalfeedback');
    That does the trick (the form appears and an Opaque question can be created) but I don't like the idea of such a solution and I think it's causing other problems to the Opaque engine communication.

    Any ideas/proposals?
    Thank you
  • Tim at Lone Pine Koala Sanctuary
    Fri, Mar 1, 2013, 2:30 AM
    That's odd. It works fine for us at the OU, in both 2.3.x and 2.4.x. Are you sure you have the latest version of the code.
  • Picture of tas ras
    Fri, Mar 1, 2013, 4:37 AM
    Hello Tim,
    My colleague installed it some days ago through git so I suppose it's the latest version. Nevertheless, I tried to reinstall it, in case it was outdated, but when trying to uninstall Opaque, there's this error:
    "You cannot delete the question type 'Opaque'. There are other question types installed that rely on it."
    (however, no qtypes seem to be associated)
    And when trying to uninstall opaque behaviour, there's that error:
    "You cannot delete the behaviour 'Question managed by a remote engine'. It is used by question attempts."
    If it matters at all, Moodle version.php:
    $version = 2012062504.06;
    $release = '2.3.4+ (Build: 20130214)';
  • Picture of illouz gabriel
    Sat, Feb 15, 2014, 12:10 AM
    Hello Tim,
    After fighting with the installation of opaque + testing it into moodle 2.5 with testopaque and openmark...
    (BTW, openmark works only with tomcat6, not 7)

    it keeps answering : "Unexpected question state."
    So, I made another install of moodle (2.3), and know it does work fine...
    Is the problem come from the test programs, or change in moodle behaviour, or opaque ?
    Thanks in advance,
    Gabriel
  • Tim at Lone Pine Koala Sanctuary
    Sat, Feb 15, 2014, 12:20 AM
    We are using the previous version of this question type with Moodle 2.5, and we are testing the latest version with 2. at the moment, and it is working for us.
  • Picture of golars networks
    Fri, Jul 24, 2015, 9:10 PM
    if quiz engine has 50 questions i need any randomized 4 questions to every students how to that
  • Picture of Albert Leatherman
    Mon, Dec 26, 2016, 9:59 AM
    Hi Tim, is there a setup guide for OpenMark and Ounit? In particular I'm trying to find the question engine and question bank URLs for those resources. I found the URLs for WeBWorK but haven't had any luck finding them for OpenMark and Ounit. Thanks.
  • Tim at Lone Pine Koala Sanctuary
    Wed, Dec 28, 2016, 6:11 PM
    OpenMark and OUnit are both software you need to install yourself, if you want to use them.
  • Picture of Zabelle Motte
    Wed, Jul 25, 2018, 3:19 PM
    Hello Tim,

    We have been developing some new question types while using your Opaque plugin.
    It works very fine without overloading the Moodle question type list.
    Many thanks for this plugin.

    But we have been testing a Moodle 3.5.1+ upgrade and we encounter an error on line 135 of connection.php with the extends_soapclient function that evolved in php7.
    It seems to be a touchy question in php community so that we hope you will have some time to have a look at wink

    Great thanks for your contributions to the Moodle community ;-*

    Zabelle


  • Picture of Zabelle Motte
    Wed, Jul 25, 2018, 4:09 PM
    Apologies, your plugin works fine on Moodle 3.5.1+ but needs the php soap plugin to be installed.
    This plugin is not refered to be mandatory for Moodle but must be installed for your plugin to work.

    Kisses

    Zabelle
  • Picture of Erick Tayouo
    Tue, Feb 12, 2019, 11:59 PM
    We have a SoapFault exception, when test a connection between Moodle Opaque module and Opaque Server. Our Moodle installation: Qtype_opaque 2.7 For Moodle 3.4+ 2018112100
    qbehaviour_opaque, 2.8 For Moodle 3.4+, 2018081400
    Moodle version 3.6

    Need help
  • Tim at Lone Pine Koala Sanctuary
    Wed, Feb 13, 2019, 11:09 PM
    Which type of Opaque server? What ist he full error message?
1 2
Please login to post comments