Question types: Select missing words

qtype_gapselect
Maintained by Tim at Lone Pine Koala Sanctuary Tim Hunt, Picture of Jamie Pratt Jamie Pratt, Picture of Phil Butcher Phil Butcher
This question type allows students to complete a paragraph of text by selecting the missing words using drop-down menus.
1545 sites
177 downloads
28 fans

There are working examples in eAssessment with Moodle on our OpenLearn site.

The documentation is in How to create questions in Moodle on that site.

This question type allows students to complete a paragraph of text by selecting the missing words using drop-down menus. You can make questions like this using the Cloze question type, but this question type is easier for teachers to get up, and presents the feedback in a more accessible way.

The question type was created by Jamie Pratt for the Open University.

Sets

This plugin is part of set Open University.

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
Picture of Jamie Pratt
Jamie Pratt: Developer
Picture of Phil Butcher
Phil Butcher: Question type designer
Picture of Colin Chambers
Colin Chambers: Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Tim at Lone Pine Koala Sanctuary
    Wed, 21 Jan 2015, 1:06 AM
    Your assumption is right.

    What you want is not possible with this question type.

    I think that if you set the max mark for a question to 0 (on the edit quiz page) normally very little correctness information is shown, and that might fit your use case. (I don't know how well this qtype handles that case.)
  • Picture of Martin Greenaway
    Wed, 21 Jan 2015, 1:17 AM
    That's fine, Tim, I'll take a look. Thanks for your assistance.
  • Picture of Charlie Ewing
    Wed, 13 Apr 2016, 5:25 AM
    Hello everyone!
    I am looking for a bit of help, I think I broke my moodle (though I've found workarounds, I'm paranoid about causing a server crash again)

    This is the error I receive, and it always is asking to install gapselect. (I have the drag and drop image questions working fine at this time)

    qtype_gapselect
    DDL sql execution error

    More information about this error

    Debug info: Table '`moodle`.`mdl_question_gapselect`' already exists
    CREATE TABLE mdl_question_gapselect (
    id BIGINT(10) NOT NULL auto_increment,
    questionid BIGINT(10) NOT NULL DEFAULT 0,
    shuffleanswers SMALLINT(4) NOT NULL DEFAULT 1,
    correctfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
    correctfeedbackformat TINYINT(2) NOT NULL DEFAULT 0,
    partiallycorrectfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
    partiallycorrectfeedbackformat TINYINT(2) NOT NULL DEFAULT 0,
    incorrectfeedback LONGTEXT CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
    incorrectfeedbackformat TINYINT(2) NOT NULL DEFAULT 0,
    shownumcorrect TINYINT(2) NOT NULL DEFAULT 0,
    CONSTRAINT PRIMARY KEY (id)
    , KEY mdl_quesgaps_que_ix (questionid)
    )
    ENGINE = InnoDB
    DEFAULT CHARACTER SET utf8
    DEFAULT COLLATE = utf8_unicode_ci
    COMMENT='Defines select missing words questions'
    Error code: ddlexecuteerror
    Stack trace:
    line 449 of \lib\dml\moodle_database.php: ddl_change_structure_exception thrown
    line 905 of \lib\dml\mysqli_native_moodle_database.php: call to moodle_database->query_end()
    line 76 of \lib\ddl\database_manager.php: call to mysqli_native_moodle_database->change_database_structure()
    line 412 of \lib\ddl\database_manager.php: call to database_manager->execute_sql_arr()
    line 364 of \lib\ddl\database_manager.php: call to database_manager->install_from_xmldb_structure()
    line 508 of \lib\upgradelib.php: call to database_manager->install_from_xmldb_file()
    line 1647 of \lib\upgradelib.php: call to upgrade_plugins()
    line 677 of \admin\index.php: call to upgrade_noncore()

    Thank you for the help,
    Charlie
  • Tim at Lone Pine Koala Sanctuary
    Wed, 13 Apr 2016, 6:30 PM
    It looks like you have got your Moodle into a state where it is confused about whether you have this question type installed or not. I don't think this is a good place for you to try to get help. I suggest you post in the Installation problems forum https://moodle.org/mod/forum/view.php?id=28. You will need to say which version of Moodle you are running, and explain how you got your Moodle site into that state.
  • Picture of Charlie Ewing
    Wed, 13 Apr 2016, 8:45 PM
    Thank you for the help Tim! I will do that immediately.
  • Picture of Edmund Evangelista
    Tue, 25 Oct 2016, 9:42 PM
    How to resolve the issue that the dropdown list overlaps until the right menu block when options are very lengthy. It reaches to a point that the width of my dropdown list due to a very long answer/option has mixed already with links found on the right menu block of Moodle.
  • Tim at Lone Pine Koala Sanctuary
    Tue, 25 Oct 2016, 10:25 PM
    Re-think your questions so you don't need to do that.
  • Picture of Vana Rizou
    Mon, 14 Nov 2016, 5:23 PM
    Hello,
    could you pls be so kind to guide me how to change the background color at Question types: Select missing words?
    (Sorry if this is already answered somewhere but I didn't find)
    TY
  • Picture of Stephen Parry
    Wed, 22 Nov 2017, 4:19 AM
    Could we have a version for 3.3 and / or 3.4 please? We are thinking upgrading but many of our plug-ins only work up to 3.1! Thanks!
  • Tim at Lone Pine Koala Sanctuary
    Wed, 22 Nov 2017, 8:32 AM
    Since Moodle 3.2, this question type is part of the standard Moodle package. No addon needed!
  • Picture of Aaron Johnson
    Fri, 22 Dec 2017, 9:00 PM
    Hello,
    I'm trying to use multiple groups in this question type, but the same set of options is shown for both pull-down menus. Any ideas? Here is my question text:

    You are preparing to analyze an aqueous sample with significant particulate content. 1 sampling, the sample should be 2.

    I'm on Moodle 3.2.2.

    Thanks,
    Aaron
  • Tim at Lone Pine Koala Sanctuary
    Fri, 22 Dec 2017, 9:04 PM
  • Picture of Aaron Johnson
    Fri, 22 Dec 2017, 9:22 PM
    Thanks, Tim. I guess I was confusing choice number and group number. It might be worth adding a warning/clarification to that point in the documentation.
  • Picture of Augusto R. M.
    Tue, 6 Feb 2018, 9:30 PM
    Hi Tim. I upgraded a Moodle system from version 2.3 to version 3.3.

    Version 2.3 had this plugin qtype_gapselect enabled, and several quizes had qtype_gapselect.

    After upgrade, those quizes aren't displaying but showing this error message at:

    /mod/quiz/startattempt.php

    "Unknown question type gapselect"

    Any suggestion on this issue is really apreciate.
  • Picture of Augusto R. M.
    Tue, 6 Feb 2018, 9:38 PM
    Note: In version 3.3 there is not version for this plugin; it should be in core.
1 2
Please login to post comments