Your Moodle version

Question types: Gapfill Question

qtype_gapfill
Maintained by Picture of Marcus Green Marcus Green
Cloze question type with VERY simple question creation syntax. Can do drag drop, dropdowns or gapfill questions
936
1k
16
Moodle 2.1, 2.2, 2.3, 2.4, 2.5, 2.6

Screenshots

Screenshot #0

Contributors

Picture of Marcus Green
Marcus Green (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Daniel Thies
    Sat, Jan 2, 2016, 8:13 AM
    I had a fatal error on my site when upgrading my site to PHP 7 on Moodle 3.0.1. I patched and have it in a pull request on github.
  • Picture of Marcus Green
    Sat, Jan 2, 2016, 4:06 PM
    Thanks Daniel, I have updated the 1.9 branch with your fix. The 1.9 branch has some other minior fixes. I don't have a working install of PHP7, so if you could install that and email me at marcusavgreen at gmail dot com to confirm it works I would be very greatful.
  • Picture of Paul Vivian
    Mon, Jan 4, 2016, 4:23 AM
    Hi All,
    Just updated via the moodle plug in database this plug in, and this error appears

    qtype_gapfill

    Cannot downgrade qtype_gapfill from 2006082517 to 2006082517.

    More information about this error
    Debug info:
    Error code: cannotdowngrade
    Stack trace:

    line 347 of /lib/upgradelib.php: downgrade_exception thrown
    line 80 of /question/type/gapfill/db/upgrade.php: call to upgrade_plugin_savepoint()
    line 541 of /lib/upgradelib.php: call to xmldb_qtype_gapfill_upgrade()
    line 1630 of /lib/upgradelib.php: call to upgrade_plugins()
    line 433 of /admin/index.php: call to upgrade_noncore()

    I have tried it for Moodle 2.9 & 3.0.1 and they all come up with the same error.

    Please assist
  • Picture of Marcus Green
    Mon, Jan 4, 2016, 4:45 AM
    Hi Paul, my apologies for that, I have just updated the file and installation should work now (it appears to be the same but there is an update within db\update.php to a versioin number). Please let me know if it works
  • Picture of Paul Vivian
    Mon, Jan 4, 2016, 3:55 PM
    Awesome, thank you Marcus..
  • Picture of camille Grasset
    Sat, Jan 16, 2016, 7:51 PM
    Hi Marcus,
    I get the same error as Paul Vivian shows above (4.january). You seem to have this issue fixed, however, I haven't found yet how to update the file: I always am directed to the same "plugins check" page waiting for an "upgrade of the moodle database". I cannot either uninstall the plugin from the plugins overview page.
    I guess I lack knowledge on how to administrate plugins, but I haven't found any answers in moodle documentation and forums...
    Some help would be really apreciated!
  • Picture of Marcus Green
    Sat, Jan 16, 2016, 8:04 PM
    Hi Camille, yes the issue Paul had is fixed in the visible release. The problem was in the db\upgrade.php file. If you can replace that the upgrade should run without error. When did you download/attempt to upgrade your version? That faulty version was only available for a matter of hours I believe. You can email me directly at marcusavgreen at gmail.com and one way or another I should be able to get your question upgraded.
  • Picture of camille Grasset
    Sat, Jan 16, 2016, 10:28 PM
    Fantastic, it's all fine now, many thx for the help
  • Picture of Chris Kenniburg
    Thu, Mar 10, 2016, 11:08 PM
    Hello Marcus, We love your question type! However, we discovered an issue. In the question text we can use Exponents. However, in the distractors when we add exponents they get removed when saving. Do you have any ideas on what might be causing this? We have some math teachers that would like to utilize your question type for a variety of purposes.
  • Picture of Kevin Bruton
    Sat, Apr 2, 2016, 6:50 PM
    Hi Marcus, Great plugin!
    With it, I'm able to ask questions such as: list the four seasons of the year. And marking "no duplicates" as you've described in your post (https://moodle.org/mod/forum/discuss.php?d=329010), it marks the answers correctly.
    However, I can see that it gives one full mark for each season. Any way of giving one mark for the question in all?
  • Picture of Marcus Green
    Mon, Apr 4, 2016, 3:50 PM
    Hi Kevin, thanks for the feedback. There is no way of giving one mark for the question overall.There is considerable testing and logic embedded in the concept of one mark per gap so changing that to an all or nothing mark would require significant re-working.
  • Picture of Daniel Thies
    Mon, Apr 4, 2016, 10:21 PM
    Hi Kevin,
    You may be able to achieve this with a behaviour plugin https://moodle.org/plugins/qbehaviour_deferredallnothing.
  • Picture of Kevin Bruton
    Wed, Apr 27, 2016, 8:26 PM
    Hi Marcus,
    I've got another question for you. I'm not sure if it's a bug or if I'm doing something wrong. I'm displaying the answers in the "gapfill" mode. When I press the preview button on the editing page, it appears as expected (a text box big enough to enter the word for each "gap"), but when I start a quiz with the question, the answer boxes occupy a whole line. Any ideas on this?
  • Picture of Marcus Green
    Wed, Apr 27, 2016, 8:28 PM
    Hi Kevin, can you email the text of your question and a screen shot of how it appears to marcusavgreen at gmail.com
  • Picture of Kevin Bruton
    Thu, Apr 28, 2016, 4:01 AM
    Just for the record... in the end it wasn't a problem with this plugin. It was a problem with the Essential theme I was using. Marcus helped debug the problem and to find a solution: I updated the theme and all works as expected now.
    Thanks Marcus!
1 2 3 4 5 6 7 8 9
Please login to post comments