Your Moodle version

Question types: Combined

qtype_combined
Maintained by Tim at Lone Pine Koala Sanctuary Tim Hunt, Picture of Phil Butcher Phil Butcher, Picture of Jamie Pratt Jamie Pratt
A Moodle question type which allows questions to be built up from parts that are other simpler question types (requires you to have these question types installed)
607
743
15
Moodle 2.6, 2.7, 2.8, 2.9

There are working examples in eAssessment with Moodle on our OpenLearn site.

The documentation is in How to create questions in Moodle on that site.

This question types uses other question types as sub questions. It allows you to have one or more entry fields for any of these question types embedded in your question text. You must have at least one of these question types installed for this combined question type to work :

Here is an example of a question where a teacher has combined 1 variable numeric, 1 pmatch, 1 multiple response and 1 select missing word sub question in one combined question.

Example of a combined question

 

Sets

This plugin is part of set Open University.

Screenshots

Screenshot #0

Contributors

Tim at Lone Pine Koala Sanctuary
Tim Hunt (Lead maintainer)
Picture of Phil Butcher
Phil Butcher: Question type designer
Picture of Jamie Pratt
Jamie Pratt: Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Kim Diana
    Sat, Aug 1, 2015, 3:32 PM
    I tried to apply this type to shortanswer(question type). I did make 'shortanswer' folder into 'combinable' folder. And then copied 'combinablebase.php' file into 'shortanswer' folder mistakenly.... When I tried to make 'combined' question type, I saw error msg(HTTP 500 error). So uninstall Combined question type and Install again! But it doesn't help ! I still see the error message. Please help me how I can fix it. I cannot use this wonderful question type again! (I have already installed pmatch, varnumeriset and varnumeric plugins and they have combinable folder in themselves)
  • Tim at Lone Pine Koala Sanctuary
    Mon, Aug 3, 2015, 3:16 AM
    To fix the error, you need to undo all the changes you made. Did you keep careful notes? Or take a back-up before you started? If you want more help, I suggest you post in the quiz forum https://moodle.org/mod/forum/view.php?id=737
  • Picture of Kim Diana
    Tue, Aug 4, 2015, 10:31 PM
    I uninstalled and install again but it doesn't help. Whenever I click 'Combined' question type to create new question, it shows a blank page...
    I will post on the forum. Thank you Tim
  • Picture of Jarreau Mathys
    Thu, Nov 19, 2015, 10:48 PM
    When will you update for 3.0. It seems to move certain question types around causing errors after plug in instal.
  • Tim at Lone Pine Koala Sanctuary
    Thu, Nov 19, 2015, 11:32 PM
    Ah yes. When the drag-drop question types were added to Moodle core, the 'combinable' bits were removed. We need a new release of the Combined question type to include those bits, in order for it to be 3.0 compatible. Sorry about that. I will try to do it soon.

    Thank you for reporting this problem.
  • Picture of S. Ali
    Fri, Feb 19, 2016, 10:23 PM
    Hello,
    Just wondering if there's an update on the 3.0 compatible version of the Combined question type?
    We were planning to upgrade on Mon but a test upgrade shows that our quizzes with Combined questions will not work so we will need to delay it until a compatible version is available as we use it quite a lot. Hope it can be made available soon.

    Thank you.
  • Tim at Lone Pine Koala Sanctuary
    Fri, Feb 19, 2016, 10:29 PM
    The issue is that in Moodle 3.0, qtype_gapselect was added to the standard Moodle release. As part of that, the 'combinable' folder was removed. (https://github.com/moodleou/moodle-qtype_gapselect/tree/master/combinable)

    I think all you need to do to make this work is to add the combinable folder back to the gapselect type.

    (The proper fix, that will take me a bit loger, is that to basically undo this change: https://github.com/moodleou/moodle-qtype_combined/commit/c1c9aec26b6c6ac58e5707f4e3ed29b19673f0aa)
  • Picture of S. Ali
    Sat, Feb 20, 2016, 2:45 AM
    Hello Tim,

    Thank you Very much for the quick response and the workaround.
    I added the folder as suggested and It's fine now.

    Thanks!
  • Tim at Lone Pine Koala Sanctuary
    Fri, Mar 18, 2016, 2:55 AM
    Finally, we have a Moodle 3.0-compatible version of this question type. Sorry it took so long.
  • Picture of S. Ali
    Fri, Mar 18, 2016, 6:51 AM
    Hello Tim,

    Thank you for the update.
    I've tried to install it but it's failing with the following error:
    [Error] Required Moodle version [2015111603]

    I have installed: 1.3 for Moodle 2.6+ [2015051000] running on Moodle 3.0.2+ (Build: 20160218)

    Kind Regards,
    sali
  • Tim at Lone Pine Koala Sanctuary
    Fri, Mar 18, 2016, 7:28 AM
    Drat! That is what you get for trying to do things in a rush before leaving work. New version pushed. Hopefully that will work now.
  • Picture of S. Ali
    Fri, Mar 18, 2016, 7:58 AM
    Thank you. Works very well now.
  • Picture of lucia liljegren
    Tue, Jun 28, 2016, 9:03 PM
    Hi,
    I upgraded from 2.5.xomething to 2.7.14 to 3.1 in one fell swoop yesterday. The combined questions do not display. (I can see them in the question bank, but I get a total blank screen if I try to view the question or edit it.) Tips for what to do?
  • Picture of lucia liljegren
    Wed, Jun 29, 2016, 1:06 AM

    I don't know if my fiddling to upgrade caused this, or if the official installation tried to declare the class twice. But someone advised me to look at debug. I get this:

    Fatal error: Cannot redeclare class qtype_combined_combinable_type_gapselect in [...] /moodle/question/type/combined/combinable/gapselect/combinable.php on line 0

    I looked and 'combinable.php' is called both by
    [...] /question/type/combined/combinable/gapselect/combinable.php and
    [...] /question/type/gapselect/combinable/combinable.php

    Would deleting the one in "combined/combinable/gapselect/combinable.php" fix the issue without also causing problems in "Select missing words"?
  • Tim at Lone Pine Koala Sanctuary
    Wed, Jun 29, 2016, 1:09 AM
    Wrong way around. In Moodle 3.x, the one in question/type/gapselect/combinable/combinable.php should not exist.
1 2 3
Please login to post comments