HotPot question import for Moodle 2.x

Question formats ::: qformat_hotpot
Maintained by Gordon Bateson
Import HotPot files to Moodle 2.x question bank
Latest release:
1526 sites
188 downloads
24 fans
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8, 2.9, 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8, 3.9

Import questions from Hot Potatoes 6 xml files into Moodle question bank

This question format requires the HotPot activity module for Moodle 2.x

Screenshots

Screenshot #0
Screenshot #1

Contributors

Gordon Bateson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Mon, Feb 13, 2012, 8:06 AM
    Is something missing? I downloaded the mod but there seems to be something missing.
    From the install
    "mod/hotpot
    upload this to "mod/hotpot" on your Moodle site

    question/format/hotpot
    upload this to "question/format/hotpot" on your Moodle site"
    If I put hotpot in moodle/mod it breaks the install. If I put it in the /moodle/question/format directory it installs but when importing I get a blank screen, no imports of any description.
    Is the some file missing.
    John
  • Thu, Mar 1, 2012, 9:59 AM
    Me too. Similar story, as yet unresolved.
  • Thu, Mar 1, 2012, 10:24 AM
    Trying to install just the import format part didn't work, but when we installed the whole module then it went fine.
  • Ben talking on the phone beside a monitor
    Thu, Mar 8, 2012, 4:31 AM
    Hi, there are 2 parts to this HotPot. This is the question format part. It goes, as quoted above, into question/format.
    Then you need to install the module HotPot. It goes into the mod folder.
    Search on Hot Potatoes to get both on one page.
  • Sat, Mar 10, 2012, 9:24 AM
    Thanks for the feedback. Sorry about any confusion caused by the README file.

    Before you install this HotPot question import plugin, you need to install the HotPot module for Moodle 2.x.

    After you have installed the HotPot module for Moodle 2.x, download the zip file for this HotPot question import plugin, unzip it to get a folder called "hotpot", and then upload that "hotpot" folder to "question/filter/hotpot" on your Moodle 2.x site.

    I have modified the README file to give a similar explanation.
  • Tue, Mar 20, 2012, 10:47 PM
    I mean "question/format/hotpot". Thanks for pointing that out.
  • Wed, Mar 21, 2012, 12:08 AM
    Paul, please ask any further questions on the HotPot forum, not here.
  • Mon, Jun 11, 2012, 6:46 PM
    where can I download the package HotPot question import for Moodle 1.9?
  • Mon, Jul 23, 2012, 7:19 AM
    Cora, the HotPot question import is included in standard Moodle 1.9, so you don't need to install it.

    Please ask any further questions on the HotPot forum:
    http://moodle.org/mod/forum/view.php?id=1599
  • Tue, Oct 1, 2013, 9:29 PM
    Hi,

    Will this plugin be avalaible for Moodle 2.5 (and so)?

    Thanks
  • Mon, Oct 14, 2013, 5:48 PM
    Yes, this plugin works on all versions of Moodle 2.x
    Please ask any further questions on the HotPot forum:
    http://moodle.org/mod/forum/view.php?id=1599
Please login to post comments