Select Moodle version:

Question formats: HotPot question import for Moodle 2.x

qformat_hotpot
Import HotPot files to Moodle 2.x question bank
Maintained by: Picture of Gordon Bateson Gordon Bateson
for Moodle
2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6

Import questions from Hot Potatoes 6 xml files into Moodle question bank

Contributors

Picture of Gordon Bateson
Gordon Bateson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of John Andrewartha
    Mon, Feb 13, 2012, 8:06 AM
    Is something missing? I downloaded the mod but there seems to be something missing.
    From the install
    "mod/hotpot
    upload this to "mod/hotpot" on your Moodle site

    question/format/hotpot
    upload this to "question/format/hotpot" on your Moodle site"
    If I put hotpot in moodle/mod it breaks the install. If I put it in the /moodle/question/format directory it installs but when importing I get a blank screen, no imports of any description.
    Is the some file missing.
    John
  • Paul
    Mon, Feb 27, 2012, 8:31 PM
    I'm a little confused here. I downloaded the module and unzipped it. The first thing I do is open the readme file, and find I must download another module and unzip it. What should I do with the module I downloaded from here?
  • Picture of Stephen Lowe
    Thu, Mar 1, 2012, 9:59 AM
    Me too. Similar story, as yet unresolved.
  • Picture of Stephen Lowe
    Thu, Mar 1, 2012, 10:24 AM
    Trying to install just the import format part didn't work, but when we installed the whole module then it went fine.
  • Ben talking on the phone beside a monitor
    Thu, Mar 8, 2012, 4:31 AM
    Hi, there are 2 parts to this HotPot. This is the question format part. It goes, as quoted above, into question/format.
    Then you need to install the module HotPot. It goes into the mod folder.
    Search on Hot Potatoes to get both on one page.
  • Picture of Gordon Bateson
    Sat, Mar 10, 2012, 9:24 AM
    Thanks for the feedback. Sorry about any confusion caused by the README file.

    Before you install this HotPot question import plugin, you need to install the HotPot module for Moodle 2.x.

    After you have installed the HotPot module for Moodle 2.x, download the zip file for this HotPot question import plugin, unzip it to get a folder called "hotpot", and then upload that "hotpot" folder to "question/filter/hotpot" on your Moodle 2.x site.

    I have modified the README file to give a similar explanation.
  • Paul
    Tue, Mar 20, 2012, 9:06 PM
    Hi Gordon,
    Do you mean "question/filter/hotpot" or "question/format/hotpot"? The latter apears in my system rather than the former.
  • Picture of Gordon Bateson
    Tue, Mar 20, 2012, 10:47 PM
    I mean "question/format/hotpot". Thanks for pointing that out.
  • Paul
    Tue, Mar 20, 2012, 11:17 PM
    Hi Gordon,
    Just another quick point: do we still need to upload the separate Import plug ins with the revised download?
  • Picture of Gordon Bateson
    Wed, Mar 21, 2012, 12:08 AM
    Paul, please ask any further questions on the HotPot forum, not here.
  • Picture of Cora Siu
    Mon, Jun 11, 2012, 6:46 PM
    where can I download the package HotPot question import for Moodle 1.9?
  • Picture of Gordon Bateson
    Mon, Jul 23, 2012, 7:19 AM
    Cora, the HotPot question import is included in standard Moodle 1.9, so you don't need to install it.

    Please ask any further questions on the HotPot forum:
    http://moodle.org/mod/forum/view.php?id=1599
  • Picture of Iñigo Zendegi Urzelai
    Tue, Oct 1, 2013, 9:29 PM
    Hi,

    Will this plugin be avalaible for Moodle 2.5 (and so)?

    Thanks
  • Picture of Gordon Bateson
    Mon, Oct 14, 2013, 5:48 PM
    Yes, this plugin works on all versions of Moodle 2.x
    Please ask any further questions on the HotPot forum:
    http://moodle.org/mod/forum/view.php?id=1599
Please login to post comments