Plagiarism: Source-code Plagiarism Plugin

plagiarism_programming
Maintained by Picture of Tri LE Tri LE
A plugin integrating 2 source code detection engines MOSS and JPlag into Moodle for programming assignments.
29 sites
41 downloads
4 fans
Moodle 2.0, 2.1, 2.2, 2.3

This plugin uses JPlag and MOSS as the underlying detection engines to provide an educational tool to raise awareness of students on code plagiarism. It permits:

  • Quick and easy scanning of assignments
  • Students' draft submission
  • Easy report navigation
  • Multiple scanning and history
  • Marking pairs of students with possible plagiarism

New version 1.3:

  • Corrections for reported bugs
  • Better interface and navigation
  • Code seeding: upload additional code (e.g. past assignments) to scan with the current assignment

Please take a look at the documentation for screen shoots and more details.

Two quick start video guides could be found at: http://www.screenr.com/Pzl8 and http://www.screenr.com/zfl8.

This plugin was tested with Moodle 2.0 to 2.3. However, it isn't available for use with Moodle 2.4 yet. A fix for compatibility with the latest Moodle version will be released soon.

Screenshots

Screenshot #0

Contributors

Picture of Tri LE
Tri LE (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Tri LE
    Fri, 30 Nov 2012, 2:28 PM
    Sorry! Temporarily disable it from several day for important bug fixes.
  • Picture of Britt Matych
    Mon, 22 Apr 2013, 3:33 PM
    It doesn't seems to work with moodle 2.4.3. The problems are the yui2-libaries. When I try to configure the plugin the system says: "Coding error detected, it must be fixed by a programmer: PAGE->yui2_lib() is not available any more, use YUI 2in3 instead, see MDL-34741 for more information."
  • Picture of Darren Bourke
    Tue, 6 Aug 2013, 9:43 AM
    Hi,
    When will versions compatible with 2.4 and 2.5 be released?
    Thanks
  • Picture of Jeff Maxwell
    Tue, 27 Aug 2013, 5:18 AM
    I as well would love to know if this add-on was going to be update for version 2.5 I just came across it and i really want to integrate it into my computer science courses.
  • Picture of Karl Engelbogen
    Tue, 15 Oct 2013, 4:54 AM
    any news on a version 2.5 update?
  • Picture of Helmond Io
    Tue, 25 Mar 2014, 5:00 PM
    May I know there's a release for Moodle2.4+, or a schedule for a new version of the plugin?

    Thanks.
  • Picture of Tri LE
    Fri, 4 Apr 2014, 10:03 AM
    Hi Helmond, a new version is under way, and it needs some testing. I hope to finish it at the end of April. Thank you.
  • Picture of Sam Black
    Tue, 8 Apr 2014, 2:00 AM
    I'll gladly help with any testing on 2.6+.
  • Picture of Michael Tanczos
    Wed, 21 May 2014, 8:30 PM
    Any updates?
  • Picture of Darren Bourke
    Tue, 5 Aug 2014, 2:01 PM
    Hi Tri,

    It would be great if this plugin could be made Moodle 2.7 compatible.

    Thanks, Darren
  • Picture of emma nnadi
    Thu, 11 Sep 2014, 2:44 PM
    This plugin is causing me much trouble. since i installed it. It kept saying yet to be installed. Each time i want to log into my page the plugin in checker will pop up. all effort to upgrade or uninstall has not worked. Please can someone help me?
  • Picture of emma nnadi
    Thu, 11 Sep 2014, 2:44 PM
    This plugin is causing me much trouble. since i installed it. It kept saying yet to be installed. Each time i want to log into my page the plugin in checker will pop up. all effort to upgrade or uninstall has not worked. Please can someone help me?
  • Picture of Tri LE
    Thu, 11 Sep 2014, 3:08 PM
    Hi Emma, what is the plugin you installed? Your Moodle version?
    I haven't seen someone reported an error like that?
  • Picture of Usman Riaz
    Wed, 24 Sep 2014, 8:20 PM
    Hi everyone,
    Kindly have a look at [1] and help me solve this issue. Suggestions by Justin seemed useless.
    [1] https://moodle.org/mod/forum/discuss.php?d=270109
  • Picture of Sam Black
    Thu, 26 Nov 2015, 11:44 AM
    Hello. Any hope for an update for 2.9 or 3.0?
1 2
Please login to post comments