Select Moodle version:

Activities: SCORM Cloud for Moodle

mod_scormcloud
Provides integration with the SCORM Cloud to give your Moodle courses access to a fully compliant SCORM 2004, 1.2 and AICC player.
Maintained by: Picture of Stuart Childs Stuart Childs

Sets

This plugin is part of set SCORM Cloud. Plugins from the set work the best when installed together.

By integrating with our SCORM Cloud product, this module enables you to use SCORM content within your Moodle courses. Our player is fully compliant with the SCORM 2004, SCORM 1.2 and AICC learning standards, giving you flexibility in the content you can provide to your learners.

We invite you to create a trial account to see if it meets your needs, and even contribute to the Moodle module if that's your thing. Please don't hesitate to contact us at support@scorm.com if you have questions, comments, or suggestions!

Contributors

Picture of Stuart Childs
Stuart Childs (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of richard boyder
    Fri, Sep 2, 2011, 6:37 PM
    Hi

    i have coppied the scormcloud folder into those 2 directories in the moodle install and get a error:

    mod/scormcloud scormcloud Non-standard (about to be installed)

    i click upgrade when it shows the above in the list.

    then get this error:

    Invalid get_string() identifier: 'pluginname' or component 'format_scormcloud'
    line 5884 of \lib\moodlelib.php: call to debugging()
    line 6474 of \lib\moodlelib.php: call to core_string_manager->get_string()
    line 21 of \admin\settings\courses.php: call to get_string()
    line 5706 of \lib\adminlib.php: call to require()
    line 2691 of \lib\navigationlib.php: call to admin_get_root()
    line 2599 of \lib\navigationlib.php: call to settings_navigation->load_administration_settings()
    line 583 of \lib\pagelib.php: call to settings_navigation->initialise()
    line 599 of \lib\pagelib.php: call to moodle_page->magic_get_settingsnav()
    line 132 of \blocks\settings\block_settings.php: call to moodle_page->__get()
    line 280 of \blocks\moodleblock.class.php: call to block_settings->get_content()
    line 232 of \blocks\moodleblock.class.php: call to block_base->formatted_contents()
    line 895 of \lib\blocklib.php: call to block_base->get_content_for_output()
    line 947 of \lib\blocklib.php: call to block_manager->create_block_contents()
    line 342 of \lib\blocklib.php: call to block_manager->ensure_content_created()
    line 6 of \theme\fusion\layout\general.php: call to block_manager->region_has_content()
    line 650 of \lib\outputrenderers.php: call to include()
    line 608 of \lib\outputrenderers.php: call to core_renderer->render_page_layout()
    line 2118 of \lib\outputrenderers.php: call to core_renderer->header()
    line ? of unknownfile: call to core_renderer->fatal_error()
    line 1241 of \lib\setuplib.php: call to call_user_func_array()
    line 328 of \lib\setuplib.php: call to bootstrap_renderer->__call()
    line 328 of \lib\setuplib.php: call to bootstrap_renderer->fatal_error()
    line 984 of \lib\upgradelib.php: call to default_exception_handler()
    line 1428 of \lib\upgradelib.php: call to upgrade_handle_exception()
    line 311 of \admin\index.php: call to upgrade_noncore()

    Plugin "mod_scormcloud" is defective or outdated, can not continue, sorry.


    My moodle version is Moodle 2.1.1+

    Please help if you are able smile
Please login to post comments