Activities: Questionnaire

mod_questionnaire
Maintained by Picture of Mike Churchward Mike Churchward
Custom Survey Creation
8638 sites
7k downloads
76 fans
Build passing

Create your own surveys using this tool.

SUPPORT DISCUSSION: http://moodle.org/mod/forum/view.php?id=2642

NOTE: If you are upgrading to Moodle 2.3 or greater, make sure you have upgraded the questionnaire module to the latest version of Moodle 2.2, in your Moodle 2.2 codebase before upgrading to Moodle 2.3 or greater.

DEVELOPERS NOTE - Questionnaire is tracked in Github at https://github.com/remotelearner/moodle-mod_questionnaire. Contact Mike Churchward if you want "push" access.

(originally based on phpESP)

/plugins/mod

Screenshots

Screenshot #0

Contributors

Picture of Mike Churchward
Mike Churchward (Lead maintainer)
Picture of Joseph Rézeau
Joseph Rézeau: Former co-maintainer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Marinda Faasen
    Tue, 5 Jul 2016, 9:54 PM
    I upgraded the past weekend from 2.8 to 3.1. And since then all images are unavailable in any of the question types. When I edit the question, the image displays, but when I view, the images are gone. I went to through the forums and it seemed to be a problem in some of the earlier versions caused by add_slashes, but apparently it was fixed. I cannot figure out what is causing the problem now.
  • Picture of Corrado Speroni
    Tue, 8 Nov 2016, 2:02 AM
    Hi, I want to ask about Questionnaire anonimity. I'm using moodle 3.1.2 and I have created many anonymous questionnaires as survey for our courses. The questionnaires are anonymous, and the students can see their answers after completion. They tell me that the answers collection is not based on answer order but in alphabetical order: the final report not shows the names, but the answers are collected based on the students alphabetical order. This break the anonymity. It is true? It is possible to fix? Many thanks.
  • Picture of Alex Ferrer
    Mon, 5 Dec 2016, 8:04 PM
    Hi.
    Is there any way to export the results in pdf format?
    If not, could it be contemplated for future updates?
    Thanks.
  • Picture of Anatoly Govorov
    Sat, 24 Dec 2016, 3:52 AM
    Hello!
    I noticed that after upgrade to 3.2 sending of messages to non-respondents stopped working. It fails to save students selected as recipients - after pressing Send page reloads, no one is selected and message 'no users selected' is displayed. Seems like upgrade to 3.2 messed with passing ids of selected students to send method
  • Picture of Mike Churchward
    Wed, 4 Jan 2017, 12:19 AM
    Hi Anatoly. I have created CONTRIB-6642 to deal with this.
  • Picture of Edmund Evangelista
    Sun, 5 Feb 2017, 5:05 PM
    When I view the questionnaire using Moodle Mobile, it says that this plugin does not support it. Can you please confirm?
  • Picture of Mike Churchward
    Mon, 6 Feb 2017, 10:04 PM
    That support has not been added yet - see https://tracker.moodle.org/browse/CONTRIB-6222
  • Picture of Edmund Evangelista
    Wed, 8 Feb 2017, 5:02 PM
    Mike is there a way to display the questions one at a time?
  • Picture of Mike Churchward
    Thu, 16 Feb 2017, 1:40 AM
    @Edmund - Adding a page break after a question means that any question after will not be displayed until you advance to the next page.
  • Picture of Edmund Evangelista
    Thu, 16 Feb 2017, 12:43 PM
    Thank you so much Mike. You made my day. I did not realize that there's a page break option among the question types. Cheers.
  • Picture of Derek Chaplin
    Tue, 14 Mar 2017, 1:22 AM
    First, thanks for this great plugin! Very nice and useful

    However, I have a problem when reviewing the responses for rate scale questions (1to5); the radio buttons are offset to the left outside answer boxes so they don't line up with the rating scale above them.

    I was able to add the following custom CSS to the theme via the theme custom CSS area:

    .radio input[type="radio"], .checkbox input[type="checkbox"] {
    float: none !important;
    margin-left: 2px !important;
    text-align: center !important;
    }

    I'm running Moodle 3.2.2 using the Adaptable theme (latest version ) I haven't tested it with other themes.
  • Picture of Renato Balbi
    Wed, 15 Mar 2017, 6:12 PM
    Hello Mike, I'm using your module to create an employee evaluation survey, a boss evaluates several employees. How can I do this using only one questionnaire and still still be able to identify which evaluation is pertaining to each employee? Thank you
  • Picture of Mike Churchward
    Thu, 16 Mar 2017, 4:51 AM
    @Derek - Sounds like this may be specific to the theme. Can you see if you see the same problem with Boost and/or Clean?
  • Picture of Mike Churchward
    Thu, 16 Mar 2017, 4:54 AM
    @Renato - Set the questionnaire response type to "respond many". Add a text field for an employee identifier and have the evaluator fill that in for each evaluation. If this isn't what you want, I would suggest asking in the questionnaire forum (http://moodle.org/mod/forum/view.php?id=2642).
  • Picture of Mike Churchward
    Wed, 29 Mar 2017, 9:53 PM
    @Derek - I believe the problem you are describing may be the same one discussed here - https://moodle.org/mod/forum/discuss.php?d=348281 If so, there is a fix in https://tracker.moodle.org/browse/CONTRIB-6809
1 2 3 4 5 6 7
Please login to post comments