Your Moodle version

Activities: OU wiki

mod_ouwiki
Maintained by Picture of sam marshall sam marshall, Picture of Jason Platts Jason Platts, Picture of Alan Thompson Alan Thompson, Picture of Alan Carter Alan Carter
Alternative wiki. Simple wiki designed for teaching and learning.
10k
1

This is an alternative wiki that you can install into standard Moodle.

It does not replace the standard wiki, and operates alongside it. The key
intention of this wiki is to provide a simple teaching tool suitable for
student use with minimal required training. It is in no way intended to be a full-fledged wiki like MediaWiki. For example, there is no wiki syntax except for links with two square brackets.

Please note: This plugin is no longer supported in Moodle Tracker. All support requests should be via the GitHub repository issue tracker (https://github.com/moodleou/moodle-mod_ouwiki).

Sets

This plugin is part of set Open University.

Contributors

Picture of sam marshall
sam marshall (Lead maintainer)
Picture of Jason Platts
Jason Platts: Current lead developer
Picture of Alan Thompson
Alan Thompson: Technical developer
Picture of Alan Carter
Alan Carter: Technical developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Sarah Schrire
    Tue, May 21, 2013, 2:54 AM
    OK, thanks for the detailed explanation. I understand the considerations.
  • Picture of Stephen Overall
    Sat, Jun 8, 2013, 2:31 AM
    Any news on when to expect the happy news of a MOODLE_24_STABLE branch for the OU Wiki?

    As Sam Marshall wrote 22 May 2013: "The tested version will be available in the MOODLE_24_STABLE branch of each [OU] plugin in GitHub at some point early in June 2013. (You can pester me online if I have forgotten to update it!)"

    http://learn.open.ac.uk/mod/oublog/viewpost.php?post=144632
  • Picture of Jason Platts
    Mon, Jun 10, 2013, 3:14 PM
    FYI. The 2.4 stable branch creation and release via Moodle plugins should be by the end of this week.
  • Picture of Jason Platts
    Thu, Jun 20, 2013, 7:02 PM
    FYI. There is a known bug around templates in the 2.4 release version of ouwiki. This has been fixed in the GitHub master and 24 stable branch (an update to locallib.php).

    This bug will cause issues for users that currently use xml wiki templates on any activities, it won't do so when using the new zip template format.
  • Picture of Andrew Nokes
    Thu, Aug 1, 2013, 6:51 AM
    Hi Jason, do you know if/when this plug-in will be available for Moodle 2.5? I was looking for a solution to using templates with individual wikis and came across this plug-in, which some users have recommended, but unfortunately our site is currently on 2.5.
  • Picture of Jason Platts
    Thu, Aug 1, 2013, 3:42 PM
    There will be an 'official' 2.5 release at the beginning of December. However, we are due to start migrating code to 2.5 in the next month so any updates will be fed into the master branch on GitHub when they are committed. If there are any 2.5 specific issues they can also be raised on GitHub and be addressed before that Dec release.
  • me
    Thu, Feb 6, 2014, 1:48 AM
    Is there a release date for OU wiki/blog for 2.6? Would one be available by March 1 since 2.7 release date is looking like March? Love the tools and would like to use them in the new systems. Thanks.
  • Picture of sam marshall
    Thu, Feb 6, 2014, 2:16 AM
    I am not the maintainer of OU blog/wiki any more but I can answer the question about OU release schedule in general. (We should really add this to the plugin descriptions and put it in bold as people keep asking, but I'll leave that for Jason to decide!)

    The OU release schedule is currently that we release our live versions in June or December, slightly more than six months after the Moodle release. For example, we will be releasing our Moodle 2.6 version in June 2014.

    If you want a live, fully tested version of our plugins that should be suitable for use in 'real' systems, you will need to match this release schedule - i.e. do not update to Moodle 2.6 until after June 2014, and Moodle 2.7 until December 2014, etc. This has the added advantage that you will be using a more reliable Moodle version rather than a bleeding-edge .0 version.

    If you are willing to use an untested developer version of our plugins, these normally start working on the 'master' branch of our GitHub repository about three or four months before a release. For example, the Moodle 2.6 versions are gradually becoming available on the master branch in February 2014. There is no announcement or branch or anything for this - we just fix issues in 2.6 as spotted. Community members can help by reporting/submitting fixes for any bugs caused by the upgrade at this point.

    In addition to this, depending on what changed in the Moodle version, sometimes (for instance) the 2.5 version might basically work in 2.6, so if you feel like living dangerously you could give it a try.
  • Picture of Blair F.
    Thu, Aug 28, 2014, 5:57 AM
    One of our instructors was getting the following error message when her or her students tried to view/edit the OU Wiki:

    "error/Sub-wikis is set to 'One wiki per group'. Please change Group mode to 'Separate groups' or 'Visible groups'."

    Here's how I ended up fixing it:
    1) Turn off the FORCED group mode in the course settings.
    2) Add the "separate groups" option in the Wiki and save the change (this was previously unchangeable because group mode was being forced).
    3) Turn back ON the FORCED group mode in the course settings.
  • Picture of Rob Clark
    Fri, Sep 12, 2014, 11:03 AM
    Is there a release date for the version that works with Moodle 2.7 yet? I'm having troubles with the 2.6 version in 2.7.
  • Picture of Ger Tielemans
    Tue, Sep 30, 2014, 6:03 PM

    Ger Tielemans

    Tue, 30 Sep 2014, 11:02 AM





    version number in latest 2.6 release is $module->version = 2014042800;

    but update mechanism shouts that it is 2014042801
  • Picture of Jason Platts
    Tue, Sep 30, 2014, 6:09 PM
    2014042800 is the correct version number, there has never been a 2014042801 version of the plugin.
  • Picture of Bobby Siegfried
    Fri, Oct 24, 2014, 10:37 PM
    Is there a firm release date set for the version that supports Moodle 2.7? Cheers,
    Bobby
  • Picture of Jason Platts
    Fri, Oct 24, 2014, 10:41 PM
    Early December is the official release. However you can use Master now (which should be ok, but - disclaimer - is not fully release tested).
  • Picture of Bobby Siegfried
    Fri, Oct 24, 2014, 10:49 PM
    Thank you Jason. That should work well. We are not planning to roll out the upgrade until the end of December, so for now we can use the "unofficial" release for our testing and install the final release when it's available. Thanks for the quick response. We will be happy to report our testing results if that's helpful.
1 2 3
Please login to post comments