Activities: Mindmap

mod_mindmap
Maintained by asdTõnis Tartes
This is the original Mindmap module for moodle formerly found on ekpenso.com.
1295 sites
775 downloads
31 fans
Moodle 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6

Mindmap module for Moodle 2.x & 3.x

------------------------

This is the original Mindmap module for moodle formerly found on ekpenso.com. 

This Mindmap module allows you to create and save simple mindmaps from within moodle.


Quick install instructions:

- Copy this "/mindmap"-Folder and place it in your /mod directory

- Go to your admin area and "Notifications"

- That's it


Have fun!


Thanks to original mindmap module author: Andreas Geier

Link: https://github.com/functino/Moodle-Mindmap-Module


Thanks goes to FatCow Webhosting for the new Mindmap icon. 

License: Creative Commons(Attribution 3.0 United States)

//20.10.2017 -version 2017102000

+Moodle 3.0+ compatibliy.

+Code cleanup.

+Added getflash button. Clicking it will prompt whether to allow flash or not in chrome.


This version is compatible with Moodle 2.6 and up. 

Please download older version for Moodle 2.5 and below.


Screenshots

Screenshot #0

Contributors

asd
Tõnis Tartes (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • asd
    Fri, May 20, 2016, 2:59 PM
    I'm glad it worked out smile
  • Photo de Patrick Viney
    Thu, Jul 28, 2016, 5:57 PM
    Hi, we've just moved to Moodle 3.1. Have you tested Mindmap on this version yet ?
  • asd
    Thu, Jul 28, 2016, 6:42 PM
    Hi! No i have not yet tested it in 3.1. If you encounter any issues let me know!
  • Picture of R Kasi
    Fri, Oct 14, 2016, 12:47 AM
    Sry for this question, which might be stupid anyway but I'm not quit sure about the Mindmap activity on moodle works:
    Do you think it is possible that I have 15 students working on one mindmap at the same time?
  • asd
    Mon, Oct 24, 2016, 8:43 PM
    Unfortunately no.. The current method how this plugin works, does not support synchronous editing.
  • Picture of Alvaro Altamirano
    Wed, Oct 18, 2017, 7:07 AM
    Hi Tõnis:

    I have installed the activity in my moodle 3.1, but the toolbar is not displayed in Chrome, only in Firefox. What can be cause this?
  • asd
    Sat, Oct 21, 2017, 7:10 PM
    Hi Alvaro!

    Make sure Google Chrome is not blocking Flash execution on your Moodle site. If flash is blocked nothing will appear.
  • Me
    Wed, Nov 1, 2017, 12:15 PM
    Hi Tonis, great plugin, thanks!!
    1. I don't get it how I can create a sub-topic to a topic. "Insert key" - don't have on my MacBook. Any tips?

    2. How about adding the possible functionality of making a topic into a clickable link?
  • asd
    Wed, Nov 1, 2017, 5:29 PM
    Hey!

    1. If you dont have "Insert key" on Mac then you can use the Mindmap toolbar Insert node(Plus icon) button to add new nodes. You could also use Google to find out which button works on Mac as insert key, like PC has.

    2. Unfortunately this plugin uses old legacy flash application as base and it is not anymore extendable. Maybe in near future i get the time to build a HTML5 based application and there would be possible to make that change you asked.
  • Picture of Michal Wazana
    Sun, Mar 4, 2018, 7:39 PM
    hey, a few questions,
    1. is this activity is responsive?
    2. is there an option to a group map/ shared map for all the class?
    3. will there be support on moodle 3.4,3.5 ex..?
    4. does this plugin support information security?
    thanks a lot!
  • asd
    Wed, Mar 7, 2018, 4:25 AM
    Hey!
    1. No. Its flash based and does not work on mobiles.
    2. Groupings available only if you create separate maps and add restrictions with Moodle core accessibility possibilities.
    3. Yes. As long as flash exists.
    4. It is as secure as your Moodle. It does not encrypt nodes..
  • Picture of Dhiraj Upadhyaya
    Thu, May 24, 2018, 4:09 PM
    Can this plugin be installed for Moodle 3.5 Latest version
  • Ricardo Caiado
    Mon, Dec 3, 2018, 7:29 PM
    Can this plugin be installed for Moodle 3.6 Latest version
  • Picture of Ericka Zuniga
    Thu, Apr 25, 2019, 12:31 AM
    Can this plugin be installed for Moodle 3.6.2+ with no errors or will this plugin be updated for Moodle 3.6.2+ (Build: 20190215)?
  • Picture of onlinedigital marketing
    Thu, Apr 25, 2019, 11:55 PM
    Thanks For Shareing thisValuable information
1 2 3
Please login to post comments