Select Moodle version:

Activities: Kitmoo

mod_kitmoo
Module to create graphical environments in a course.
Maintained by: Jair R. Jair Alexander Riaño Castañeda, Picture of Andrés Rodríguez Andrés Rodríguez
for Moodle
2.0, 2.1, 2.2, 2.3

English

This module allows the teacher of a course in graphical environments to create a virtual classroom in an easy and quick. By means of this module the teacher can establish a bottom to the course, establish icons that assume to other activities inside the platform (for example: Wikis, Chats, Forums, between others.) achieving hereby that the students see in more dynamic form the activities.

Español

Este módulo permite al profesor de un curso poder crear entornos gráficos en su aula virtual de una manera fácil y rápida. Por medio de este módulo el profesor puede establecer un fondo al curso, establecer íconos que se atribuyen a otras actividades dentro de la plataforma (por ejemplo: Wikis, Chats, Foros, entre otros.) logrando de esta manera que los estudiantes vean en forma más dinámica las actividades.

Screenshots

screenshot

Contributors

Picture of Andrés Rodríguez
Andrés Rodríguez
Jair R.
Jair Alexander Riaño Castañeda (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Jair R.
    Tue, Nov 13, 2012, 12:17 AM
    ok, working on this.

    Thank you.
  • Picture of German Valero
    Tue, Nov 13, 2012, 10:05 AM
    Hola,
    De acuerdo a AMOS (http://lang.moodle.org/mod/forum/view.php?id=1 ), las traducciones (diferentes del inglés original) ya no deben incluirse en los archivos de los plugins.

    Mandé las traducciones del idioma español que estaban en el archivo al responsable del idioma español internacional (Benito Arias) y las subí al español de México.

    De acuerdo al sitio anterior, "Good news! Almost all contributed plugins published in Moodle plugins directory have been imported into AMOS and are ready to be translated. As a part of MDLSITE-1836, changes were made on both AMOS and Plugins sites so that these two are now integrated.

    From now on, whenever a maintainer publishes a new version of their contributed plugin, strings are automatically sent via a web service to the AMOS. This process respects the supported Moodle version setting so the strings appear at the correct Moodle branch in AMOS.

    This works for new plugins that will be uploaded into Plugins in the future, too. With the exception that the strings appear in AMOS only after when the plugin is approved as a part of its validation.

    This new mechanism works for all plugins that were uploaded into the Plugins directory and are written for Moodle 2.0 and higher. Contributed plugin maintainers are now encouraged to transfer all their current code to this new scheme:

    The plugin code itself should now contain just the English strings in the /lang/en folder.
    All other translations are to be maintained via AMOS and you as the plugin maintainer do not need to look after them any more! Translated strings for contributed plugins are part of the standard language packs generated by AMOS.
    If your plugin code currently contains some translation, you (as the plugin maintainer) should submit it as a contribution into AMOS prior to dropping it from your plugin's source code. AMOS stage page provides a form to upload strings from an existing PHP file. You are supposed to import all non-English string files you currently have shipped with your plugin (eg. /lang/cs/yourmodule.php) into the AMOS stage and then submit them language pack maintainers.

    We believe that this new procedure will make translation of contributed plugins much easier than it ever been - for both the plugin maintainer and translators, too.

    Should you have any questions regarding this new feature, do not hesitate to ask in AMOS support forum at this site.

    Thank you all for you great work on contributed plugins and their translations!"

    Agradeciendo su atención, queda de Ustedes,
    Germán Valero, traductor del español de México
  • Picture of German Valero
    Tue, Nov 13, 2012, 10:30 AM
    Hi,
    Trying the Kitmoo plugin I get the following error when I try to add a URL:

    "Detectado un error de codificación, debe ser corregido por un programador: Function course_allowed_module no longer supports numeric module ids. Please update your code to pass the module name."
  • Jair R.
    Wed, Nov 14, 2012, 9:55 AM
    German, gracias por tus comentarios que aportan a este trabajo.

    Con respecto a los idiomas la verdad no tenia conocimiento de esto, por esta razón lo traduci al español. Y el error que encuentras, trataré de solucionarlo, aunque si pudieras comentarme más de este problema, te estaré agradecido.

    Aunque en este momento me encuentro realizando unos proyectos para la Universidad, tratare de trabajar en lo que me dices lo más pronto posible.

    Att:
    Jair Riaño.
  • Picture of Melinda Nolan
    Tue, Apr 16, 2013, 8:51 AM
    Hello, I think your plugin would be very useful for our teachers. Currently, we have a Moodle 2.4.3+ site. Can you tell me if there will be an updated Kitmoo version for Moodle 2.4/ I have installed the Kitmoo plugin, which is currently displays an error message, which reads 'make sure this is an activity or resource'. Following this another error is displayed - The requested URL/course/kitmoo_modedit.php was not found on this server. Thank you for any assistance. Mel
  • Picture of Melinda Nolan
    Tue, Apr 16, 2013, 8:54 AM
    Further to my previous comment, I can create a Kitmoo activity, add a theme but when I attempt to drag a resource onto the graphical environment, the above error is displayed. Thanks.
  • Jair R.
    Tue, Apr 16, 2013, 9:56 PM
    copy the file kitmoo_modedit.php in the path: /course/ of your Web server.
  • Picture of Rafael David
    Sun, Jul 21, 2013, 6:06 PM
    Hola, antes de nada enhorabuena por este modulo, y tras esto, queria hacer una pregunta, resulta que tengo el modulo instalado en moodle 2.5 y cuando intento incorporar un icono, de foro por ejemplo, me da un error: Detectado un error de codificación, debe ser corregido por un programador: Function course_allowed_module no longer supports numeric module ids. Please update your code to pass the module name.
    Ya he copiado kitmoo_modedit.php en la carpeta curso de moodle en el servidor.

    Gracias de antemano por vuestras respuestas
  • Jair R.
    Mon, Jul 22, 2013, 11:33 PM
    El problema es la versión de Moodle utilizada, ya que en un principio el módulo fue desarrollado para la versión 2.0, 2.1, 2.2, 2.3. Tal vez más adelante se actualice este módulo para que tenga más posibilidades que el actual y que funcione en las versiones más recientes de Moodle.
Please login to post comments