Your Moodle version

Activities: Etherpad and Moodle Integration

mod_etherpad
Maintained by Picture of Chris Kenniburg Chris Kenniburg
Etherpad and Moodle as a course activity. Allows the teacher to add an Etherpad activity directly from the moodle course.
2k
292
2
Moodle 2.2, 2.3, 2.4, 2.5

We are pleased to announce a Moodle module that makes collaborative writing possible in Moodle. Real time editing inside of Moodle brings even more functionality to the worlds most popular Educationally focused Learning Platform. If you want to try it out before you install you can use our sandbox Etherpad deployment at beta.etherpad.org.   If you require any assistance deploying Etherpad Lite or help installing new plugins or features then please get in touch.

Please note that in order to use this plugin you will need to have access to an Etherpad setup.  You can download and install Etherpad on your own server or you can use PrimaryPad.

PrimaryPad offers a hosted Etherpad Lite instance too that can be leveraged so you don’t need to host your own, this service comes with an uptime guarantee and SLA that should provide your school with the piece of mind and simplicity of deployment.

Watch a video guide for how to get started.

Further reading ODT PDF DOC

This plugin was developed in collaboration with the Etherpad Foundation, Primarypad, and Dearborn Public Schools (Dearborn,Michigan).  

This will only work with ETHERPAD - LITE.  It will not work with the older Etherpad.

 

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Chris Kenniburg
Chris Kenniburg (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Ryan Tandy
    Thu, Oct 10, 2013, 12:58 AM
    Chris, the latest release here seems to have some changes that aren't in the GitHub repository. Is it possible to get that updated? Might also be nice to set the source control URL of this plugin page to point to that repository.
  • Picture of Dirk Grunwald
    Tue, Dec 10, 2013, 2:17 AM
    I've installed the module and it works well on Moodle 2.6, except that it throws an exception when doing backups (I recently enabled auto-backups). Here's the error - any suggested fix?

    [Mon Dec 09 10:50:08 2013] [error] [client 128.138.201.72] Default exception handler: Exception - Empty or No \
    Response from the server Debug: \nError code: generalexceptionmessage\n* line 95 of /mod/etherpadlite/etherpad\
    -lite-client.php: UnexpectedValueException thrown\n* line 43 of /mod/etherpadlite/etherpad-lite-client.php: ca\
    ll to EtherpadLiteClient->call()\n* line 266 of /mod/etherpadlite/etherpad-lite-client.php: call to EtherpadLi\
    teClient->get()\n* line 56 of /mod/etherpadlite/backup/moodle2/backup_etherpadlite_stepslib.php: call to Ether\
    padLiteClient->getHTML()\n* line 88 of /backup/util/plan/backup_structure_step.class.php: call to backup_ether\
    padlite_activity_structure_step->define_structure()\n* line 181 of /backup/util/plan/base_task.class.php: call\
    to backup_structure_step->execute()\n* line 211 of /backup/moodle2/backup_activity_task.class.php: call to ba\
    se_task->execute()\n* line 177 of /backup/util/plan/base_plan.class.php: call to backup_activity_task->execute\
    ()\n* line 120 of /backup/util/plan/backup_plan.class.php: call to base_plan->execute()\n* line 320 of /backup\
    /controller/backup_controller.class.php: call to backup_plan->execute()\n* line 426 of /backup/util/helper/bac\
    kup_cron_helper.class.php: call to backup_controller->execute_plan()\n* line 209 of /backup/util/helper/backup\
    _cron_helper.class.php: call to backup_cron_automated_helper::launch_automated_backup()\n* line 477 of /lib/cr\
    onlib.php: call to backup_cron_automated_helper::run_automated_backup()\n* line 81 of /admin/cron.php: call to\
    cron_run()\n
  • Picture of Shawarma Consumer
    Mon, Feb 3, 2014, 10:57 PM
    Hello,
    I am doing some stuff with Moodle. I set up one Moodle 2.5.2 on a CentOS server, and an Etherpad on a Ubuntu server. When I try to add an Etherpad activity, I get this error : "Exception : JSON response could not be decoded". We tried the same on another Moodle (2.5 too), and it worked perfectly. So, it should come from my CentOS configuration, but I haven't got any idea. I can just add that "php -i | grep -i json" ran on my CentOS web server gives me "json support => enabled" and "json version=> 1.2.1".

    Thanks in advance for your answer and sorry if it is not the best place to ask.
  • Martin Dougiamas
    Sun, Apr 6, 2014, 7:14 PM
    I've had a quick look at this because it's promising but the module appears to have a few problems preventing it from working. Is anyone willing to take up the maintenance of ths module and have the source code on github so people can contribute?
  • Picture of Si Wooler
    Tue, Apr 29, 2014, 8:43 AM
    Thank you for building this. It is a great plugin and a really useful resource for us. This might be a naive question, but is there a way to increase the height of the pad in moodle?

    Thank you
  • Picture of Chris Kenniburg
    Tue, Apr 29, 2014, 8:10 PM
    JS folder > etherpad.js file is where the settings are for building the etherpad display.
  • Picture of Chris Kenniburg
    Tue, Apr 29, 2014, 8:12 PM
    Martin, I think the errors you are getting might be related to JQuery. It has it's own package included with this plugin.
  • Hi Chris,
    I just want to inform you that we also developed an etherpad-lite module for moodle right at the same time as you did, but we didn't upload it to moodle.org yet.
    Now, that it is established at our university, we are submitting it to moodle.org and are waiting for approval right now.

    The module's github page is: https://github.com/moodlehu/moodle-mod_etherpadlite

    The additional features we decided we need include:
    - The user is only be able to access the pad, when he has access to the course.
    - It is possible to configure the etherpad server, so that only pads, which are created via moodle are allowed
    (Otherwise anyone who knows the url of the server could create and modify pads).
    - Backup the module via moodle's internal backup routine

    We invite anybody who's interested to comment and contribute.

    Best Regards
    Timo Welde
    (Humboldt-Universität zu Berlin)
  • Picture of Chris Kenniburg
    Thu, May 15, 2014, 12:14 AM
    Timo, That is great news. This plugin is old and hasn't been modified in quite some time. We initially paid to have this developed to get the ball rolling and it was our intent that someone in the community could take this and more fully develop it or create a completely new plugin that is more robust. I think this plugin worked for the time and look forward to checking out your plugin.
  • Oam
    Fri, Jul 18, 2014, 7:37 PM
    Hello !

    In debug mode, I've got some errors easy to fix : (Moodle 2.5)

    Invalid get_string() identifier: 'etherpad:debugger' or component 'mod_etherpad'. Perhaps you are missing $string['etherpad:debugger'] = ''; in mod/etherpad/lang/en/etherpad.php?

    Invalid get_string() identifier: 'etherpad:student' or component 'mod_etherpad'. Perhaps you are missing $string['etherpad:student'] = ''; in mod/etherpad/lang/en/etherpad.php?

    Invalid get_string() identifier: 'etherpad:teacher' or component 'mod_etherpad'. Perhaps you are missing $string['etherpad:teacher'] = ''; in mod/etherpad/lang/en/etherpad.php?

    Can you add the missing lines in lang/en.php ?


    Thanks !
  • Matt Bury
    Thu, Aug 21, 2014, 6:39 AM
    Hi, thanks for everyone's contributions to this project. I think this could be a great module. It installs OK on Moodle 2.7 but returns a JSON error if you try to create an instance. I created a free pad (primarypad.com) and tried some variations of the URL and API key but still got JSON errors.

    Would love to see some progress on this smile
  • Picture of Jesse H
    Tue, Oct 7, 2014, 12:08 PM
    This seems like a great plugin but I cant get it to work.

    1. Unclear where to find the API key when using a hosted service.
    2. The hosted primarypad.com seemed very slow and unresponsibe
  • Picture of Chris Kenniburg
    Tue, Oct 7, 2014, 7:42 PM
    Jesse H,
    1. The host would need to provide this to you.
    2. I do not operate primarypad.
    This plugin is designed to work with Etherpad installed on a server. You need to run it yourself. Then this plugin allows you to connect and use Moodle with Etherpad.
  • Anthony Borrow
    Fri, Feb 20, 2015, 3:49 AM
    Chris - Would it be possible to get the source code and tracker URLs properly setup and updated? Peace - Anthony
  • Picture of Chris Kenniburg
    Fri, Feb 20, 2015, 3:53 AM
    We don't have source code other than the project download. It is not on github.
1 2 3
Please login to post comments