General plugins (Local): Moodle welcome

local_welcome
Maintained by Picture of Bas Brands Bas Brands
Sends a welcome message to new users, sends a notification to a moderator of the new user creation
930 sites
916 downloads
47 fans

Usage:

This plugin sends one email message to users that are new in Moodle and one email to a moderator.

This will work to all standard moodle authentication systems:

  • manually created users
  • users that signed up
  • users authentication through LDAP
  • all other standard authentication systems

Configuration can be done using:

Site administration->Plugins->Local plugins->Moodle welcome

Configurable fields are:

enable / disable welcome messages to users
enable / disable welcome messages to moderators

message send to user
message send to moderator

message subject for user
message subject for moderator

send from firstname
send from lastname
send from email address

moderator email address

Installation:

Download and install in your /local folder in moodle's wwwroot

Run Moodle notifications,

Configure your email messages / moderators etc

Screenshots

Screenshot #0

Contributors

Picture of Bas Brands
Bas Brands (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Aida Debibi
    Fri, 17 Feb 2017, 6:53 PM
    Hi Bas,
    Plugin, very useful !
    Is it possible to send the password when the manual creation of an account ? (I want them to use the password that was generated for them).
    Thanks
  • Picture of Arkadiusz Baryła
    Tue, 28 Feb 2017, 4:50 PM
    Hi Bas,
    Does this plugin sends also email notification to moderator and users that are imported from file.
  • Picture of Bas Brands
    Wed, 1 Mar 2017, 7:01 PM
    That's correct. If you do not wish to see notifications when manually creating accounts uncheck the "manual" authentation option in the plugin welcome settings page.
  • Picture of Bas Brands
    Wed, 1 Mar 2017, 7:03 PM
    In reply to Aida Debibi. No this plugin activates after account creation. Once the account is created Moodle can only retreive the encrypted password.
  • Picture of Arkadiusz Baryła
    Mon, 6 Mar 2017, 5:27 PM
    Hi Bas,
    thanks for reply. I've a little problem, during import a list of users I've only get email notification to moderator for first user on list.
    I get a moderator notification about adding user only for the first user in the list, the remaining notification I don't received any.
  • Picture of allen blanchard
    Mon, 6 Mar 2017, 11:38 PM
    Dear Bas,
    Thank you for your effort on this plugin. It appears you have done a fine job with a very needed too. The plugin is not working for us, however, and I'm hoping you may have some insight. We're running 3.1.1 and the plugin installed successfully. Set up appears correct but when we test with a New Registration, your plugin's email is not sent to user and nothing is sent to the Administrator/Moderator. Instead the moodle system sign up notification email is sent. If you can direct us where to look or what to reset, I would appreciate it. Thank you.
  • Picture of Bas Brands
    Sun, 12 Mar 2017, 9:34 PM
    Have you checked the plugin settings page? Is the manual authentication method enabled?
  • Picture of Sam Villamizar
    Fri, 7 Apr 2017, 6:31 PM
    Bas, is it possible to create different welcome messages for different courses? Or the plugin supports only one message for the whole Moodle site? I have instructors who would like to personalize their welcome messages and let their newly added students know what their expectations are, for this they need to create individual welcome messages. Thank you for letting me know.
  • Picture of Bobby Loscko
    Thu, 20 Apr 2017, 11:07 PM
    Bas,

    I have installed the plugin and it seems to work for the moderator message, but the new students I'm registering are not receiving an email. Do you have any ideas abut what may be causing this?
  • Picture of Bas Brands
    Fri, 21 Apr 2017, 4:31 PM
    Hi Bobby. Have you turned the plugin on for the email and manual authentication methods?
  • Picture of Bobby Loscko
    Fri, 21 Apr 2017, 9:40 PM
    Yes I have verified that the plug in is active and the manual authentication method has the box check. The email goes out to the administrator almost immediately but I created student accounts with two other personal email addresses and I didn't receive anything to either of them. Does the plug in look for the email address in a field other than the "email"?
  • Picture of Bas Brands
    Fri, 21 Apr 2017, 10:33 PM
    Okay, and have you enabled the message_user_enabled tickbox too?
  • Picture of Bobby Loscko
    Fri, 21 Apr 2017, 11:06 PM
    Yes sir, hat's the frustrating part. The plug in is well laid out and easy to set up and can't figure out for the life of me why only half is working. I've been looking at every setting I can think of in our email system that might be causing a conflict, but I can't see anything. IS there anything in the site admin you can think of that I could take a look at?
  • Picture of Bas Brands
    Fri, 21 Apr 2017, 11:31 PM
    If there is an issue sending email that might show up in your server logs. But there is no way to see that in Moodle logs. You could try some other email addresses too but other than that I don't know whats going on.
  • Picture of Bobby Loscko
    Sat, 22 Apr 2017, 12:09 AM
    Ok thank you very much. I'll see what I can find out from the logs.
1 2 3 4 5 6 7
Please login to post comments