Moodle App additional features

General plugins (Local) ::: local_mobile
Maintained by Juan Leyva, Dani Palou
Supports all features added to the latest Moodle App releases
Latest release:
2479 sites
561 downloads
108 fans

Local plugin for adding new features to the current Moodle Mobile app.

THIS PLUGIN IS NOT NECESSARY FOR MOODLE 3.5 ONWARDS

This add-on provides new features and web services which are currently only available in Moodle 3.5 onwards.

This plugin is officially developed and maintained by Moodle HQ

How it works

Once installed the plugin creates a new service "Moodle Mobile additional features".

The Mobile app checks if this service is enabled. If not, the Mobile app falls backs to the standard core Mobile app service.

Installation instructions and additional information:

https://docs.moodle.org/en/Moodle_Mobile_additional_features

Sets

This plugin is part of set Moodle Mobile app.

Screenshots

Screenshot #0
Screenshot #1

Contributors

Juan Leyva (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Tue, Mar 14, 2017, 5:51 PM
    Hi Juan, this has been refererd in discussion https://moodle.org/mod/forum/discuss.php?d=348499#p1408278 as last post. Cheers !
  • Thu, Mar 23, 2017, 1:35 AM
    Is this plugin still **required** if you're running Moodle 3.2 and wish to use SSO? If not, then I don't understand why there's a 3.2-compatible version of the plugin? Are there other features this plugin provides to a Moodle 3.2 site beyond SSO?
  • Thu, Mar 23, 2017, 4:39 PM
    Hi Brian, this plugin is not required for SSO in 3.2, but it is also used to backport WebServices. For example, it can be used to include some WebServices created for Moodle 3.3, that way the Mobile app can support more things without having to update your Moodle.
  • Fri, Mar 24, 2017, 6:27 AM
    Hi Dani -- Thanks very much for the quick response. I do have one more question... maybe more of a clarification needed. The documentation for the plugin (https://docs.moodle.org/32/en/Moodle_Mobile_additional_features) states that auto login guest must be disabled. Yet, with 3.2, it apparently is no longer required that auto login guest be disabled (https://moodle.org/mod/forum/discuss.php?d=335133#p1389946). If auto login guest does not need to disabled in 3.2 for SSO to work, does installing the local_mobile plugin change this in any way (as the documentation implies)? If auto login guest being disabled is no longer a requirement in 3.2, even with the local_mobile plugin installed, perhaps the documentation should clarify this? Thanks very much.... Brian
  • Fri, Mar 24, 2017, 3:44 PM
    Hi Brian, I clarified it a bit. I think it should work in Moodle 3.2 onwards (we haven't being able to reproduce the problem any more)
  • Fri, Aug 11, 2017, 1:00 AM
    I have version 1.9 of moodle, I can not use the play store app?

  • Thu, Sep 7, 2017, 1:08 AM
    Previously our Moodle Mobile is running fine. However, just recently after login via SSO authentication it fails to bring me back to the mobile app. Instead, it brings me to the browser version. What's wrong with Moodle Mobile? Our Moodle version is 3.1, and my /local/mobile is updated anyway.
  • Tue, Sep 12, 2017, 6:02 PM
    I also went over our logs and found out that the web service login failed with the following error "Web service authentication failed with code: "invalid_token".". However, I have enabled all the necessary settings in the configuration. In face, the same copy of our Moodle was installed in a test server and Moodle Mobile works fine on this server.
  • Tue, Sep 12, 2017, 8:00 PM
    Hi Edmund, I notice you posted about your problem in the Moodle for mobile forum - https://moodle.org/mod/forum/discuss.php?d=356166#p1444882 (I'm just posting the link for anyone else who is interested. It's probably easier to continue the discussion in the forum rather than here, as you can attach screenshots etc. to forum posts.)
  • Mon, Dec 11, 2017, 9:43 AM
    Hi, any plans of including Attendance into the moodle mobile app? It would be very handy for those of us doing blended learning.
  • Thu, Jul 26, 2018, 5:16 PM
    Quick question - the description states:

    "This add-on provides new features and web services which are currently only available in the latest Moodle versions"

    Does this mean that if I have Moodle 3.4 then I don't need to install this plugin because all the features are included in the 3.4 official release?


    Thanks

    Raad
  • Thu, Jun 20, 2019, 9:26 PM
    Hi! I want to Know does this plugin will effect the website view. I want a plugin which look like moodle new app (orange theme) in a webview on my native Android app, but that do not effect my website view which has old interface.
  • Ricardo Caiado
    Tue, Aug 18, 2020, 4:44 AM
    Is it compatible with 3.9+ version of Moodle?
  • Mon, Aug 31, 2020, 2:40 PM
    Hi Ricardo, as it says in the description the plugin isn't needed for Moodle 3.5 onwards. It won't add anything to your site, and it could cause some issues, so don't install it in a 3.9+ site.
  • Tue, Dec 15, 2020, 7:04 PM
    It says "THIS PLUGIN IS NOT NECESSARY FOR MOODLE 3.5 ONWARDS" but there are versions for moodle 3.6 and 3.7. Why is it not necessary for moodle 3.8 or 3.9?
1 2
Please login to post comments