Your Moodle version

General plugins (Local): MediaCore Package Configuration

Maintained by Picture of MediaCore Support MediaCore Support, Picture of Derek Harnanansingh Derek Harnanansingh
Provides LTI integration libraries and configuration setup that is used by the other MediaCore plugins.

MediaCore Package Configuration Features

The MediaCore package configuration plugin gives adds support for the MediaCore Chooser, Filter, and Repository plugins. It it part of the MediaCore Moodle plugin package.

MediaCore Chooser

MediaCore Filter

MediaCore Repository

Compatible with Moodle versions 2.3+


This plugin is part of set MediaCore.


Picture of MediaCore Support
MediaCore Support (Lead maintainer)
Picture of Derek Harnanansingh
Derek Harnanansingh: developer
Picture of Maddy Bentley
Maddy Bentley: support
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Plugins bot
    Fri, Jun 20, 2014, 4:27 PM
    Thanks for sharing this plugin with the Moodle community. Some formal issues were detected and reported by our automated plugin checker tool. Please review all the plugin checker results and fix the issues mentioned, if possible. These changes are typically pretty easy to make but if you have any questions just let us know.

    Please resolve these formal issues so that the plugin code can be fully reviewed and approved by my human colleagues.

    Further approval process is tracked at CONTRIB-5132, please join the discussion there.
  • Picture of MediaCore Support
    Sat, Jul 5, 2014, 3:14 AM
    All issues have been resolved and the plugin has been approved.
    See for full details.
  • Picture of Matthew Davidson
    Wed, Apr 15, 2015, 12:01 AM
    Love the continued development of MediaCore! Trusted Embeds is a brilliant addition that really empowers users and takes the burden of managing multiple permission systems at the same time. However, I just installed the new plugin and (even though I want trusted embeds enabled) it doesn't seem that disabling trusted embeds is working for me. I have a student in a course that, according to MediaCore collection permissions, is able to view a video he should not be able to view.
  • Picture of MediaCore Support
    Wed, Apr 15, 2015, 3:25 AM
    Hi Matthew, Thanks for getting in touch. Toggling the trusted embed plugin setting only affects embeds going forward. Any previous embeds will remain "trusted" unless you delete them and re-embed them manually. If this isn't what is causing the issue, can you please submit a support request to with a link to the media item you are referring to so we can dig into it? Thanks in advance.
  • Picture of Matthew Davidson
    Wed, Apr 15, 2015, 3:34 AM
    ah, thanks for that. I see now that a token is given from the chooser. Thanks!
Please login to post comments