Incubating: Kopere Dashboard

local_kopere_dashboard
Maintained by Picture of Eduardo KrausEduardo Kraus
Kopere Dashboard is a tool panel with reports, online users, backup, notifications and more.
999 sites
1k downloads
89 fans
Moodle 3.0, 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7, 3.8

Users online

This is the feature I've always wanted to develop and did it on Kopere Dashboard. It shows the users online in real time, which page they are accessing, whether the focus is on the page or not, the size of the Monitor, which browser they are using and if they are accessing a smartphone and which model of it.

All this in real time.

Click here and see more about Online Users

Import Users

A simple and complete system for importing users.

It is not necessary to send with fixed columns and after import it is just to link columns of the CSV with columns of Moodle.

Performace

Benchmark is the act of performing a set of operations in order to evaluate the relative performance of an object, usually running a series of tests and tests on it.

This part is an enhancement to the report_benchmark

Click here and see more about Performace

Static pages

Static pages are pages that you can create for a wide range of purposes. You can, for example, create a FAQ with the main information for the students or for those who access your moodle not being a student.

Click here and see more about static pages

Backup

System that generates complete bank backup and MoodleData in moodle easily and quickly.

Reports

Lots of useful reports.

Next versions will be developed system to be able to create new reports.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Eduardo Kraus
Eduardo Kraus (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Khoirul Umam
    Sat, Oct 26, 2019, 6:49 AM
    Thank you for sharing.

    I have installed in my site, but I have trouble when I want to export Course access report. I get this error message:

    The requested URL /local/kopere_dashboard/classname=reports&method=load_report&type=course&report=5&courseid=87&export=xls was not found on this server.

    Hopefully you will be give me support where is the trouble.

    Thanks
  • Picture of kranthi nimmy
    Wed, Jan 8, 2020, 2:08 AM
    Thanks fon sharing this valuable informationwith us, it is really helpful article!
  • Picture of Juan Carlos Jimenez
    Sun, Jan 12, 2020, 2:44 AM
    Hola he instalado kopere en moodle 3.6
    He intentado desinstalarlo pero no me deja.
    Como puedo desintalarlo manualmente?
    Gracias
  • Picture of Lauro Rosas Neto
    Fri, Jan 31, 2020, 8:49 AM
    Kraus, tudo bem? Espero que sim...

    No item de notificações quando tentamos remover uma notificação a tela fica escura, mas não abre nada.

    O que poderia ser?
  • Picture of I Komang Deny Supanji
    Sun, Mar 22, 2020, 7:43 AM
    Hi,
    im using moodle 3.7 and install the lates version of kopere dashboard, why the new features like online user didnt show? thank you
  • Picture of Максим Білецький
    Sun, Mar 22, 2020, 3:55 PM
    Hi,
    I have Error 500 with Release 2020062003 on Moodle 3.6.1 (Build: 20181205) with PHP 7.2.28 and mysql (5.7.16-10-log) (Linux).
  • Picture of guillaume crepin
    Sun, Mar 22, 2020, 4:14 PM
    Hello, moodle 3.8+ crash with this version, the my page is white and i had to delete it from hard. If not it's a great plugin !
  • Picture of Marko Marko
    Mon, Mar 23, 2020, 7:59 AM
    I have a version of M3.4 and upgrading to your latest version and I can't upgrade once I hit to upgrade it breaks the site

    HTTP ERROR 500

    Please help

    Thanks
  • Picture of Eduardo José Soares
    Wed, Mar 25, 2020, 10:16 PM
    Bom dia,
    Após atualizar o plugin "local_kopere_dashboard" para a versão mais recente 2.4.8 (Build 2020062004) em um moodle versão 3.8.1+ (Build: 20200124) PHP versão 7.1.33 não é mais possível acessar a interface do plugin, pois surge o seguinte erro: Exceção - Class 'local_kopere_dashboard\performancemonitor' not found
    Por gentileza, poderia verificar este problema?

    Agradeço antecipadamente.

    Eduardo.
  • Picture of muhammad najib
    Fri, Mar 27, 2020, 12:46 AM
    Thanks for sharing this great plugin, but I have problem on my model version 3.8.2. were plugin said need upgrade, I do it. then I was stuck on plugin check and there is information from this plugin if Higher version already installed!. what should I do to fix this problem, thank you very much.
  • Picture of Gary Newport
    Sat, Sep 19, 2020, 7:32 PM
    I have just installed the latest version due to upgrading Moodle (we had this on the previous version). Unzipping the downloaded files resulted in a directory/folder name that is NOT the one to be placed into the local directory; it has a number of erroneous parts to it, such as the author's name.

    More concerning, I have installed the latest version, can confirm it is all installed and yet the system reports that there is a newer version available. If I click download I get the very same version I have just installed and I go around in circles. The latest version is not reporting itself as the latest version!
  • Picture of Doug E. Wray
    Sun, Sep 20, 2020, 5:05 AM
    I am having the same problem as Messers Newport and Najib: I have this installed on one site. The Notifications page give a notice for the update, but attempting to install simply loops back to the Notifications page with notification that there is a new version of the Dashboard available. Moodle version: 3.9.2+ (Build: 20200918).
  • Picture of Diego Maia
    Wed, Sep 23, 2020, 11:17 PM
    Hi Eduardo, i'm installing your plugin on Moodle 3.9.1+ with SQL Server, but I had received a DML Exception like this: Informações de depuração: SQLState: 42000
    Error Code: 102
    Message: [Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Incorrect syntax near 'LIMIT'.

    SELECT count(u.id) AS num
    FROM mdl_user u
    LEFT JOIN mdl_context cx ON cx.instanceid = u.id
    WHERE u.lastaccess > '1600872784'
    AND u.lastaccess < '1600873084'
    AND cx.contextlevel = '30'
    GROUP BY u.id
    ORDER BY u.timecreated DESC
    LIMIT 1
    [array (
    0 => 1600872784,
    1 => 1600873084,
    2 => 30,
    )]
    Error code: dmlreadexception

    Could you help me, please?

    Thanks in advance.
  • Picture of Doug E. Wray
    Sat, Sep 26, 2020, 7:16 AM
    The problem I reported before (on 20 September) continues with the latest build [3.9.2+ (Build: 20200924)].
  • Picture of Sistemas Unintese
    Thu, Nov 26, 2020, 2:22 AM
    Olá, estou enfrentando o seguinte erro quando o aluno faz a matricula pelo corte "Início em 31 de dezembro de 1969 às 21:00 e nunca expira "
1 2 3
Please login to post comments