Your Moodle version

General plugins (Local): Moodle flavours

local_flavours
Maintained by Picture of David Monllaó David Monllaó
Tool to package (into downloadable files) and deploy sets of Moodle plugins, settings, language packs and language customizations
113
213
15

Please, use https://moodle.org/plugins/block_admin_presets instead of moodle flavour to import/export Moodle site settings. You can still use Moodle flavours to pack plugins, language packs and language strings customisations, but it is not recommended for settings.

With this plugin Moodle Administrators will be able to create a flavour from their installation, selecting which settings, plugins and language packs will be packaged into a compressed file. They can then, share the package with the Moodle community, store it as a backup or use it to replicate the flavour to other installations they manages. It could also be useful for administrators with little Moodle experienced, allowing them to explore the Moodle settings and setup recommended by others.

It has been developed as part of Google Summer of Code 2011 and mentored by Michael de Raadt.

Moodle 2.1 or higher required, to install, please, follow the README steps.

Screenshots

Screenshot #0

Contributors

Picture of David Monllaó
David Monllaó (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Wesley Ellis
    Thu, Jul 19, 2012, 8:33 PM
    Tested in 2.3.1 and there is currently an error when trying to package a flavour. You can't select any options (Check boxs invisible) PHP returns the following error

    Notice: Trying to get property of non-object in /lib/pluginlib.php on line 198
  • Picture of David Monllaó
    Fri, Jul 20, 2012, 8:43 PM
    Thanks for the info Wesley, I filled a new issue (http://tracker.moodle.org/browse/CONTRIB-3784) with your message, you can keep track of the progress there
  • Picture of Bas Brands
    Tue, Nov 13, 2012, 10:19 PM
    Hi David,

    I just installed and used the flavors plugin. It is simply awesome, your work saved me a lot of work. Thank you very much for all your work and sharing this!
  • Picture of Wesley Ellis
    Fri, Nov 30, 2012, 6:19 PM
    Hi David, The current commit in master seems to be broken, the check boxes on deploy flavour are now bullet points. Seems to affect Firefox and IE9 Moodle Version 2.3.3
  • Picture of David Monllaó
    Sat, Dec 8, 2012, 9:20 AM
    Hi Wesley,

    Many thanks for the report, hopefully during this weekend I'll find time to solve it.

    Regards,
    David
  • Picture of David Monllaó
    Sun, Dec 9, 2012, 7:57 PM
    Hi Wesley,

    The commit you commented about was a work in progress for Moodle 2.4, I've updated the download page of the 2.3 version to point to the MOODLE_23_STABLE branch, so if you are using Moodle 2.3 checkout from the MOODLE_23_STABLE instead of master.

    I've also released the new version for Moodle 2.4 which solves the flavours deployment problem with the tree which causes HTML warnings to be displayed like plain text.

    Thanks for reporting the issue,
    David
  • Picture of David Monllaó
    Sun, Dec 16, 2012, 11:36 AM
    Hi,

    I've found a problem with the new version for Moodle 2.4 which prevents tree items to be selected, it's solved now, sorry for the inconvenience
  • Picture of tong adam
    Sun, Jul 5, 2015, 11:27 AM
    Hi..it didn't work in Moodle 2.9 for packaging a flavour. Will it be updated?
  • Picture of Daniel Neis Araujo
    Thu, Oct 8, 2015, 3:27 AM
    Hello,

    it would be nice if there are any plans to update it to work with 2.9 or maybe 3.0,
    current error is:
    PHP Fatal error: require_once(): Failed opening required '/var/www/uc/lib/pluginlib.php' in /var/www/uc/local/flavours/ingredient/flavours_ingredient_plugin.class.php on line 26,
  • Picture of David Monllaó
    Mon, Oct 12, 2015, 1:42 PM
    Hi,

    Thanks for reporting the issue Tong and Daniel, https://tracker.moodle.org/browse/MDL-46122 has been pluginlib.php final deprecation, it shouldn't be too hard to update the code to use core_component (lib/classes/component.php) instead. I will try to find time for it, but feel free to send a pull request as my daughter will be born one of these days and I doubt I will have time for it at short term.

    Cheers,
    David
  • BT
    Thu, Aug 18, 2016, 9:31 PM
    Hi,
    I run Moodle 3.1 with Adaptable theme

    I ask on the forum how to save all the settings from the Administration menu: fonts, colors, images, etc. to transfer them to the production site in a second time, and I was guided to your plugin. Do you know if it's works on Moodle 3.1 ? And is there any risk to test it ?
  • Picture of David Monllaó
    Fri, Aug 19, 2016, 9:37 AM
    Hi benoit,

    Although it should work I would always first try in a testing environment and compare mdl_config table differences. If you are only interested in exporting and importing setting, I would recommend you https://moodle.org/plugins/block_admin_presets, which also exports / imports settings but using Moodle's administrations settings API instead of raw database writes to config table. It is more reliable.
  • St Petersburg, Russia
    Sat, Aug 20, 2016, 12:23 AM
    Moodle 3.1.1+ (build 20161817). Use Flavours to capture a slew of Adaptable theme settings from a test server.
    The Flavour was successfully created and downloaded.
    But on target server -- with EXACTLY the same codebase -- I get:

    1. Flavours Deployment - Ingredients previsualization
    Step 2 - Ingredients previsualization
    Warning : All Adaptable settings will be overwritten (which is what I want!)
    2. Hit [Deploy]. Success
    3. [Continue to Notifications]
    4. Site Admin > Purge all caches
    5. No changes saved!

    There are no php errors thrown (I have error reporting switched on).
    Admin_presets is not a solution -- it does not work with Moodle v3.x.
    I'll file an Issue on the Tracker.
  • St Petersburg, Russia
    Sat, Aug 20, 2016, 12:34 AM
  • Picture of David Monllaó
    Thu, Aug 25, 2016, 2:04 PM
    Hi Mark,

    I've pushed some fixes (thanks to Marina Glancy) to make https://moodle.org/plugins/block_admin_presets compatible with Moodle 3.0, 3.1 & 3.2 (currently in development) moodle flavours may have some similar bugs as it is not using admin settings APIs.
1 2
Please login to post comments