Course formats: Onetopic format

format_onetopic
Maintained by que bueno que sabe el café colombiano... David Herney Bernal
Format to course that allows showing each topic in a tab, keeping the current tab between calls to resources, in such a way that when it returns from a module as the blog or the glossary it returns to tab from where you started. This format is based on the Moodle standard format: “Topics”. It accepts edition by AJAX.
3572 sites
2k downloads
41 fans

Developed by: David Herney Bernal García - davidherney at gmail dot com

GIT: https://github.com/davidherney/moodle-format_onetopic

Information in: http://aprendeenlinea.udea.edu.co/lms/investigacion/course/view.php?id=50&topic=2

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

que bueno que sabe el café colombiano...
David Herney Bernal (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Sarah Ricketts
    Tue, 25 Apr 2017, 11:36 PM
    Hi Irith, I got the same error and managed to fix it by going to 'Administration > Edit settings' and changing the course format to something else and adding in 1 additional section to the total number and saving. For example, if it breaks on OneTopic course with 11 sections, change it to Topic format with 12 sections. Once your course content is navigable again, go back to 'Administration > Edit settings' and switch back to OneTopic course format and your course should work again. I repeated the error and found the problem to be that by being active in the final section (clicking in the last visible section) and trying to remove that last section (using - icon) - you then get the "This section does not exist" error. I hope this helps. Perhaps there is a way to prevent this error in the coding?
  • que bueno que sabe el café colombiano...
    Wed, 26 Apr 2017, 3:24 PM
    Uploaded the new release.

    2016071401:
    - Fixed: Error code: sectionnotexist
    - Applied Moodle coding style
    - CSS styles changed (Commented by Kuriko A)
    - Granted compatibility with Moodle 3.2+

    Saludos
  • Picture of Irith Herman
    Fri, 28 Apr 2017, 1:08 AM
    Thank you It works fine now
    Saludos
  • Picture of Sarah Ricketts
    Tue, 2 May 2017, 5:09 PM
    Brilliant thanks David for your speedy response, tested at 3.2.2 and works well, no 'section does not exist' error.
  • Picture of Erica Bithell
    Wed, 3 May 2017, 10:08 PM
    Hi David, I've been testing this course format in Moodle 3.2.2, and am running into an issue with the Announcements/News forum.

    It looks as if the auto-creation of the forum no longer works, now that Moodle core has changed the method for doing this (see https://docs.moodle.org/dev/Course_formats#Supporting_the_automatic_creation_of_the_Announcements_forum). I can't see any support for this method in the Onetopic codebase.

    There are two effects of this: the simple one is that it isn't possible to add the forum by adding the Latest News block. But also, if you have an Announcements forum already (e.g. it was there before the Moodle 3.2 upgrade), as soon as you visit the course settings page and re-save it, the Latest News block vanishes because the number of News items has reset to zero.

    I wonder whether you have any plans to add support for this new method so that the Announcements forum and block can be made to work again?

    Thanks in advance,

    Erica
  • que bueno que sabe el café colombiano...
    Sat, 6 May 2017, 3:38 PM
    Hi Erica...

    I added the supports_news method required.

    Thanks by your comment.

    Saludos
  • Picture of Sarah Ricketts
    Thu, 25 May 2017, 6:24 PM
    Hi,
    We're using BuenaVista (2016071401) with Moodle 3.2.2 and i've noticed that when clicking around tabs within a course, when a tab becomes highlighted (with the blue line above it) it can sometimes knockout and misalign future tabs. When clicking on the next tab along, again the tab locations are readjusting. As highlighting doesn't seem to increase the width of the selected tab I can't see a reason for this effecting placement of any other tabs? Example here:
    Thanks
    Sarah
  • que bueno que sabe el café colombiano...
    Fri, 26 May 2017, 3:25 AM
    Hi Sarah...

    I think that your problem is by the tab height in your current theme, the height in selected tab stop the align of next tabs. Please, check it or send me access to a site for test.

    Saludos
  • Picture of Novaschool myAgora
    Thu, 8 Jun 2017, 7:17 PM
    Hi David,

    do you plan to release a version compatible with moodle 3.3? Do you have any dates?

    Thx,
    Angel
  • Picture of Dr. Nellie Deutsch
    Tue, 13 Jun 2017, 5:06 PM
    I installed the plugin for 3.3, but the announcement doesn't work. Is there a way around this?

    Thank you
  • Dear David, very good contribution, I would like you to help me with the following. Update the plugin and most of my courses have been unconfigured, the information in the tabs has gone to one of the tabs and hiding the others.
    There is some way to get back to the state they were in, ie with the tabs with their contents and showing.

    I'll be waiting for your prompt response, thank you very much
  • que bueno que sabe el café colombiano...
    Wed, 21 Jun 2017, 12:23 PM
    Hi Richard...

    I think that it is not a bug from the format, maybe the error was in the process or other external reason. What version did you upgrade? Did you change to other format before the upgrade? Did change the sections number into the course or only hide the topics? Check this in order to find posible reasons.

    Saludos
  • que bueno que sabe el café colombiano...
    Wed, 21 Jun 2017, 12:25 PM
    Hi Novaschool, Nellie...

    I am work in the new version but I don't have a final date yet, I am sorry. I expect release it in the next days.

    Saludos
  • Picture of Rajakumar Jillella
    Fri, 23 Jun 2017, 10:45 PM
    Hi David, This plugin is not supporting in "moove" theme.
    Output for tabs it is giving HTML code.

    https://moodle.org/mod/forum/discuss.php?d=354019#p1429816
  • Picture of Sarah Ricketts
    Wed, 28 Jun 2017, 9:13 PM
    Hi, if an "&" ampersand is used in a section name, it gets converted to '&' for example "Assignments & Resources" becomes "Assignments & Resources". Is it possible to fix this? This is not theme specific.
1 2 3 4 5 6 7 8 9 10 11 12 13 14
Please login to post comments