Your Moodle version

Filters: WIRIS

filter_wiris
Maintained by Picture of WIRIS team SUPPORT WIRIS team SUPPORT
WIRIS math tools enhances your Moodle with WIRIS editor and WIRIS cas. WIRIS editor is a WYSIWYG equations editor (also known as formula editor). WIRIS cas is an online platform for mathematical calculations and graphics designed for education.
Moodle 2.2, 2.3, 2.4, 2.5, 2.6

WIRIS math tools enhances your Moodle with WIRIS editor and WIRIS cas.

WIRIS editor is a mathematical visual (WYSIWYG) editor. You can use a large collection of icons nicely organized in thematic tabs in order to create formulas or equations for any web content. You can create and edit your formulas in a visual environment, just click on the WIRIS editor icon for creation or double-click on the formula for edition. No maintenance when upgrading Moodle to a new minor version. It is based on JavaScript and compatible with HTML 5.

WIRIS cas is an online platform for mathematical calculations designed for education. You can access a powerful calculation toolbar through an HTML page that includes integrals and limits calculation, function graphing in 2D or 3D and symbolic matrices manipulation, among others. WIRIS cas covers all mathematical topics from primary school to university level (Calculus, Algebra, Geometry, Differential Equations...).

You also need to install WIRIS plugin for TinyMCE.

The same components for Moodle 1.9 can be found here.

WIRIS editor and WIRIS cas can be used for free up to a certain level per natural year. Please read conditions and prices in WIRIS store.

If you are also interested in mathematical quizzes with random parameters and mathematical evaluation, check our WIRIS quizzes plugin.

Screenshots

Screenshot
Screenshot
Screenshot
Screenshot
Screenshot
Screenshot

Contributors

Picture of WIRIS team SUPPORT
WIRIS team SUPPORT (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of WIRIS team SUPPORT
    Thu, Dec 29, 2011, 12:32 AM
    This filter substitutes the WIRIS plugin under section "Other" for Moodle 2.x versions
  • Capt. Moodle
    Thu, Dec 29, 2011, 3:19 AM
    I noticed that there is no README.txt file. The files indicate that all rights are reserved. Since the filter is a derivative of Moodle code which is GPL licensed, in order for the code to be shared it must also be GPL licensed. I am going to hold off approving this entry until the copyright/license notices clearly indicate that the filter is GPL licensed and a README.txt file is added as suggested in http://moodle.org/plugins/pluginversions.php?plugin=filter_wiris&validation=1. Please do not hesitate to let me know if there is anything I can do to be supportive of your efforts. Peace - Anthony
  • Picture of WIRIS team SUPPORT
    Thu, Dec 29, 2011, 11:22 PM
    README.txt file created and GPL license agreement added to every file... and Love - Carles @ WIRIS team
  • Picture of Nadav Kavalerchik
    Tue, Oct 9, 2012, 4:00 PM
    After some of our teachers, who have put a lot of work creating WIRIS quizzes, found out that WIRIS is not free and got back to me, surprised, that WIRIS cost money. I suggest we add a comment about it with a link: http://www.wiris.com/store ( Here and on all instances of the WIRIS plugin )
  • Picture of Luis Perez
    Fri, Jan 11, 2013, 12:59 AM
    Have problems installing with moodle 2.4. Any recommendations?
  • ivan @ wiris.com
    Fri, Jan 11, 2013, 1:37 AM

    Hello Luis,

    Just today we uploaded the Filter/Plugin for Moodle 2.4.
    Please ensure you have the latest version, and you have followed the instructions:
    http://www.wiris.com/plugins/docs/moodle

    Next week we will upload the Quizzes module for Moodle 2.4.

    Feel free to find me at: support at wiris.com

  • ivan @ wiris.com
    Fri, Jan 11, 2013, 8:13 PM
    Hello Luis,

    This error is thrown by the packages for Moodle 2.2 and 2.3, when installed in Moodle 2.4.
    You should use the packages for Moodle 2.4, availables at:
    http://www.wiris.com/plugins/moodle/download



  • Picture of Luis Perez
    Fri, Jan 11, 2013, 10:54 PM
    Hello Ivan
    Thanks, everything is working fine.
    Luis
  • Picture of Carles Aguiló Collado
    Tue, Jan 15, 2013, 12:30 AM
    @Nadav, I found the way to change the description of the plugin and did it a few days ago... As plugins go through a peer review and I couldn't find the option, just wrongly assumed that it was not possible... Anyway, it's amended now smile
  • Picture of hanna edelman
    Tue, Aug 6, 2013, 9:54 PM
    link to the required WIRIS TinyMCE plugin: http://www.wiris.com/en/plugins/moodle/download
  • Не отступать и не сдаваться!
    Wed, Sep 4, 2013, 6:50 PM
    Good product for all!
  • Picture of Miki Alliel
    Thu, Jan 9, 2014, 10:04 PM
    just installed wiris filter and plugin on tiny mce in Moodle 2.6
    and clicking the wiris icon getting this error:
    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /....moodle_test/lib/editor/tinymce/plugins/tiny_mce_wiris/integration/editor.php:2) in /..../moodle_test/lib/classes/session/handler.php on line 42
    what can I do?
  • Picture of WIRIS team SUPPORT
    Fri, Jan 10, 2014, 5:52 PM
    @Miki Alliel, you have "Display debug messages" option enabled in Moodle Debugging (Site administration > Development > Debugging). As Moodle notes, it may break the HTML pages in some cases. We'd recommend that you uncheck that option so any warnings will only go to your server error log (not to the browser).
    This is a known issue that a few other clients have experienced in different Moodle versions but, unfortunately, at the moment we have been unable to reproduce it in our machines...
Please login to post comments