Enrolment: Signup

enrol_signup
Maintained by Picture of Antonio Duran Antonio Duran
This enrolment plugin lets you enrol users in the desired courses when they sign up to Moodle.
339 sites
330 downloads
17 fans
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6

This enrolment plugin lets you automatically enrol users in the desired courses when they sign up to Moodle.

For example, you can set it to enrol all your new users to the "Moodle intro" course.

You just need to enable the plugin in the courses you want users to be auto-enroled when they register.

Contributors

Picture of Antonio Duran
Antonio Duran (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of remco koffijberg
    Fri, 12 Oct 2012, 2:09 AM
    After half a day I gave up. Used another plugin named AutoEnrol, worked immediately. I don't know why.
  • Picture of Francis Vendrell
    Fri, 2 Nov 2012, 6:59 AM
    Hello
    I downloaded and installed the last version of signup. I am using Moodle 2.2+. Installation went fine. However I could not make it work. I tried also AutoEnrol and it didn't work either. sad
    Is there something I have done wrong?

  • Picture of timothy pacson
    Wed, 22 Jan 2014, 9:01 PM
    hi.. i am currently enrolled at the university of the east blended learning subject which is AC417N. I can't access my account in my school moodle. What should I do???
  • Just wondering . . .
    Thu, 20 Feb 2014, 3:47 PM
    Is anyone there? Is this likely to be updated for 2.6, or have you guys moved on with your life.

    -Derek
    And @timothy. Ask your tutor.
  • Picture of Antonio Duran
    Tue, 25 Feb 2014, 2:42 AM
    Thanks for the heads up. It is been a while since I last used the plugin and I did not know it needed an upgrae.
    I have uploaded a new version now. I have tested it on Moodle 2.6 and it seems to work fine.
    Please try and let me know if you find any issues.

    Antonio
  • Picture of Sorin Lascu
    Fri, 29 Jan 2016, 11:16 PM
    Hello, tried to install on 3.0 but got the message that no pluginname is available? Anybody aware about this issue during installation with moodle 3.0?
  • Picture of Antonio Duran
    Mon, 8 Feb 2016, 5:44 AM
    Hi. Thanks for the info.

    I have now uploaded a new version compatible with Moodle 3.0.
  • Picture of Dr. Jatong Anthony
    Mon, 12 Dec 2016, 7:56 PM
    Have tried confirmation of new account as requested in but the link sent is not hyperlinked. anthonyjatong@yahoo.com
  • Picture of Jaume Albaigès
    Thu, 15 Dec 2016, 3:28 AM
    Hello Antonio. Just installed the plugin in a 3.2 environtment and when trying to register a new user a HTTP ERROR 500 is thrown and the site goes blank. Do you know if the plugin is 3.2 compatible? Have you planned to update it? Thank you very much.
  • Picture of Antonio Duran
    Wed, 21 Dec 2016, 3:47 AM
    Hi Jaume.
    I just tested current version with latest Moodle 3.2 and it all worked fine.
    Can you try to get more info about Error 500 from your logs? Maybe that way we can find what's causing the problem for you.
  • Picture of Richard Havinga
    Wed, 11 Jan 2017, 4:54 PM
    Hi Antonio, I have found an issue with the plugin in Moodle 3.2. When the plugin is installed and trying to add a new user to the Moodle instance, the plugin errors with Exception - Class 'course_enrolment_manager' not found. Thanks Richard
  • Picture of Antonio Duran
    Fri, 13 Jan 2017, 4:13 PM
    Hi Richard.

    I cannot replicate the problem in current Moodle 3.2.1+. Are you using the latest plugin version?
    You could try addding:
    require_once("$CFG->dirroot/enrol/locallib.php");

    At the start of file:
    moodle/enrol/signup/locallib.php

    As the error is that it cannot find the class that is defined in that file.
  • Picture of Richard Havinga
    Tue, 17 Jan 2017, 12:43 AM
    Hi Antonio,

    Thanks

    Adding in the require once underneath the global declaration of $CFG within the enrol_signup_handler class works.

    Do you have a git repo for this plugin?

    Richard
  • Picture of Antonio Duran
    Tue, 17 Jan 2017, 2:01 AM
    Hi Richard.

    Thanks for the feedback. I will release a new version with the fix included soon.

    I am sorry, but I do not yet have a git repo for the plugin. It's on my TODO list, though, so hopefully I will have it in the future.

    Antonio
  • Picture of Rekha C
    Tue, 17 Jan 2017, 4:55 AM
    Hi Richard, please provide for 3.2.1 soon, there is no other auto enrol plugin for 3.2 yet.
1 2
Please login to post comments