Select Moodle version:

Blocks: Simple Navigation Block

block_simple_nav
This block provides a navigation as it is often used on standard websites.
Maintained by: it's me David Bogner
for Moodle
2.0, 2.1, 2.2, 2.3, 2.4

This block shows a much simpler navigation than the standard Moodle navigation block. It is designed to be used on Moodle sites, that are also used as standard websites and not only as LMS.

Screenshots

screenshot
screenshot

Contributors

it's me
David Bogner (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Irene Nagornaia
    Thu, Nov 1, 2012, 9:44 PM
    Hi David,
    The new plugin is installed onto my server. Only it still seems I'm doing something wrong. I'll send you screenshots in about ten minutes. The categories/subcategories/courses --> they all behave on their own, do not want to be controlled. Please give me a hand here. Very much appreciated,
    Irene.
  • Picture of Irene Nagornaia
    Fri, Nov 2, 2012, 12:17 AM
    Hi David, is there a limit of amount of categories in the Simple Nav. Block? Because I've managed to display five categories with six sub-categories in total. But when I add more, trouble starts.
    Or, could it be that sub-categories/categories cannot contain same words? Some sub-categories are named identically in my case -> do I need to find the way to name them differently? Do you need any pictures from me to see it? Thank you very much,
    Irene.
  • Picture of German Valero
    Thu, Nov 8, 2012, 1:52 AM
    Hi David,
    The simple navigation block is working nicely in both English and in the spanish translation. smile
    Thank you.

    But I think that maybe the string [blockstring,block_simple_nav], which currently is "Feld Titel" might perhaps be "Field Title".

    Greetings from Mexico
  • it's me
    Thu, Nov 8, 2012, 11:39 PM
    @Irene: I uploaded a new version, that allows to display more subcategories. (you can change the value in line 56 in edit_form.php if you want to change it again). @German: I did update the string field title. Greetings from Vienna. David
  • Picture of Sarah Jane
    Fri, Jan 25, 2013, 12:48 AM
    I was hoping this would have solved my problem with wishing a simpler navigational route for the students. Mostly though to try to get rid of the forum. But I must be getting something wrong. I have to say when I downloaded this I was delighted that I could select exactly what my students can see - brilliant. However, how can I get the students to use this simpler one rather than the Navigation default? The configuration gives the impression this would be used as the default - but all I have to 2 navigation menus now. sad Also I have created 2 pages with information but the word 'page' appears and overlaps the title of my pages. Can you help? I really want to use your block. Many Thanks Sarahx
  • it's me
    Fri, Jan 25, 2013, 1:14 AM
    Hi Sarah Jane,

    thank you for bringing up this issue. In fact you can make disappear the standard navigation block by changing the rights of th block:

    1) Click on the "assign roles" symbol in "editing on" mode in the navigation block
    2) Then in the settings block click on "Permissions"
    3) Remove the "View block" permissions for the specific roles (student, guest, authenticated user, etc.)

    Best regards,
    David
  • Picture of Nick Rivers
    Tue, Jun 25, 2013, 10:41 PM
    David,

    When debugging is turned on I see this message:

    Function get_categories() is deprecated. Please use coursecat::get_children(). See phpdocs for more details.

    I changed the function to what is being suggested, but I just get some errors.

    Will this effect the block? Or should I not worry about this?
  • it's me
    Wed, Jun 26, 2013, 5:35 PM
    @Nick,

    Moodle changed the navigation methods in core, the function get_categories will work without problems, it is only deprecated from Moodle 2.5 onwards. That should not be a problem, we will update the code, when we upgrade to 2.5 or 2.6, that will be in automn. Meanwhile you can use it without worrying about the warnings in dev mode.
  • Picture of Nick Rivers
    Fri, Jul 12, 2013, 2:32 AM
    @David,

    Thanks, is there a simple way to add the topics too?
  • it's me
    Fri, Jul 12, 2013, 9:16 PM
    @Nick: As far as I remember, we wanted to keep it really basic and therefore we decided not to include the topics. This could be done, but is not on our agenda.
  • Picture of Jason Brisson
    Fri, Aug 9, 2013, 10:42 PM
    @David

    First thing first, thank you very much for your work on this great block!
    It does almost everything i need except for some minors exception that i would like to implement by myself.

    For exemple, id like the first category showed (not the home as i don't display it) to be open by default when the block is first displayed on the page.
    This category must stay «collapsible» like all the others.

    Could you please point me out what would be,in your opinion, the simplest way to acheve something like this?

    Again, thanks a lot!
    Best regards,
    Jay
  • it's me
    Sun, Aug 11, 2013, 2:45 AM
    Hi Jay,

    I think, you can already achieve this in the settings (activate editing mode, then click on the settings icon of the block). Do not activate the "home" category, then it won't be displayed.

    Best regards,
    David
  • Picture of Jason Brisson
    Tue, Jan 7, 2014, 4:31 AM
    Me again!!! sourire
    Are you planning on updating your nice block to moodle 2.6 any time soon?

    Thx a lot!!
  • Picture of Siumin Ang
    Mon, Apr 7, 2014, 4:55 PM
    Hi, I was unable to set the settings of this block under the 'Where this block appears' sections. When I selected 'Any page', it doesnt appear on all pages, and instead all of my information within the block disappears! Please help.
  • it's me
    Tue, Apr 8, 2014, 1:23 AM
    @Slumin Ang: I just uploaded a new version of the block. But the problem you describe, is more a moodle core bug, that should be resolved in the latest version of Moodle 2.5 and 2.6. What Moodle version are you using?
1 2 3
Please login to post comments