Your Moodle version

Blocks: Quickmail

Maintained by Picture of Buddy Ethridge Buddy Ethridge, Picture of jason peak jason peak, Picture of Robert Russo Robert Russo, Picture of David Elliott David Elliott
A block that provides selective, bulk emailing within courses. Developed by LSU.
Moodle 2.1, 2.2, 2.3

Quickmail is a block that provides selective, bulk emailing within courses.


  • Multiple attachments
  • Drafts
  • Signatures
  • Filter by Role
  • Filter by Groups
  • Optionally allow Students to email people within their group.


Quickmail adopts the same license that Moodle does.


Quickmail was developed at Louisiana State University.


Screenshot #0
Screenshot #1
Screenshot #2
Screenshot #3


Picture of Buddy Ethridge
Buddy Ethridge (Lead maintainer)
Picture of Philip Cali
Philip Cali: Former Lead Developer
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Amanda Doughty
    Thu, Aug 13, 2015, 10:22 PM
    Atto autosave overwrites contents of history

    Go to Quickmail->View History
    Open an email.
    Wait for the time that the atto editor is set to autosave (default 1 min) 'Draft saved' will flash.
    Go to Quickmail->View History
    Open a different email.
    The content displayed is that of the first email opened. It is the same for every email.
    Turn JS off and the correct content is displayed.

    A record is created in editor_atto_autosave that is used to overwrite the content of every email text editor box.
  • Picture of David Elliott
    Fri, Aug 14, 2015, 1:53 AM
    @Edward Chong,
    QM does work for 2.9.1 , if there are no errors thrown it could be a problem with how email is set up on your moodle server. I can't think of any config setting related to QM that would affect that though. If you do discover something let me know!
  • Picture of David Elliott
    Fri, Aug 14, 2015, 1:54 AM
    @Amanda Doughty
    Thanks for bringing that to my attention! That's a pretty weird bug. I'll take a look at it soon, and maybe ask a Moodle core developer about Atto doing that.
  • Daniel McSweeney
    Sun, Aug 23, 2015, 10:33 PM
    two questions
    1. Any plans for an official 2.9 release?
    2. Any reports of issues when relaying to large groups. I've had user reports that emails to large classes fails (over 60+). Not sure if this is a relay issue on th exchange box or something thats a know issue in quickmail?
  • Picture of Yong Ra
    Fri, Sep 4, 2015, 11:19 PM
    In Moodle 3.0 DEV version, I get following error. The Moodle version is Moodle 3.0dev (Build: 20150903).

    Plugin "block_quickmail" is defective or outdated, can not continue, sorry.

    More information about this error
    Debug info: Missing $plugin->component declaration in version.php.
    Error code: detectedbrokenplugin
    Stack trace:

    line 807 of /lib/upgradelib.php: plugin_defective_exception thrown
    line 428 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
    line 1640 of /lib/upgradelib.php: call to upgrade_plugins()
    line 433 of /admin/index.php: call to upgrade_noncore()
  • Picture of Francesco D'Amico
    Tue, Sep 8, 2015, 8:17 PM
    I have an issue using Quickmail.

    I have Moodle 2.7 installed and the latest version of Quickmail (2014042914 v1.5.0)
    I have a course set with separate groups. If I am using Chrome on my Windows PC I can send messages to everyone in that group. If I use my ipad when I try to send the email a message appears: There are no users you are capable of emailing.

    Any hint?
  • Frankie's the name, Moodle's my game!
    Wed, Sep 9, 2015, 2:18 PM
    I noticed that when I insert an image, the image does not appear in the E-mail that is received by a recipient. The recipient only sees the image rectangular bordr/outline. Bit the image itself is blank (white). Anyone else having this problem with Moodle 2.9.1?
  • Frankie's the name, Moodle's my game!
    Wed, Sep 9, 2015, 2:36 PM
    I suppose that "inserting an image inside a Quickmail message results in a missing image once the E-mail is received" problem is not a problem, but is inherent in how Moodle works (?):
  • Picture of bobby demers
    Tue, Sep 22, 2015, 5:49 AM
    I've just installed QuickMail into our Moodle (2.9+ Build: 20150618) and it won't add any of the groups to the recipient list (but they do show in the Potential Groups list).
    It shows a list of the teachers in Potential Recipients (who aren't in any groups) who I can add, but none of the students are showing in this list of Potential Recipients.

    Hope this is updated to work with 2.9 soon!!
  • Picture of Michelle Krill
    Fri, Sep 25, 2015, 11:52 PM
    We installed the quickmail block, but when we try to send an email to students we receive a message "could not email [student name]. I verified the email address is in the profile for students. Is there a system/server setting that could be causing the error?
  • Picture of Ryan Bernstein
    Wed, Oct 14, 2015, 2:45 AM

    We've noticed that in Moodle 2.9, HTML formatting is stripped from Quickmail email messages to recipients whose email address was manually entered into the 'Additional email addresses' field. Recipients who were selected from the 'Potential recipients' (enrolled users), received emails with HTML formatting intact.
  • alvareza
    Fri, Oct 30, 2015, 1:10 AM
    for when Moodle version 2.9? It is a very good plugin and migrated to 2.9 as I will miss sad
    ¿para cuando la versión para moodle 2.9? Es un plugin muy bueno y como migro a 2.9 lo voy a extrañar... sad
    Gracias/ Thanks
  • Picture of Yong Ra
    Thu, Nov 5, 2015, 11:04 PM
    Is this block be updated to 2.9 or higher? This is a great block.

  • Picture of Yong Ra
    Tue, Nov 17, 2015, 3:11 AM
    Now that 3.0 is officially released, why one working on quickmail to work in 3.0? This is the error I get.

    Plugin "block/quickmail" is defective or outdated, can not continue, sorry.

    More information about this error

    Debug info: Missing version.php file.
    Error code: detectedbrokenplugin

    Stack trace: •line 789 of /lib/upgradelib.php: plugin_defective_exception thrown
    •line 429 of /lib/upgradelib.php: call to upgrade_plugins_blocks()
    •line 1641 of /lib/upgradelib.php: call to upgrade_plugins()
    •line 677 of /admin/index.php: call to upgrade_noncore()

    Thank you.
  • Picture of Joe Amatrucola
    Sun, Nov 22, 2015, 12:33 AM
    Just upgraded our testing site to Moodle 3.0 and installed Quickmail v1.5.0 (2014042914). I am experiencing the same errors described by Yong Ra on Thu, 5 Nov 2015. Looking forward to a version that will work with 3.0; we can't upgrade our production site to 3.0 without this plugin working. It's a great addition to Moodle that we use a lot. Thanks!
1 2 3 4 5 6 7 8 9 10 11 12
Please login to post comments