Your Moodle version

Blocks: Quick Course List

block_quickcourselist
Maintained by Picture of Mark Johnson Mark Johnson
This block allows quick searching of Moodle courses, and displays a link to the course page.
7k
240
2
Moodle 2.0, 2.1, 2.2, 2.3, 2.4, 2.5, 2.6

Like the Quick Find List, this block displays a search box on the page, but instead of searching through users, searches through Courses.  Courses that match the search string either by shortname or fullname will be displayed, with a link through to the course page.

If Javascript is available, the block will "Find as you type", otherwise a button will be displayed to submit the search.

Please dont report bugs here

If you experience an error with the block, or would like to request a feature, please use the "Bug Tracker" link below.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

Picture of Mark Johnson
Mark Johnson (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Mark Johnson
    Tue, Aug 28, 2012, 6:29 PM
    Hi Thomas,
    Just to check the permissions - there's a system level capability called quickcourselist:use which users will need to have to use the block, even if they have the block-level permission to view the instance of the block. If you want everyone to be able to use the block, I'd suggest giving the quickcourselist:use capability to the Authenticated User system role.
  • Picture of Thomas Schoeftner
    Tue, Aug 28, 2012, 6:32 PM
    Hello Mark!
    where exactly do I find this "quickcourselist:use" - can I do this as the admin on the moodle platform or do I have to change some php-code?
    I'm on 2.3.1+ by the way
  • Picture of Mark Johnson
    Tue, Aug 28, 2012, 6:38 PM
    Hi Thomas
    You just need to use the Moodle admin interface to assign the capability to the role, under Site Administration->Users->Permissions->Define Roles. If you need help using this interface, your best bet is to read the Documentation[1] and ask in the forums[2]

    [1] http://docs.moodle.org/23/en/Capabilities/
    [2] http://moodle.org/mod/forum/view.php?id=6826
  • Picture of Thomas Schoeftner
    Tue, Aug 28, 2012, 6:55 PM
    Dear Mark!
    Thank you very much indeed - got it to work now - I love this block by the way!!
    Cheers,
    Thomas
  • Picture of phuong hoang
    Sun, Aug 11, 2013, 5:56 PM
    Thanks for your useful block! It works well. I just wonder why It doesn't search button as demo. Do I miss something?
  • Picture of Mark Johnson
    Sun, Aug 11, 2013, 8:04 PM
    The search button is only visible if Javascript isn't available (or fails for some reason). Otherwise, it does find-as-you-type!
  • Picture of phuong hoang
    Sun, Aug 11, 2013, 11:17 PM
    Thanks Mark, I got it.
  • Picture of Nicholas Lidden
    Tue, Jan 7, 2014, 9:41 AM
    Hi Mark
    Very much like your plugin. Just wondering if you have any plans to upgrade it for Moodle 2.6.
    Cheers
    Nick
  • Picture of Mark Johnson
    Wed, Jan 15, 2014, 2:12 AM
    Hi Nicholas, I'm not currently working with Moodle as part of my day job, but I'll try and keep it up to date as best I can. Do you have any details about the changes in 2.6 that make it incompatible?
  • Picture of Usman Asar
    Sun, Feb 9, 2014, 11:30 PM
    Well Done Mark! Nice, Simple and Does Work Well.

    Although have had difficulty to show it to Roles other than Admin/Teacher, but did manage to get it worked reading Thomas's issue, Can this block be made visible to anyone (Like Most Other Blocks) so users don't have to take the step of going into Permissions and over-ride them?
  • Picture of Mikhail Janowski
    Mon, Jun 30, 2014, 5:24 PM
    This is an amazing plugin and we would love to use it on our Moodle 2.7 site. Is there any chance that the warnings that appear when used on Moodle 2.7 could be fixed?
  • Picture of Mark Johnson
    Mon, Jun 30, 2014, 6:54 PM
    Hi Mikhail,
    Please post details of the error messages you see to the Bug Tracker (link is near the top of the page). I'm afraid I'm not actively developing this plugin at the moment, but I might be able to fix the problem if its small (or someone else might do it for you!).
  • Picture of James Foster
    Tue, Jan 13, 2015, 11:05 PM
    Is there any word if a 2.8 capatabile version is in the works?
  • Picture of Christine Brown
    Fri, Jan 16, 2015, 5:56 AM
    We are also keen to have a 2.8 compatible version so like James we would like to know if there is one planned.
  • Picture of Grigoriy Milman
    Tue, Feb 17, 2015, 3:24 AM
    We would like to have 2.8 compatible version too! Please....
1 2
Please login to post comments