Your Moodle version

Blocks: jmail

block_jmail
Maintained by Picture of Juan Leyva Juan Leyva
jmail is an internal mailing (aka internal email) tool for Moodle 2
18k
1
Moodle 2.2, 2.3, 2.4, 2.5, 2.6, 2.7, 2.8

jmail is an internal mailing tool for Moodle 2

It supports features like: labels(folders), attachments, reply, forward, print, read and unread messages, etc...

VERSIONS NOTE:

  • This plugin doesn't work in Moodle 2.0

Main features:

  • Send messages (TO, CC, BCC)
  • Reply, forward
  • Attachments in messages
  • User names auto-completition when composing messages
  • Bulk user selection
  • Save attachments directly to your Moodle private files
  • Drafts support
  • Moodle HTML Editor integrated
  • AJAX and Rich User Interface
  • Quick search tool
  • Ordering (date, subject, remitent)
  • Pagination
  • Labels (like folder, but a message can be linked to more than one label)
  • Different types of mailboxes
  • Receive copy of your messages to your profile external email account
  • Direct access to all your mailboxes
  • Groups support
  • Message key shortcouts (reply, forward, delete and print)
  • Global inbox
  • Full backup and restore support

This plugin has been sponsored by CV&A Consulting (Moodle Partner in Spain).

Screenshots

Screenshot

Contributors

Picture of Juan Leyva
Juan Leyva (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Marcelo Varela
    Sat, Aug 17, 2013, 1:55 AM
    Juan, disculpa mi pregunta pero ya esta disponible para funcionar en la versión 2.5? Gracias
  • Picture of Burt Polesitter
    Tue, Sep 17, 2013, 5:07 AM
    I have this plugin installed and can send messages as an admin, I can not as a student. Is there a permission I am not setting correctly please help!
  • Picture of Lou Rosenberg
    Fri, Oct 4, 2013, 5:42 AM
    Clearly, I'm missing something: How do I use this plugin? All I'm able to use is the block.
  • Picture of William Lu
    Thu, Dec 19, 2013, 11:36 AM
    Thanks, it works well on my Moodle2.6/Postgres9.1.4/php5.3.3.
    At the right hand side column, where listed all users' names with three buttons: To---CC---BCC. Only one small problem: the text only shows a tiny part on the button. I guess the baseline setting issue. anyone can fix it please?
  • Picture of Gustavo Isakson
    Sat, Apr 26, 2014, 12:12 AM
    Estimado Juan:
    He instalado jmail (block_jmail_moodle26_2011122510) en mi moodle 2.6.2 y tengo los siguientes problemas:
    - Al intentar acceder a la bandeja me da el siguiente error: "No se puede encontrar registro de datos en la tabla block_instances de la base de datos."
    - No puedo fijar el bloque "jmail" en los usuarios del sistema.
    Un cordial saludo desde Buenos Aires.
  • My picture
    Thu, May 8, 2014, 7:31 PM
    Hola, Juan.

    I have installed what I think it is the latest version of Jmail -2011122510- in Moodle 2.5.5 (I have installed automatically)

    I have noticed that Jmail does not work with Firefox 28 for this version of Moodle although it works fine in Moodle 2.2.4.

    I would like to know if I am the only administrator experiencing this problem.

    Thank you very much for your advise.
  • Picture of April Cookson
    Tue, May 20, 2014, 11:37 PM
    Hello,
    I just installed the latest version of JMail on Moodle 2.5.2. It seems to work great in Firefox and Google Chrome, but the Attachment section will not load in Internet Explorer 11. Has anyone else had this problem, and if so, is there a solution?
  • Picture of Cesar Cruz
    Wed, Jun 18, 2014, 8:14 AM
    He encontrado un problema cuando se envia a un mismo destinatario Para, BC y BCC, lo cual provocaba que cuando se leia un correo siguiera apareciento como no leido, adicionalmente en el conteo de correos no leidos, cada copia se tomaba como un nuevo correo, mas no se mostraba.

    Ya lo he solucionado, como puedo aportar esta mejora al módulo?
  • Picture of Cesar Cruz
    Wed, Jun 18, 2014, 8:14 AM
    He encontrado un problema cuando se envia a un mismo destinatario Para, BC y BCC, lo cual provocaba que cuando se leia un correo siguiera apareciento como no leido, adicionalmente en el conteo de correos no leidos, cada copia se tomaba como un nuevo correo, mas no se mostraba.

    Ya lo he solucionado, como puedo aportar esta mejora al módulo?
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:44 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:45 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:45 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:45 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:46 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
  • Picture of Manuel Álvarez
    Mon, Dec 1, 2014, 8:46 PM
    He instalado este plugin en Moodle 2.8 y todo parece funcionar correctamente, pero cuando envío un correo no llega nada. He probado el modo depuración y no veo errores. Otro tipo de mensajes, como cuando un usuario se da de alta si funcionan correctamente. Gracias
1 2
Please login to post comments