Your Moodle version

Blocks: ILP Integration

block_intelligent_learning
Maintained by Picture of Kris Stokking Kris Stokking
Moodlerooms is proud to share the ILP Integration package, which enables the exchange of data between Moodle and Ellucian's Colleague Portal.

Moodlerooms is proud to share the ILP Integration package, which enables the exchange of data between Moodle and Ellucian's Colleague Portal.

Features include:

  • The ability to synchronize user, course and enrollment data from Colleague using Moodlerooms' Web Services (included).
  • The ability to send retention alerts, mid-term and final grades, and attendance information to Colleague from Moodle.
  • The ability to provide a user's course listing (My Classes), upcoming calendar events (My Week) and due assignments and quizzes (My To Do) through the Colleague Portal.

Installation instructions can be found within a PDF in the download.

Moodlerooms' combines the benefits of open-source Moodle with enterprise-level services including hosting through the Dell Services Cloud, dedicated technical support, robust Moodle training, needs-based platform implementation, and Moodle customizations delivered by our experienced development team. Moodlerooms offers additional features to the integration that are not available in the released version. Some of these enhancements include:

  • Replication ensures data consistency between Colleague and Moodle.
  • Detailed transaction reports allow site administrators to monitor the integration. If there is ever a problem with the integration, your administrators can be notified immediately via e-mail.
  • Single sign-on between the Datatel Portal and Moodle.
  • Automatically back up courses before they are marked for deletion to prevent data loss.
  • Course templating integration allows for streamlined course creation.

Versions

ILP Integration version 2.0 (latest for Moodle 2.0 - 2.2)

Version 2.0 contains all of the features of Version 1.1, but has been upgraded to work with Moodle 2.

Version 2.0 of the ILP Integration package is compatible only with Release 2.0 or later of Ellucian's Colleague Intelligent Learning Platform (ILP).

Version 2012022000: This update fixes an issue with IP Address validation. Clients are encouraged to upgrade to this version if IP Address validation is enabled.

ILP Integration version 1.1 (latest for Moodle 1.9)

Version 1.1 Features

  • Enhancements to the My Classes Web Part
  • Enhancements to Moodle Grading Forms
  • Moodle Groups integration with Cross-Listed Sections
  • Support for Creating Moodle Courses Using a Template (Conduit Only)
  • Support for Different Date Formats in Moodle

ILP Integration version 1.0

Version 1.0 of the ILP Integration package is compatible only with Datatel Colleague ILP 1.0. If you are using Datatel Colleague ILP 1.1 or a higher 1.x release, you must download Version 1.1 of the ILP Integration package instead.

Contributors

Picture of Kris Stokking
Kris Stokking (Lead maintainer)
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • MD shot of me from his iphone4
    Wed, Feb 13, 2013, 3:14 PM
    Hi Kris,
    'Installation instructions can be found in the ZIP file containing the package.' > The downloaded package i'm seeing does not contain installation instructions. It mentions contacting a Ellucian representative instead.

    Could you also consider adding to the 'useful links' section : eg: documentation, code repository, any issue tracker and any relevant website.
  • Picture of Kris Stokking
    Tue, May 21, 2013, 6:23 AM
    A new version of the ILP Integration has been released for Moodle 2.4. Please note this is a beta release as it has not gone through full testing by our QA team.
  • Picture of charles frank
    Wed, May 22, 2013, 3:02 AM
    is there a downlolad link for the 2.4 beta version?
  • Picture of Larry Elliott
    Mon, Jun 24, 2013, 11:36 PM
    When do you think we might get a 2.5 version? Also, how stable is the 2.4 version?
  • Picture of Kris Stokking
    Mon, Jan 20, 2014, 5:54 AM
    Version 2.5 of the ILP Integration has been uploaded to the plugins repository. In addition, we've posted the plugin code in Github, which we will be updating in the future prior to availability in the Plugins Repository. Please check there first for updates to new Core versions.
  • Picture of Kris Stokking
    Wed, Jun 4, 2014, 11:04 PM
    A Release Candidate version for Moodle 2.6 of the ILP Integration has been uploaded to the plugins repository. There are no known issues with the new version at this time, but if you do experience a problem please ensure that you submit any issues to tracker.moodle.org.
Please login to post comments