Integrity Advocate Block

Blocks ::: block_integrityadvocate
Maintained by I sell cookiesMark van Hoek, Scott Dellinger, Darcy Chalifoux, Leah MacDermid
Online proctoring, identity verification and participation monitoring by Integrity Advocate. This is a privacy-first and accessibility friendly solution to ensure assessment integrity inside of Moodle activities. This block allows Moodle to show a proctoring interface to students, interact with the Integrity Advocate service, and show proctoring results to instructors.
Latest release:
37 sites
37 downloads
7 fans

Overview

Moodle proctoring and identity verification brought to you by Integrity Advocate. The Integrity Advocate proctoring plugin for Moodle installs in minutes and saves you hours of support emails. Using our proprietary hybrid AI and human powered participation monitoring, we deliver a fast, easy and secure environment that is truly GDPR compliant because it doesn't store any unnecessary data.

Integrity Advocate is for online proctoring, identity verification and participation monitoring. You can use it to confirm learner identity, to ensure learner participation during course viewing and/or as an online exam proctor. Integrity Advocate is activated by the learner accepting a privacy policy, participation rules (customizable), giving access to their webcam/mic as well as to the monitoring of their screen activity (optional).

Use of this plugin requires purchasing a paid service - please visit Integrity Advocate to get the credentials needed to be able to use this plugin.

The Integrity Advocate plugins allow Moodle to show a proctoring interface to students, interact with the Integrity Advocate service, and show monitoring results to instructors.

The Integrity Advocate block plugin can be added to Moodle activities and makes the Integrity Advocate proctoring interface show up for students, and gives instructors a way to view Integrity Advocate results. See also What are Moodle blocks?

The Integrity Advocate restrict access plugin can be added to a Moodle activities and prevents access to activities and resources depending on the Integrity Advocate results in another activity. It requires the Integrity Advocate block plugin. See also What are activity restrictions?

Support

Please visit Support for Integrity Advocate.

Integrity Advocate provides both administrator (support@integrityadvocate.com) and end-user (learner) support 24/7/365 via chat, email, phone and through an online support portal.

A nice feature is that the Integrity Advocate App will automatically change its language to that of the user's browser settings (over 64 languages supported).

Bugs / Issue Tracker

We welcome reports of bugs, code contributions via the Bitbucket repos for block_integrityadvocate and availability_integrityadvocate.

We take privacy and security seriously. Any security issues can most responsibly be disclosed to admin@integrityadvocate.com

Privacy

This plugin does not store any data in Moodle. In order to function properly, this plugin sends data to the Integrity Advocate API. This data includes:

  • User: full name, email, Moodle user id number;
  • Enrolment: course-module id;
  • Video session: identification card image, session start, session end, video of the user completing the activity;
  • Override: override date, overrider full name, override reason, override status.

This info is sent using 256-bit encryption (the same used by major financial institutions), meaning your data is kept safe and secure. Integrity Advocate also restricts access by insecure web browsers to ensure data security.

Please see the Integrity Advocate Privacy statement for more info. The full privacy policy details and security standards can be provided upon request.

Accessibility

We are proud to offer a solution that accommodates all users, regardless of ability.

  • WCAG 2.0 AA compliant
  • User-friendly and intuitive interface
  • No scheduling required
  • Flexible rule setting
  • Violation override available
  • Continuously tested to ensure accessibility

Requirements for installation

Requirements for students

  • A camera-equipped device with an updated browser (all common browser types supported). An additional benefit is that Integrity Advocate will work on all device types that the Moodle content will work on (laptop, tablet, phone etc).
  • Disable all browser ad blockers (e.g. uBlock) and privacy plugins (e.g. Privacy Badger) - see How to Disable AdBlock on Chrome, Safari, Firefox, Edge or Opera.

Download

There are two components to download and install:

The block can be added to Moodle activities and makes the Integrity Advocate proctoring interface show up for learners, and shows instructors an overview button so they can view IA results. See also What are Moodle blocks?

The optional availability restriction (condition) prevents access to a course module depending on the Integrity Advocate results in another module.

Potential privacy issues

Integrity Advocate, when appropriately applied, can mitigate the majority of the privacy concerns that organizations can face when using monitoring technology. Please see the Privacy section in the Description and/or contact Integrity Advocate for more details.

Useful links

Potential privacy issues

Integrity Advocate, when appropriately applied, can mitigate the majority of the privacy concerns that organizations can face when using monitoring technology. Please see the Privacy section in the Description and/or contact Integrity Advocate for more details.

Screenshots

Screenshot #0
Screenshot #1
Screenshot #2

Contributors

I sell cookies
Mark van Hoek (Lead maintainer)
Scott Dellinger: Administrator
Darcy Chalifoux: Owner
Leah MacDermid: Account Manager
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Fri, Jan 31, 2020, 11:30 AM
    Approval issue created: CONTRIB-7967
  • Mon, Nov 9, 2020, 9:37 PM
    After installing in Moodle 3.9 I can't add any activity or resource and can't edit an existing one (page is not responding). Are you familiar with this kind of behavior after installing this block in Moodle 3.9?
  • I sell cookies
    Tue, Nov 10, 2020, 2:13 AM
    Hi Miki - Thanks for your query. I sent a note to your email asking for more information.
  • Tue, Jul 6, 2021, 9:42 PM
    When I installing this to 3.6. I got this error. Exception - syntax error, unexpected '?
    I am stuck
  • I sell cookies
    Wed, Jul 7, 2021, 9:53 PM
    Hi nadeerag! PHP 7.2 or higher is required for this plugin.
Please login to post comments