Blocks: Help Desk

block_helpdesk
Maintained by Picture of Jonathan DoaneJonathan Doane, Picture of Matt OquistMatt Oquist, Picture of David ZahareeDavid Zaharee, Picture of Jérôme MouneyracJérôme Mouneyrac
Moodle help desk block to facilitate technical support within Moodle.
272 sites
171 downloads
20 fans

Screenshots

Screenshot #0

Contributors

Picture of Jonathan Doane
Jonathan Doane (Lead maintainer)
Picture of Matt Oquist
Matt Oquist: Developer
Picture of Jérôme Mouneyrac
Jérôme Mouneyrac
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Picture of Andrew Earley
    Thu, Oct 8, 2015, 5:53 PM
    Hello, I am getting a dmlreadexception error and cannot succeed in finding the syntax error.
    The Debug information that is provided is as follows:
    Debug info: Incorrect syntax near 'LIMIT'.

    SELECT CAST('u-' AS NVARCHAR(255)) + CAST(u.id AS NVARCHAR(255)) AS id,
    u.id AS userid, hu2.id AS hd_userid, u.email, u.firstname, u.lastname,
    COALESCE(u.phone1, u.phone2) AS phone, '' AS type

    FROM mdl_user AS u
    LEFT JOIN mdl_block_helpdesk_hd_user AS hu2 ON hu2.userid = u.id
    WHERE u.deleted = 0


    ORDER BY firstname
    LIMIT 20
    OFFSET 0
    [array (
    )]
    Error code: dmlreadexception
    Stack trace:
    line 443 of /lib/dml/moodle_database.php: dml_read_exception thrown
    line 242 of /lib/dml/mssql_native_moodle_database.php: call to moodle_database->query_end()
    line 724 of /lib/dml/mssql_native_moodle_database.php: call to mssql_native_moodle_database->query_end()
    line 758 of /lib/dml/mssql_native_moodle_database.php: call to mssql_native_moodle_database->get_recordset_sql()
    line 278 of /blocks/helpdesk/userlist.php: call to mssql_native_moodle_database->get_records_sql()
  • Picture of Andrew Earley
    Wed, Oct 14, 2015, 9:04 PM
    Hello, my issue is that we run with T-SQL, LIMIT and OFFSET are not accepted terms.
  • Picture of Chris Miller
    Mon, Dec 7, 2015, 11:50 PM
    Does this work with 2.9?
  • Picture of Ranjana Verma
    Tue, Dec 22, 2015, 1:44 AM
    Same question as above - Does this run with Moodle 2.9?
    Ranjana
  • Picture of Franky Just
    Tue, Feb 2, 2016, 9:56 PM
    Hello, I've tested this but ran in same issues as above. Users don't see the block, the rights are set to allow everything, but nothing helps. And there seems a lack of documentation. I think the block could be very useful, when it would be working...
  • Picture of Daniel Neis Araujo
    Wed, Feb 24, 2016, 6:27 AM
    Hello,

    I am using the last version from git and it works on 2.9 although guests are not able to create tickets.

    Also, I would like to translate it to brazilian portuguese, but it is not available on AMOS for any Moodle version or language.

    Kind regards,
    Daniel
  • Ricardo Caiado
    Fri, Jun 17, 2016, 8:11 PM
    Is this plugin still being supported?
  • Ricardo Caiado
    Wed, Dec 7, 2016, 8:27 PM
    Any upgrade to Moodle 3.2?
  • Picture of Kees Koopman
    Sat, Dec 24, 2016, 2:41 AM
    I use Helpdesk with Moodle version 3.1.3 without problems. I hope this plugin gets an update to Moodle 3.2.
  • Picture of Ian Williams
    Fri, Mar 24, 2017, 6:37 PM
    I attempted to install moodle version 3.1.1. Although the report was that the installation was succesful, further access to the site administration pages continuously timed out. As a result I was forced to un-install Helpdesk. Are there any plans to update the code to support versions of Moodle?
  • Picture of suhaida m.sood
    Wed, Aug 30, 2017, 1:25 PM
    Hi everyone,
    I want to use cloze questions for my quiz. however the q does not have space for the students to fill in their answers. nothing wrong inthe setup of the questions.

    what the students see is this:
    You are considering two investment options. In option A, you have to invest RM5,000 now and RM500 three years from now. In option B, you have to invest RM3,500 now, RM1,500 a year from now, and RM1,000 three years from now. In both options, you will receive four annual payments of RM2,000 each. (You will get first payment a year from now.) Which of these options would you choose based on
    (a) the conventional payback criterion, and
    (b) the present worth criterion, assuming 10% interest?
    Please round up to 0 decimal point.

    Answers:
    (a) Based on payback period: Option qtypemultianswer1marker with qtypemultianswer2marker years.
    (b) Based on PW analysis at 10%: Option qtypemultianswer3marker, with PW of RM Answer
  • Picture of Mack Soneh
    Thu, Jun 20, 2019, 6:29 AM
    Hi Everyone!
    I want to install the latest version off GIT, like Daniel did. Is there a procedure available to download a release package from GIT and install on Moodle?
    Thanks,
    Mack
  • Picture of Gary Newport
    Fri, Nov 8, 2019, 7:49 PM
    Is this still a live plugin?
  • Picture of Louise Fullard
    Thu, Jan 23, 2020, 4:17 PM
    please help me. I tried download plugin yesterday - it asked to fix errors - after that i cannot work on my moodle site. it is stuck. shows errors and when i go down to bottom - registry configuration summary - it takes me back to my site - but i cannot do anything further. it goes back to the error as soon as i click on any bars ons left side (site admin, etc).
    please, i am stuck and cannot get anyone to help in this regards.
    louise
  • Picture of Leonardo Freitas da Silva Pereira
    Thu, Jan 30, 2020, 11:36 PM
    Hi devs,
    The language package for this plugin is not available at lang.moodle.org
1 2 3 4
Please login to post comments