Grade Me

Blocks ::: block_grade_me
Maintained by Tyler Bannister, Logan Reynolds, James McQuillan
Shows a teacher all of the assignments and manual quiz questions (essays and file responses) that have been submitted, but not graded.
Latest release:
2677 sites
954 downloads
140 fans

Shows a teacher all of the assignments and manual quiz questions (essays and file responses) that have been submitted, but not graded. The block is configured to work with groups that is, teachers will only see the assignments submitted by students if they are both members of the same group. You'll have to let me know if it works with courses that don't use groups at all. You can install the block on the Front Page and it will show ungraded assignments for ALL courses, and if you put the block on a course page it will only show the ungraded assignments for that course.

Screenshots

Screenshot #0

Contributors

Tyler Bannister (Lead maintainer): Maintainer
Logan Reynolds: Maintainer
James McQuillan: Maintainer
Dakota Duff: Original Developer
Tim Gus: Contributor
Linda Vanderbaan: Contributor
Arnie Murdock: Director
Please login to view contributors details and/or to contact them

Comments RSS

Show comments
  • Fri, Aug 20, 2021, 3:31 PM
    I love this plugin, and have it working superbly on many different Moodles - however I am having problems getting it to work on a Moodle Workplace installation. It works for me as the admin (even if I change my role to tutor), but it doesn't work for the other tutors (in that it shows 'nothing to grade' even when there are things to grade). My guess is that it is connected to our use of tenancies - e.g. the tutor isn't in the same tenancy as the student - which in turn is affecting the visibilty. The tutor can see and mark the students work fine, even though they are not in the same tenancy, and the tutor and students are in the same group within the course, so that is as you would expect.

    Has anyone got this plugin working with Moodle Workplace (especially if using tenancies) - and if yes, what do I need to do?
  • Mon, Aug 30, 2021, 5:25 AM
    I like this plugin. How can I present only current year assignments and manual quiz questions to be graded, and hide previous years? Apparently, many teachers have old ungraded tasks that fill up the list. This is exactly the reason we wanted to use this plugin - to avoid pileup of old ungraded assignments .
  • Mon, Sep 20, 2021, 8:10 PM
    I am working with moodle 3.10.4 ¿is the latest grade_me version ok for this moodle version?. Thanks.
  • Mon, Sep 20, 2021, 8:19 PM
    Works fine even with Moodle 3.11.3
    No issues with this plugin.
  • Tue, Sep 21, 2021, 9:17 PM
    I've just tried to install the latest version of this plugin in Moodle 3.10.4 using moosh and then a message appears: "This plugin is not supported for your Moodle version"
    If I insist using -f to force this installation, the plugin appears as disabled at the pluginlist.
    How can i work with this plugin and Moodle 3.10.4?
  • Tue, Sep 21, 2021, 9:47 PM
    Check plugin conflict with another plugin. Been using this same plugin on Moodle 3.10 and now 3.11 - never have an issue.
  • Tue, Sep 21, 2021, 10:50 PM
    I can't even install that version of the plugin on moodle 3.10.4. How do you install that on Moodle 3.10? I've jast tryed with zip file too and I have not been able either
  • Thu, Sep 23, 2021, 7:06 PM
    I have uninstalled all the additional plugins to avoid conflicts, but still, when I force-install the latest version of block_grade_me in Moodle 3.10.4 it appears as disabled and there is no option to enable it.
    I am very interested in using this plugin with Moodle 3.10.4, any help please?
  • Thu, Sep 23, 2021, 10:52 PM
    Hi Cristina, Grade Me block is fully supported on Moodle 3.10 and should install normally through the regular install process. I would try installing with the standard method via the UI or via the command line using "/admin/cli/upgrade.php --non-interactive", as I've occasionally had problems installing/uninstalling plugins using Moosh in the past. If you're still running into problems please file a bug in our issue tracker on GitHub and include all steps to reproduce the problem, including:
    * Moodle version in question (sounds like Moodle 3.10.4)
    * OS you're installing on and version number (i.e. Windows 10, Centos 7, etc.)
    * Database platform you're running on and version (i.e. MariaDB 10.6, Oracle 19c, etc.)
    * Any other specific steps you're taking to copy the code into the web directory and proceed with install (i.e. just so we have a sense for your usual process of installing plugins.)
  • Sat, Sep 25, 2021, 2:50 AM
    Hi Cristina, did you try Site Admin > Pllugins > Manage Blocks?
  • Mon, Sep 27, 2021, 5:37 PM
    Hi Johny Lo, when I force-intall and it appears as disabled, it does not appear in the list of Manage Blocks so I can't activate from there. Thanks.
  • Mon, Sep 27, 2021, 7:10 PM
    Used it on Moodle 3.9, 3.10 and now on 3.11. Never had a issue like this. Must be the site specific.
  • Mon, Sep 27, 2021, 7:25 PM
    Hi Logan, I have retested the installation in the regular way from UI and here I have two options:
    1. If I download the zip and upload it to the server (which is one of the ways as I was trying last week) then a validation error occurs when loading the .zip:
    [OK] External module version [2021051700]
    [Error] Moodle version required [2021051700]
    2. If I install from the moodle extensions directory (by clicking that button) then it does install correctly but "tricking" the system a bit, modifying the moodle version in the list of my sites to 3.9, then it does install but the version 2020061502 (3.9.0.2) and not the latest one (3.11.0.0). If in the same way I modify the version of my moodle to 3.11 in the list of my sites, it also does not install the latest version of the plugin, appearing the same error as in the case of zip.

    Do you know if there is a problem using version 3.9.0.2 of the plugin with a moodle 3.10.4?
    The fact is that I need to do the installation in several moodles, so I would prefer to do it via moosh to automate. Thanks a lot.
  • Sat, Oct 23, 2021, 9:24 AM
    Hi Cristina,

    You should be able to run the Moodle 3.9 version on Moodle 3.10 with no problems, provided that you have correct, unmodified version values which have not been changed in the site and plugin's version.php files. Noting that you should never manually modify these version values in version.php, as doing so can cause problems with the site and future upgrades of both plugins and the core site.
  • Mon, Nov 1, 2021, 11:11 AM
    I use Moodle 4.0dev and it doesn't work. Is there any plan for a new version of grade me for 4.0
Please login to post comments